No announcement yet.

AMD A6-3400M not working on Linux kernel 3.0

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by sandy8925 View Post
    so radeon.modeset=0 won't work?
    That is correct.


    • #12
      Originally posted by sandy8925 View Post
      problem is i can't see anything on booting the live CD, so can't install ubuntu 11.10. i might be able to install using the alternate iso and then I can try changing grub settings.
      I was successfull booting with the SystemRescueCD from gentoo.

      I have booted the special amd64 system all in memory and I had a display & a keyboard from where to start.
      I have started X with the wizard and I had a basic screen with xfce I think.

      I was also able to boot from a Ubuntu 11.04 natty narwal amd64 cd but I haven't installed since I was only trying to access the disk to put my funtoo stage3 data to start a funtoo install.




      • #13
        Originally posted by sandy8925 View Post
        I'm using Ubuntu 11.04 64-bit version.
        Tried compiling kernel 3.0.4 and used the 3.0 kernel from xorg-edgers and neither of them work. No display on screen although the system does seem to be loading. This is on the Asus K53TA-BBR6 laptop.
        Haven't tried newer kernel versions since is down.

        On Fedora 15 64-bit with latest updates and 2.6.40 kernel, also not working.

        2.6.38 kernel uses VESA for both distros.
        I have this exact system, and i got it working on Sabayon linux 6.0. However, it is worth noting that I have it fully updated ( using catalyst 11.8 ) and that for the initial setup i used the vesa graphics drivers for initial setup. However, this should be working fine on this system after all updates are applied for the open source drivers.


        • #14
          I've got an A8-3850 that had a similar problem when it updated the Xorg Server under fedora (because I was too lazy at that point to put in the work to get Slackware running on it), So I went back and put slackware on it, and got it into a working position by blacklisting the radeon module and compiling the 3.0.4 kernel which it's running now, which works fine with fglrx.


          • #15
            Originally posted by bridgman View Post
            I think the A-series is a bit too new for even Ubuntu 11.04. Try an 11.10 beta or the equivalent work-in-progress Fedora.

            Updating the kernel gets you closer but you need to pick up new microcode as well. If you look in dmesg output you'll probably see messages along the lines of "can't find SUMO firmware"
            Actually, it really has nothing to do with that. Linux 3.0 has a regression where VGA (including the laptop monitor) won't turn on after the initial splash screen. I know it applies to all Llano systems, and possibly others. I have the same laptop, it works fine out of the box with 2.6.38/Ubuntu 11.04 (except for needing Catalyst for 3d). It also works in 11.10 beta if I plug the HDMI port into a monitor before I turn the laptop on, and it even has 3d acceleration with the FOSS driver. I could then install the Catalyst driver using HDMI/monitor and (supposedly) have a working system, but I haven't tried it yet.
            Last edited by nepwk; 09-22-2011, 09:03 PM. Reason: oops....


            • #16
              Originally posted by nepwk View Post
              Linux 3.0 has a regression where VGA (including the laptop monitor) won't turn on after the initial splash screen.
              3.0 was the first kernel with llano GPU support in radeon. Presumably anything prior to that used vesa.


              • #17
                The open-source Llano support in 3.0 is a new feature which isn't yet working fully OK, but it is already enabled by default, replacing the Vesa driver. This is why it seems a regression.


                • #18
                  Originally posted by PerfMonk View Post
                  I have the same board AMD a6-3400m with a Radeon ATI hd 6520.
                  I'm on Funtoo (based on gentoo) with the 3.1.0-rc4-git2 kernel, and masked versions of Xorg and video drivers, libdrm, libkms, mesa, ...).
                  What CFLAGs do you use for your system?



                  • #19
                    I should clarify that I was talking about the open source drivers. Laptop works fine with fglrx in Ubuntu 11.04 and probably will in Ubuntu 11.10. The problem is that I can't even install ubuntu 11.10 using the desktop live dvd since it tries to use the open source drivers and no display comes up. Will try with beta 2 dvd that was released recently.


                    • #20
                      Originally posted by jasn View Post
                      What CFLAGs do you use for your system?

                      Here is my "make.conf" ;

                      FEATURES="-userfetch mini-manifest"
                      CFLAGS="-O2 -march=amdfam10 -pipe"
                      MAKEOPTS="-j5 -l5"
                      USE="-gnome -gtk -kde -kdeenablefinal nls -q3 -qt4 userlocales libkms classic gallium nptl bindist ldap"
                      INPUT_DEVICES="keyboard mouse evdev synaptics"
                      VIDEO_CARDS="vesa radeon r600"
                      PORTAGE_ELOG_CLASSES="log warn error info"
                      PORTAGE_ELOG_SYSTEM="echo:log,warn save:log,warn,error,info, syslog:error"

                      ACCEPT_LICENSE="* [email protected]"

                      source /var/lib/layman/make.conf


                      I took off the "d3d" use flag because of problem with the compilation of mesa. It wouldn't compile at all... And I didn't feeled I wanted to spend a week of my time on it.
                      Be carefull to set your kernel options as recommanded at :

                      But I have installed a second distro "ubuntu 11.04" with the latest git sources for the video drivers
                      see :

                      But I had exactly the same problem I have with funtoo : libdrm doesn't see KMS as enabled and the driver won't load.

                      I have installed the closed drivers from ATI and It work well with Ubuntu 11.04. I'm waiting to do it on funtoo because I don't wan't to goback to an old kernel and an old Xorg...