Announcement

Collapse
No announcement yet.

Heroes of Newerth performance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    ATi blobs are nasty unfortunately - they have vastly improved but still have issues

    A couple of things you can try

    #1
    Code:
    cat /proc/mtrr 
    reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
    reg01: base=0x080000000 ( 2048MB), size= 1024MB, count=1: write-back
    reg02: base=0x0c0000000 ( 3072MB), size=  512MB, count=1: write-back
    reg03: base=0x100000000 ( 4096MB), size= 4096MB, count=1: write-back
    reg04: base=0x200000000 ( 8192MB), size=  512MB, count=1: write-back
    Generally you shouldn't have any un-cachable entries.

    #2
    Code:
    newx() { DISPLAY=:1.0; xinit $* -- :1; }; newx /opt/HoN/hon.sh
    and redo those ingame tests

    #3 disable the composite xorg extension

    Comment


    • #12
      60 fps most of the time
      some big action drops to 30 or so
      all max graphics except shadows.

      1280x960 windowed

      amd 6000+ 3ghz, 6gig ddr2 800mhz, ati 5770 (fglrx 11.5-11.8), Linux Mint 11, compiz on

      no probelems noticed with performance

      Comment


      • #13
        So this is what I do to get good fps in HoN with my 4650.

        I am running Ubuntu 11.04, but it should generalise well.

        1. You have to deactivate vsync completely through amdcccle. (3D -> more settings -> set vsync = performance)

        2. You will get a fps boost if you make compiz/kwin to use "undirect rendering when fullscreen" or even better, deactivate compositing.

        Thats it. I get good fps with highest settings.
        Last edited by tball; 08-31-2011, 01:30 AM.

        Comment


        • #14
          New Xserver thingy was one of first ideas i've tried .. composite suspend as well. Im not using OGL composition at all, i use Xrender (and disable it on demand while gaming). Vertical sync and tearfree is disabled, still - framerate suck. If you guys say it works on HD5xxx, couldnt it be just R700 (and older?) issue?
          Can you guys try to change effects to see how big is impact on framerate (if any)? In my case framerate changes from low to high is like 10 FPS (if there is any change at all).
          Its interesting as lot of people reported same behavior on HoN forums but here it seems to be otherwise. Any more ideas what could be wrong?

          Comment


          • #15
            Originally posted by Schmaker View Post
            New Xserver thingy was one of first ideas i've tried .. composite suspend as well. Im not using OGL composition at all, i use Xrender (and disable it on demand while gaming). Vertical sync and tearfree is disabled, still - framerate suck. If you guys say it works on HD5xxx, couldnt it be just R700 (and older?) issue?
            Can you guys try to change effects to see how big is impact on framerate (if any)? In my case framerate changes from low to high is like 10 FPS (if there is any change at all).
            Its interesting as lot of people reported same behavior on HoN forums but here it seems to be otherwise. Any more ideas what could be wrong?
            How about: you have obsolete hardware?

            Seriously, come on. If you're a real gamer, you should at least have a Core 2 system, if not a Nehalem. 2 gigs of RAM is obsolete these days. It's time to upgrade.

            Unfortunately, GPU drivers need a lot of system memory bandwidth, and a game like HoN also eats a lot of CPU. Your graphics card should be sufficient to get good FPS, but your core system paths (FSB, RAM, CPU) are going to be ass slow on a dual-core Pentium 4. You're probably still using DDR2, aren't you?

            I can get solid 60 FPS in HoN with Catalyst, with tear-free and VSync enabled and all settings maxed out, no problem at all. And I don't even have a crazy high-end system with a $1000 CPU and 32GB of RAM. No, I just have a merely average gaming machine: Core i7 920, 6GB DDR3 @ 1066 MHz, and a Radeon HD5970. The GPU is a bit of overkill, but only one of the GPUs gets used on Linux anyway, so think of it as a HD5850 (the cores are clocked at the same speed as a 5850).

            The reason I can get that FPS is that I have the bus bandwidth and memory bandwidth to move huge amounts of data. The game demands no less.

            And don't go saying that the system requirements for HoN says this and that. The system requirements are what you need to start the program without crashing. They imply nothing about getting performance that is actually enjoyable. These days, system requirements are almost always lowballed to the point that, if you have a system that's at the Recommended level, you will get about 10 FPS. For the requirements that most game developers list, you have to significantly exceed the Recommended requirements to get smooth (consistent 30+ fps) gameplay.

            That said, I have noticed that I can get smoother (but not necessarily higher) FPS with an up-to-date r600g than Catalyst. YMMV. On the flip side, the top-end framerate you can reach with Catalyst is much higher than r600g, because there are some bottlenecks in the open source graphics stack. If you have fast, recent hardware, you can easily top 100 fps with Catalyst and VSync off -- not true with r600g.

            Comment


            • #16
              Originally posted by allquixotic View Post
              Unfortunately, GPU drivers need a lot of system memory bandwidth, and a game like HoN also eats a lot of CPU. Your graphics card should be sufficient to get good FPS, but your core system paths (FSB, RAM, CPU) are going to be ass slow on a dual-core Pentium 4. You're probably still using DDR2, aren't you?
              FYI, the e2180 is an Allendale (a Core 2 with less L2 cache), not a P4.

              Comment


              • #17
                Originally posted by Schmaker View Post
                New Xserver thingy was one of first ideas i've tried .. composite suspend as well. Im not using OGL composition at all, i use Xrender (and disable it on demand while gaming). Vertical sync and tearfree is disabled, still - framerate suck. If you guys say it works on HD5xxx, couldnt it be just R700 (and older?) issue?
                Can you guys try to change effects to see how big is impact on framerate (if any)? In my case framerate changes from low to high is like 10 FPS (if there is any change at all).
                Its interesting as lot of people reported same behavior on HoN forums but here it seems to be otherwise. Any more ideas what could be wrong?
                As I said. I have no issues running HoN on my HD4650. And thats on a laptop.

                Comment


                • #18
                  Originally posted by allquixotic View Post
                  How about: you have obsolete hardware?
                  To be fair, Qaridarium gets similar results with a recent quad core. Recommended hardware for HoN lists a Radeon X1900 GPU.

                  Originally posted by allquixotic View Post
                  No, I just have a merely average gaming machine: Core i7 920, 6GB DDR3 @ 1066 MHz, and a Radeon HD5970.
                  Heh I wish MY rig was as "average" as yours :P

                  Comment


                  • #19
                    You guys really dont have idea how much i would like to have nVidia graphic card here as well to show you performance gap between those two. I just set details to lowest i could to get crazy 45 FPS (nothing more i can beat from 4670?! in fight its like 20~30 FPS). Game looks like 10 year old, but its a little bit more playable. Lets get objective again now.
                    It feels like just some cards are affected by this performance issue. Maybe Michael could be usefull now as he could make a HoN benchmark into Phoronix Test Suite?

                    Comment


                    • #20
                      I have Intel i3 processor, with hd5470 amd card. Running on Ubuntu 11.04 with catalyst 11.7. Dont sure what fps exactly is, but i can play without any lags, sometimes in big fights in have some performance issues but not critical. Settings are set to Mid->High. Also i prefer closing other programs(especially after firefox 6 update, causing some huge memory leaks for me, even when only firefox is running). But in overall - everything is working fine. BTW i have 2 video card in my laptop because of i3 processor.

                      Comment

                      Working...
                      X