Announcement

Collapse
No announcement yet.

How to enable hyper-z on R500?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to enable hyper-z on R500?

    How to? is RADEON_HYPERZ=1 enough?
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

  • #2
    OMG, yes it's enough, +50% in openarena and perfect rendering
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

    Comment


    • #3
      Where do you pass that argument? Can you write in into .drirc?

      Comment


      • #4
        Put
        Code:
        RADEON_HYPERZ=1
        into ~/.bashrc

        Actually my X1950XTX beats an HD6870 in world of padman with hyperz enabled
        Benchmarks will follow
        ## VGA ##
        AMD: X1950XTX, HD3870, HD5870
        Intel: GMA45, HD3000 (Core i5 2500K)

        Comment


        • #5
          Its not so that on older cards only one App can use HyperZ?

          Comment


          • #6
            Wasn't this almost finished for r600+ too? Or at least somebody was working on it and it was relatively advanced?

            This plus texture tiling and 2d colour tiling would make a huge impact on r600+ cards. We'd be really close to Catalyst.

            Comment


            • #7
              Why are most interesting features are disabled and hidden in open drivers? I didn't know hyperz was finished. By the way, which level of hyperz we are talking about? (or are they handled by hardware and driver only turns compression on?)

              Comment


              • #8
                http://openbenchmarking.org/result/1...DARK-110717430

                Hyperz does help alot, the rendering was perfect except Smokin Guns and Tremolous which had problems. With another openarena timedemo I reached a nearly 50% boost.
                World of padman is just impressive with R300g

                I was testing R600g too but my Sandy Bridge system does not want to start anymore: ram led blinks, it doesn't matter if I use one or both the banks or if I change the slots, I even tried another PSU
                ## VGA ##
                AMD: X1950XTX, HD3870, HD5870
                Intel: GMA45, HD3000 (Core i5 2500K)

                Comment


                • #9
                  r600 hyperz appears stalled, but the bug to follow is https://bugs.freedesktop.org/show_bug.cgi?id=36602

                  @crazycheese

                  It's hidden and off by default because it isn't finished :P

                  Comment


                  • #10
                    Originally posted by curaga View Post
                    It's hidden and off by default because it isn't finished :P
                    Yep. I think the usual protocol is roughly :

                    * can cause problems even when disabled : in a branch
                    * code works OK when feature is disabled, works for "some people" but not "most people" when enabled : in master but disabled by default
                    * works for most people : enabled by default
                    Last edited by bridgman; 17 July 2011, 02:40 PM.

                    Comment

                    Working...
                    X