No announcement yet.

Xorg hardlock; latest libdrm, mesa, xf86-video-ati, xorg-server 1.10.2

  • Filter
  • Time
  • Show
Clear All
new posts

  • Xorg hardlock; latest libdrm, mesa, xf86-video-ati, xorg-server 1.10.2

    Hi guys,

    since several days I'm easily getting hardlocks when having

    compiz-fusion (0.8.4/0.8.6) enabled with emerald and by simply browsing through the web

    e.g. just now I got a hardlock with browsing through kernel source directories on github

    last time it was during app-switching (alt + tab)

    magic sysrq key doesn't work anymore the box seems to be completely dead

    gentoo ~amd64

    Portage 2.2.0_alpha34 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, x86_64)
    ================================================== ===============
    System uname: [email protected]_2.80GHz-with-gentoo-2.0.2
    Timestamp of tree: Tue, 14 Jun 2011 20:15:01 +0000
    ccache version 3.1.4 [disabled]
    app-shells/bash: 4.2_p8
    dev-java/java-config: 2.1.11-r3
    dev-lang/python: 2.6.6-r1, 2.7.1-r1, 3.1.3-r1
    dev-util/ccache: 3.1.4
    dev-util/cmake: 2.8.4
    sys-apps/baselayout: 2.0.2
    sys-apps/openrc: 0.8.2-r1
    sys-apps/sandbox: 2.5
    sys-devel/autoconf: 2.13, 2.68
    sys-devel/automake: 1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
    sys-devel/binutils: 2.20.1,, 2.21,,,,,
    sys-devel/gcc: 4.3.5, 4.4.4-r1, 4.4.5, 4.5.1-r1, 4.5.2-r1:ortage
    sys-devel/gcc-config: 1.4.1
    sys-devel/libtool: 2.4-r1
    sys-devel/make: 3.81-r2:ortage
    sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
    sys-libs/glibc: 2.13-r2

    live builds of:
    - libdrm
    - mesa
    - xf86-video-ati

    xorg-server 1.10.2 and (also happened with that)

    afaik this started when I had watched a video with flash in fullscreen a few days ago (I wanted to see if things had improved) and everything seemed to be dead by the sound of the video kept on playing (no loop !)


    - usb keyboard + mouse affected
    - screen output affected (monitor -> black/blank)

    any help would be highly welcome since I need this box working with composite asap

    Many thanks in advance !

  • #2
    ok seems like it works again:

    - compiled the kernel + added newer radeon-ucode (20110531)
    - re-compiled all the mentioned packages
    - freshly re-installed adobe-flash

    and it didn't crash so far with fullscreen flash

    also did some app-switching, etc.




    • #3
      oh CRAP !

      it's happening again :\

      several hours of stable usage and then suddenly it hardlocked again while surfing with chromium through github

      something's definitely not cool


      • #4
        just had the following softreset if it's useful

        [ 915.061258] radeon 0000:01:00.0: GPU lockup CP stall for more than 747313msec
        [ 915.061262] ------------[ cut here ]------------
        [ 915.061285] WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:246 radeon_fence_wait+0x39e/0x400 [radeon]()
        [ 915.061289] Hardware name: ipower G3710
        [ 915.061292] GPU lockup (waiting for 0x00008CA2 last fence id 0x00008C9D)
        [ 915.061295] Modules linked in: iptable_filter xt_NFQUEUE xt_DSCP xt_owner xt_hashlimit xt_dscp xt_iprange xt_conntrack xt_mark xt_multiport xt_connmark nf_conntrack xt_string ip_tables x_tables it87 hwmon_vid coretemp snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss radeon ttm drm_kms_helper cfbcopyarea cfbimgblt cfbfillrect snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd e1000e wmi i2c_i801 soundcore snd_page_alloc libphy e1000 auth_rpcgss lockd sunrpc scsi_wait_scan sl811_hcd ohci_hcd ssb usb_storage ehci_hcd [last unloaded: nfs_acl]
        [ 915.061350] Pid: 6830, comm: X Not tainted #2
        [ 915.061353] Call Trace:
        [ 915.061362] [<ffffffff8104f6fb>] ? warn_slowpath_common+0x7b/0xc0
        [ 915.061368] [<ffffffff8104f7f5>] ? warn_slowpath_fmt+0x45/0x50
        [ 915.061385] [<ffffffffa02d2b3e>] ? radeon_fence_wait+0x39e/0x400 [radeon]
        [ 915.061393] [<ffffffff8106b760>] ? wake_up_bit+0x40/0x40
        [ 915.061401] [<ffffffffa0222f4d>] ? ttm_bo_wait+0x10d/0x1c0 [ttm]
        [ 915.061419] [<ffffffffa02ebfef>] ? radeon_gem_wait_idle_ioctl+0x8f/0x110 [radeon]
        [ 915.061425] [<ffffffff8143630c>] ? drm_ioctl+0x3bc/0x480
        [ 915.061432] [<ffffffff8138a3c8>] ? prio_tree_insert+0x148/0x2a0
        [ 915.061450] [<ffffffffa02ebf60>] ? radeon_gem_busy_ioctl+0x140/0x140 [radeon]
        [ 915.061456] [<ffffffff810d0d58>] ? mmap_region+0x1e8/0x540
        [ 915.061463] [<ffffffff810fea06>] ? do_vfs_ioctl+0x96/0x500
        [ 915.061467] [<ffffffff810feeb9>] ? sys_ioctl+0x49/0x80
        [ 915.061475] [<ffffffff816b41fb>] ? system_call_fastpath+0x16/0x1b
        [ 915.061478] ---[ end trace 3b4bbf99fc48bf77 ]---
        [ 915.062673] radeon 0000:01:00.0: GPU softreset
        [ 915.062677] radeon 0000:01:00.0: GRBM_STATUS=0xA0003828
        [ 915.062680] radeon 0000:01:00.0: GRBM_STATUS_SE0=0x00000007
        [ 915.062684] radeon 0000:01:00.0: GRBM_STATUS_SE1=0x00000007
        [ 915.062688] radeon 0000:01:00.0: SRBM_STATUS=0x200000C0
        [ 915.062710] radeon 0000:01:00.0: GRBM_SOFT_RESET=0x00007F6B
        [ 915.062816] radeon 0000:01:00.0: GRBM_STATUS=0x00003828
        [ 915.062819] radeon 0000:01:00.0: GRBM_STATUS_SE0=0x00000007
        [ 915.062823] radeon 0000:01:00.0: GRBM_STATUS_SE1=0x00000007
        [ 915.062826] radeon 0000:01:00.0: SRBM_STATUS=0x200000C0
        [ 915.063832] radeon 0000:01:00.0: GPU reset succeed
        [ 915.142044] radeon 0000:01:00.0: WB enabled
        [ 915.158636] [drm] ring test succeeded in 1 usecs
        [ 915.158644] [drm] ib test succeeded in 1 usecs

        the reset doesn't seem to work correctly

        the fan of the PC is spinning faster and louder constantly after the reset

        even though it's set to "low" profile the fan is spinning faster

        so the "fix" so far for this little "issue" was to set it to "mid" and then back to "low"

        echo mid > /sys/class/drm/card0/device/power_profile

        cat /sys/class/drm/card0/device/power_profile

        -> mid

        echo low > /sys/class/drm/card0/device/power_profile

        cat /sys/class/drm/card0/device/power_profile

        -> low
        Last edited by kernelOfTruth; 06-17-2011, 09:37 AM.


        • #5
          I reported something like that three months ago (it hasn't been fixed). Maybe it's the same issue:

          For me, disabling page flipping prevents this from happening.


          • #6
            If it's pageflipping related, this patch should fix the issue:


            • #7
              Originally posted by agd5f View Post
              If it's pageflipping related, this patch should fix the issue:
              I hoped it would, but unfortunately, it doesn't.


              • #8
                Hi Dave,

                it definitely seems to be related to pageflipping

                I disabled it and it's smooth sailing for several hours already

                will try out your patch when I find some time

                thanks !


                • #9
                  Segfault and lock-ups

                  This might not be a similar issue, but I'm facing Segfaults using xorg-edgers repository on Xubuntu. This always occurs when the game Extreme Tux Racer is run from the terminal. Has been happening ever since I started using the repo (1 week back) so I can't tell when exactly this started happening in relation to git. I reverted back to stock Xubuntu drm, mesa, radeon driver, xorg and it does not occur, hence I believe this might be a regression.

                  I also get hard lockups frequently, regardless if flash videos are being watched or games are being run. Only solution is to hard reset.

                  Tried to look for logs on the Segfault, but couldn't find anything in Xorg.log, dmesg, kern.log or syslog.

                  I would like to help out identify the bugs but don't have any experience in bug reporting. If instructions can be provided, I am more than willing to help report bugs.

                  Processor: Pentium 4
                  Graphics card: Radeon Xpress 200 - RC410 (assigned 256Mb ram in BIOS)
                  Kernel: 3.0.0-999-generic #201106091205 SMP i686 i686 i386 GNU/Linux

                  xorg.conf settings (tried all variations but didn't help):

                  Option "EnablePageFlip" "True"
                  Option "ColorTiling" "True"
                  Option "SwapbuffersWait" "False"

                  Xorg Edgers packages:

                  libdrm-radeon1: 2.4.26+git20110604.6dd804c5-0ubuntu0sarvatt~natty
                  libdrm2: 2.4.26+git20110604.6dd804c5-0ubuntu0sarvatt~natty
                  libgl1-mesa-dri: 7.11.0+git20110616.fc8c4a3a-0ubuntu0sarvatt~natty
                  libgl1-mesa-glx: 7.11.0+git20110616.fc8c4a3a-0ubuntu0sarvatt~natty
                  libglu1-mesa: 7.11.0+git20110616.fc8c4a3a-0ubuntu0sarvatt~natty
                  libpixman-1-0: 0.21.8-0ubuntu0sarvatt~natty
                  libtxc-dxtn-dev: 1.0.1-0.1~edgers~natty
                  libtxc-dxtn0: 1.0.1-0.1~edgers~natty
                  xserver-common: 2:1.10.2+git20110616+server-1.10-branch.9551f504-0ubuntu0sarvatt~natty
                  xserver-xorg-core: 2:1.10.2+git20110616+server-1.10-branch.9551f504-0ubuntu0sarvatt~natty
                  xserver-xorg-video-ati: 1:6.14.99+git20110613.41eb1fbb-0ubuntu0sarvatt~natty
                  xserver-xorg-video-radeon: 1:6.14.99+git20110613.41eb1fbb-0ubuntu0sarvatt~natty


                  • #10
                    Originally posted by agd5f View Post
                    If it's pageflipping related, this patch should fix the issue:
                    ok, seems like a good point to test out that patch

                    I had disabled pageflipping and colortiling but it still kept on appearing

                    I re-compiled my whole system and the X-server and the video driver

                    but it kept on coming after several days, hours or even minutes - completely random

                    there was sort of a commonality: it very often happened when running chromium and browsing through github

                    so I disabled the gles (opengl ES) switch for mesa

                    and recompiled everything

                    so far it's still running for several hours

                    will see if it was that which caused the hardlocks & keep you updated

                    if not I'll recompile the kernel with your patch

                    Thanks !