No announcement yet.

Open-Source AMD Fusion E-350 Support Takes A Dive

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Things aren't perfect under 3.0, but very usable. I get flickering for some minutes after returning from DPMS sleep, and changing modes with xrandr (tried that to see if it helped the flicker ) corrupts the screen.


    • #62
      That'll be fine for me, I should not use xrandr or DPMS anyway.
      On the whole this platform seems quite nice : fast enough, no noise thanks to a fan-less Asus mobo, perfectly recognized by the Linux kernel apart for this small firmware issue. I'm waiting for twoZotac mini-PC based on this that will make perfect computers for my daughters.
      Thanks again!


      • #63
        CPU Frequency Scaling

        Just for anyone searching I had to go to a 3.0.0 kernel to get CPU frequency scaling to work.

        ASRock E350M1/USB3, WD Scorpio Blue 1Tb, 4gb DDR3 running Linux Mint Debian Edition with Gnome 3.

        3.0 kernel from Debian Experimental. CPU drops back to 800hz most of the time with two steps 1.28ghz and 1.6ghz "On Demand"

        It is in a Antec ISK300-65 case with a 65w brick power supply.

        Pulls 26w at wall for most of the time, maxing out at 33w when working hard with full screen flash.

        FGLRX just does not work with Gnome 3, so until either ATI and/or Gnome solve the issues it is the open source driver all the way.

        Note: CPU frequency scaling worked fine on 2.6.39 under Ubuntu 11.04, it was just Debian where I had to resort to a 3.0 kernel.


        • #64
          Does audio over HDMI work?


          • #65
            HDMI Audio

            Firstly, I am using Debian Testing with Gnome 3. This means using FGLRX is out of the question. Using the open source video driver and pulseaudio I have not got so much as a beep out of the HDMI sound. I do not have an HDMI amp so I have not tried that hard, I only have a Samsung TV to test it on. But, so far, nothing. The onboard optical spdif is plug and play and works just fine. The HDMI video output auto configures to the correct 1920x1080 resolution.

            The bios has settings for turning HDMI and analog audio on and off - but in different menus. The system certainly recognizes that HDMI is there and allows you to select it, just nothing comes out. I tried a few different ideas in /etc/asound.conf, but so far none worked.

            The MythTV forums have a few threads on HDMI audio.

            Maybe with Ubuntu and a bit of homework it might work, but it certainly does not with my setup. Installing the proprietary video driver might help, but to try that would stuff up my system.

            sorry not to have any good news.


            • #66
              HDMI audio is not supported on evergreen or newer asics yet.


              • #67
                I get black screen afret modprobe -av radeon on E-350 board.
                Firmware loaded well, but nothing more, just blackscreen.
                I use 2.6.38 kernel.

                [  208.761365] [drm] Initialized drm 1.1.0 20060810
                [  208.858346] [drm] radeon defaulting to kernel modesetting.
                [  208.858352] [drm] radeon kernel modesetting enabled.
                [  208.858423] radeon 0000:00:01.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
                [  208.858431] radeon 0000:00:01.0: setting latency timer to 64
                [  208.867813] [drm] initializing kernel modesetting (PALM 0x1002:0x9802).
                [  208.867907] [drm] register mmio base: 0xFE000000
                [  208.867910] [drm] register mmio size: 262144
                [  208.868214] ATOM BIOS: AMD
                [  208.868265] radeon 0000:00:01.0: VRAM: 384M 0x0000000000000000 - 0x0000000017FFFFFF (384M used)
                [  208.868271] radeon 0000:00:01.0: GTT: 512M 0x0000000018000000 - 0x0000000037FFFFFF
                [  208.868446] [drm] Detected VRAM RAM=384M, BAR=256M
                [  208.868453] [drm] RAM width 16bits DDR
                [  208.868865] [TTM] Zone  kernel: Available graphics memory: 820394 kiB.
                [  208.868876] [TTM] Initializing pool allocator.
                [  208.868938] [drm] radeon: 384M of VRAM memory ready
                [  208.868988] [drm] radeon: 512M of GTT memory ready.
                [  208.869047] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
                [  208.869054] [drm] Driver supports precise vblank timestamp query.
                [  208.869131] radeon 0000:00:01.0: irq 40 for MSI/MSI-X
                [  208.869145] radeon 0000:00:01.0: radeon: using MSI.
                [  208.869210] [drm] radeon: irq initialized.
                [  208.869220] [drm] GART: num cpu pages 131072, num gpu pages 131072
                [  208.873133] [drm] Loading PALM Microcode
                [  208.905519] radeon 0000:00:01.0: WB enabled
                [  208.922151] [drm] ring test succeeded in 1 usecs
                [  208.922326] [drm] radeon: ib pool ready.
                [  208.922445] [drm] ib test succeeded in 0 usecs
                [  208.953333] [drm] Radeon Display Connectors
                [  208.953339] [drm] Connector 0:
                [  208.953342] [drm]   HDMI-A
                [  208.953345] [drm]   HPD2
                [  208.953349] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
                [  208.953353] [drm]   Encoders:
                [  208.953356] [drm]     DFP1: INTERNAL_UNIPHY
                [  208.953359] [drm] Connector 1:
                [  208.953362] [drm]   VGA
                [  208.953366] [drm]   DDC: 0x64d8 0x64d8 0x64dc 0x64dc 0x64e0 0x64e0 0x64e4 0x64e4
                [  208.953369] [drm]   Encoders:
                [  208.953371] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
                [  209.009294] [drm] Internal thermal controller without fan control
                [  209.009542] [drm] radeon: power management initialized
                [  209.090148] [drm] fb mappable at 0xC0141000
                [  209.090152] [drm] vram apper at 0xC0000000
                [  209.090155] [drm] size 14745600
                [  209.090157] [drm] fb depth is 24
                [  209.090160] [drm]    pitch is 10240
                [  209.090416] fb0: radeondrmfb frame buffer device
                [  209.090419] drm: registered panic notifier
                [  209.090429] [drm] Initialized radeon 2.8.0 20080528 for 0000:00:01.0 on minor 0


                • #68

                  A 2.6.38 kernel is way too old. Mine was working fine with a 3.16 kernel and newish xorg under Linuxmint. I have switched to fglrx for power saving.