No announcement yet.

Need help debugging possible graphics-related crash

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Okay, thank you so far, but my system seems to be seriously screwed up.
    First I removed the git drivers as far as I could by manually removing them from /usr/local. (there wasn't a "make uninstall" option)
    Xorg seems to successfully fall back on the Debian drivers. Games like Chromium still work but with small glitches. And Xorg still crashes.

    Then I removed Section "DRI" in xorg.conf.
    To my surprise, the games still run as fast as if they had direct rendering, although glxinfo says no.
    And the crashes still happen.

    I have no way out, I guess I have to live with it for the time being.
    At least it has become unlikely that the current Mesa driver is responsible.


    • #12
      Okay, so I tried again.
      I deleted my whole /usr/local directory. Finally all traces of the mesa drivers are gone and no longer loaded. My system is now rock solid, as far as I can see. But only 2D.
      Apart from the crashes I fixed another bug this way that caused graphics glitches when I moved areas, for example when a tooltip is opened inside Firefox and I scrolled with the wheelmouse. I decided to investigate further, maybe it was my window manager.

      My previous mesa installation was ages old, so I tried to reinstall the current mesa, this time in /usr/local/xorg, so that I can remove it quickly without destroying other applications I have installed in /usr/local.

      My problem are probably the following messages in Xorg.0.log:
      (EE) AIGLX error: dlopen of /usr/lib/dri/ failed (/usr/lib/dri/ cannot open shared object file: No such file or directory)
      (EE) AIGLX: reverting to software rendering
      (II) AIGLX: Screen 0 is not DRI capable
      (EE) AIGLX error: dlopen of /usr/lib/dri/ failed (/usr/lib/dri/ cannot open shared object file: No such file or directory)
      (EE) GLX: could not load software renderer
      I tried to follow the instructions at

      These are basically my commands when I installed:
      git clone git://
      git clone git://
      git clone git://
      cd drm/
      ./ --prefix=/usr/local/xorg
      make -j 3 ; make install ; cd ..
      export PKG_CONFIG_PATH="/usr/local/xorg/lib/pkgconfig"
      cd xf86-video-ati/
      ./ --prefix=/usr/local/xorg
      make -j 3 ; make install ; cd ..
      cd mesa/
      ./ --prefix=/usr/local/xorg --enable-gallium-r600 --with-dri-driverdir=/usr/local/xorg/lib/dri/
      make -j 3 ; make install ; cd ..
      Then I added the line "/usr/local/xorg/lib" to /etc/ and executed "ldconfig".
      Then I added "/usr/local/xorg/lib/modules" to the ModulePath entry in xorg.conf, although this seems useless since there isn't a modules folder.
      I set this variable:
      In xorg.conf I still have this section:
      Section "DRI"
          Group      "dard"
          Mode       0666
      I thought this is everything I need, but glxinfo gives me:
      name of display: :0.0
      Error: couldn't find RGB GLX visual or fbconfig
      What am I missing?