Announcement

Collapse
No announcement yet.

Can I have KMS for X11 but not for the console?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can I have KMS for X11 but not for the console?

    Is there a way to make the consoles (tty1 to tty6) be in normal 80x25 textmode while using the radeon driver with KMS?

    Or is it possible to set a resolution like 640x480 or whatever would correspond to a 80x25 framebuffer?

  • #2
    Originally posted by RealNC View Post
    Is there a way to make the consoles (tty1 to tty6) be in normal 80x25 textmode while using the radeon driver with KMS?

    Or is it possible to set a resolution like 640x480 or whatever would correspond to a 80x25 framebuffer?
    not really, either its KMS on or its off completly. closest would probably be to put in a video=640x480 or some low res to get a lower-res console if you wish for it. and have Xorg set its own mode on its startup which it usually does.

    Comment


    • #3
      video=640x400 has zero effect :-/ It keeps using 1920x1080.

      Splash is disabled (in case it tries to set a mode on its own.)

      Comment


      • #4
        if you use grub2, you can put

        Code:
        GRUB_GFXMODE=640x480
        GRUB_GFXPAYLOAD_LINUX=640x480
        in /etc/default/grub

        After update-grub, the resolution of tty should be 640x480

        Comment


        • #5
          Originally posted by RealNC View Post
          video=640x400 has zero effect :-/ It keeps using 1920x1080.

          Splash is disabled (in case it tries to set a mode on its own.)
          400 != 480 , i think you made a typo, most screens should support that low

          Comment


          • #6
            640x480 doesn't work either. I also tried 800x600, 1024x768 and 1280x1024, also with no success.

            I'm not using grub2 so I can't try that one.

            Comment


            • #7
              Have you tried looking at supported modes? You should see a similar path on your machine under /sys/class/drm for your display adapter and output.

              [email protected]:~$ cat /sys/class/drm/card0-LVDS-1/modes
              1366x768
              1280x720
              1152x768
              1024x768
              800x600
              848x480
              720x480
              640x480

              Comment


              • #8
                Originally posted by amphigory View Post
                Have you tried looking at supported modes? You should see a similar path on your machine under /sys/class/drm for your display adapter and output.
                The list I get is:

                Code:
                1920x1080
                1600x1200
                1680x1050
                1280x1024
                1440x900
                1280x960
                1280x800
                1024x768
                800x600
                800x600
                640x480
                But none of them work. It seems that the radeon driver is ignoring the "video" kernel parameter. Does it actually work OK on your system?

                Comment


                • #9
                  I tried jacking with 'fbset' but all that does is constrain the console to a smaller region of the actual screen. Worthless. What would probably work for you is to change console font. They are in /usr/share/consolefont in Debian.

                  See what 'setfont Uni3-TerminusBold32x16.psf.gz' or some other large font does for you. It make a radical difference for me. I'm not sure if there are any fonts large enough to give you 80x25 at 1920x1080 though. Of course, you could always create your own font.... :-)

                  Comment


                  • #10
                    The largest console font I've found is 32x16 which would give you 120x33 at 1920x1080 resolution.

                    Comment

                    Working...
                    X