Announcement

Collapse
No announcement yet.

Heroes of Newerth character display & Gallium r600g

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • oibaf
    replied
    Originally posted by charlie View Post
    Shadows on any object do not draw correctly but produces a kind of banding.
    This may be related:
    https://bugs.freedesktop.org/show_bug.cgi?id=31159

    If it is it's a more general problem involving not only one driver.

    Leave a comment:


  • stev47
    replied
    Originally posted by charlie View Post
    But 600c is prone to crashing if there is a lot of action on the screen (like all 10 players executing their ultimates at the same time).
    This is an old regression:
    https://bugs.freedesktop.org/show_bug.cgi?id=31391

    But no one seems to bother, since it's just the ?old? r600c driver.

    Leave a comment:


  • charlie
    replied
    Originally posted by tilman View Post
    To fix rendering of units and (some) buildings, enter this in the in-game console (CTRL-F8):
    vid_meshGPUDeform false
    "vid_meshGPUDeform false" draws characters correctly but gives a large performance hit that makes the game unplayable.

    With "vid_meshGPUDeform" set to true and with the current xorg git characters now display but there is no animation. After a certain uknown commit the characters are now skewed where as before they were drawn mostly correct.

    By
    imagebugs at 2011-01-22

    Shadows on any object do not draw correctly but produces a kind of banding.

    Leave a comment:


  • agd5f
    replied
    You might try this latest mesa commit too depending on how many constants it uses:
    http://cgit.freedesktop.org/mesa/mes...575a22db638d5a

    Leave a comment:


  • Jecos
    replied
    Originally posted by tilman View Post
    To fix rendering of units and (some) buildings, enter this in the in-game console (CTRL-F8):
    vid_meshGPUDeform false

    To make HoN even start correctly, you might have to set shader detail to low in the settings.

    AFAICT, both workarounds are due to r600g only supporting 16 constants in GLSL shaders currently.
    Aha, thank you for that!

    Leave a comment:


  • tilman
    replied
    To fix rendering of units and (some) buildings, enter this in the in-game console (CTRL-F8):
    vid_meshGPUDeform false

    To make HoN even start correctly, you might have to set shader detail to low in the settings.

    AFAICT, both workarounds are due to r600g only supporting 16 constants in GLSL shaders currently.

    Leave a comment:


  • charlie
    replied
    No change in HON. I compiled that commit about two hours after it went up. I watch mesa/mesa git at least once a day and just before bed I saw it and had to try it.

    Leave a comment:


  • agd5f
    replied
    Does this patch help:
    http://people.freedesktop.org/~agd5f...ing-a-ze.patch

    Leave a comment:


  • Jecos
    replied
    I was thinking this might be just Evergreen specific.

    I can only test it on an r500 and r800.

    Leave a comment:


  • charlie
    replied
    I have an HD3850=RV670 using xorg-git/mesa-git/etc (which I assume xorg-git is not equal to xorg-edgers?)

    Leave a comment:

Working...
X