Announcement

Collapse
No announcement yet.

How to use r600 near barts on Linux?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to use r600 near barts on Linux?

    Hi, I have a r600 onboard GPU. I am using it for some years, with Mesa and xf64-video-ati drivers from git, compiled locally. But I am stcuk on some situation...

    I bought a 6850 gpu, installed to my system. Every thing is ok. Monitor cable connected to internal GPU (r600). My system happy with it's r600g driver but now, my r600 became secondary GPU and required driver not loaded on startup by default.

    Can I use r600 at linux at this configuration in linux? I know the short answer ("Yes"). But Don't know how to do that. Could you give detail about it? Currently writing this lines from vesa

    Using OpenSuSE 11.3
    Thanks.

  • #2
    Shouldn't you make the onboard GPU the primary video device in your BIOS? I remember reading somewhere that most motherboards disable it by default if they detect a discrete card.

    I don't know how good the HD6xxx support is at the moment, but it should be possible to use it alongside your onboard GPU without any trouble.

    Comment


    • #3
      Select which card is initialized first in your bios if it has the option; also if you want to use the onboard card in conjuction with a pcie card, you may need to enable the "surround view" option in the bios. You can specify the busid of the card in your xorg.conf. I'm working on Northern Islands support. Patches should be available soon.

      Comment


      • #4
        I found the answer while I am searching my-self but answer is here.
        The magic's name is: "BusId".


        Code:
        [email protected]:~> cat /etc/X11/xorg.conf.d/50-device.conf 
        Section "Device"
          Identifier "ATI 3300 IGP"
          Driver "radeon"
          BusId "PCI:1:5:0"
          ## Required magic for radeon/radeonhd drivers; output name
          ## (here: "DVI-0") can be figured out via 'xrandr -q'
          #Option "monitor-DVI-0" "Default Monitor"
        
        EndSection
        [email protected]d:~>
        Fixes the problem.

        System works almost perfect. One little glitch is I think I couldn't put my bart sleep/powersave mode in linux yet. Currently takes ~25W alone.

        Thank you for the hint

        Comment

        Working...
        X