No announcement yet.

AMD's R300 Gallium3D Driver Is Looking Good For 2011

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Mr James View Post
    I wonder what Ubuntu employees spend thier time working on. Oh that's right, they did come up with a font and a Unity interface nobody (as far as I read) seems to like.
    I'm not sure where you came up with that statistic, from what I have seen the reception of unity has been quite fine.


    • Originally posted by Dard View Post
      I read a little in the specifications, and there's no way I would ever start working on the driver unless I get one or two years of education in hardware/software co-design and a full time job. It's just too complex to work on one or two hours after work.
      Parts of it, sure. Helping architect the entire driver, absolutely. Fixing a bug here or there, not so much. Helping with some of the simpler but very important aspects of the driver software, like the GLSL compiler (which is very cleanly written and well designed) is also not something that requires a tremendous amount of time or any exceptional knowledge of hardware.

      Hell, just help triage bugs in the freedesktop or your distribution's bugzilla, to help the more skilled developers focus time on the actual bugs.

      You can always help. Even if you have no programming experience at all.


      • I was going to give up but decided to look via Synaptic at possible packages that relate to video. So, I upgraded linux firmware packages and the radeon driver version to name two. Fortunately, when I retried various tests including tuxracer and Google Earth, they worked! I had a problem with Google Earth on this machine (with Radeon 9000 card, M9, R250), too! So, I am not sure which package upgrade helped or if that was the solution, but it's my interpretation that something upgraded 'fixed' "something" so now these programs work. Glxgears worked previously but tuxracer would crash to a black screen and Google Earth's logo would display and then disappear.

        They now work albeit slow but the main thing is these two packages work now. I interpret the 'solution' of the packages being upgraded since I cannot trace much different being changed except for that. It's my inexperience and lack of knowledge, I admit, but I didn't find this 'solution' on google. I read a few claims of what packages were needed but I thought I had nothing to lose so looked up packages that might relate to video and just upgraded them if there was a new version available.

        This is Debian Testing, kernel 2.6.32-5. Anyway, 'glad that these programs work. I'm not complaining about the slow speed as I expect it to be slow as this is on older hardware but I thought at least I should not have a crash. It's frustrating when you are confused and not sure what's wrong - at least, if there is some feedback or some way to troubleshoot but I really had no idea of what was wrong.