Announcement

Collapse
No announcement yet.

AMD Radeon HD 6800 Series Graphics Cards On Linux?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by bridgman View Post
    Check and see if there is a game option or Wine option to prevent the game from changing modes on you.
    NomadDemon, wine supports the "virtual desktop" concept. Either set this using winecfg (will affect all apps started via that wine configuration) or run something like
    Code:
    wine explorer.exe /desktop=Starcraft,1024x768 "C:\\Starcraft\\Starcraft.exe"
    Originally posted by NomadDemon View Post
    ok, changed DVi connector on my graphic card to other, and it works, but some programs have problems like firefox, they MAXIMIZE to 1024x768 not to 1280x1024
    That's probably because your window manager detects two outputs and maximizes windows to the output they're currently "on" (which switches randomly, since they're overlapping).
    It's a weird, largely untested configuration. I think kwin4 will do better in this configuration; it does an equally stupid thing and just discards one of the overlapping monitors.

    Comment


    • #32
      yea, but playing on "desktop" mode suck hard.. scrolling, mouse often get out of window, even with "grab" enabled

      @ Bridgman
      wine have options like this? where?

      starcraft was only example, all program that use full screen do same thing, even quake live[native]

      Comment


      • #33
        Originally posted by bridgman View Post
        Is Starcraft doing a mode set ? If so, that will probably over-write all the stuff you carefully set up.
        Any application that does modesetting needs to be understand xrandr 1.3 scaling or it will mess things up. Wine doesn't...

        Originally posted by bridgman View Post
        Check and see if there is a game option or Wine option to prevent the game from changing modes on you.
        You can stop wine from doing any modesetting by setting the registry key [ HKEY_CURRENT_USER \ Software \ Wine \ X11 Driver \ UseXRandR ] to "N", but then applications will fail if it tries to modeset to anything that doesn't match the current settings exactly.

        Originally posted by rohcQaH View Post
        I think kwin4 will do better in this configuration; it does an equally stupid thing and just discards one of the overlapping monitors.
        kwin doesn't understand scaling, but it will always use the primary monitor if it overlaps with another one, so as long as you use xrandr --output DVI-0 [...] --primary from my previous post you should be fine.

        If you are using another complex setup kwin doesn't fully understand (such as scaling on your primary monitor), you can disable its multi-monitor mode, in which case it will treat the entire framebuffer as a single monitor and maximize all windows over the entire thing. Unfortunately the GUI for this is hidden in System Settings unless it detects multiple non-overlapping monitors, so you will have to add the following lines to ~/.kde/share/config/kdeglobals manually and then log out and log back in again for them to take effect.
        Code:
        [Windows]
        XineramaEnabled=false

        Comment


        • #34
          buu.. i dont like KDE :<

          Comment


          • #35
            I have a HD 6870 driving two CRTs on Fedora 14 with Catalyst 10.10. This card only has one DVI-I port (The other is DVI-D), so I needed a DisplayPort to VGA adapter to drive the other monitor. Also, a "Unsupported hardware" watermark is displayed in the bottom left corner of both screens.

            Anyways, here's my xorg.conf:
            Section "Module"
            Load "GLcore"
            Load "glx"
            Load "dri"
            EndSection

            Section "Device"
            Identifier "Card0"
            Driver "fglrx"
            EndSection

            Section "Monitor"
            Identifier "CRT1"
            Option "Monitor-outputname" "CRT1"
            HorizSync 30-121
            VertRefresh 48-160
            EndSection

            Section "Monitor"
            Identifier "DFP1"
            Option "Monitor-outputname" "DFP1"
            HorizSync 30-121
            VertRefresh 48-160
            EndSection

            Section "Screen"
            Identifier "Screen0"
            Monitor "DFP1"
            Device "Card0"
            SubSection "Display"
            Modes "1600x1200" "1280x1024"
            Virtual 3200 1200
            EndSubSection
            EndSection
            Note: aticonfig won't work. It complains that no supported adapters are detected.

            Comment


            • #36
              Fixed the formatting. Also, the watermark is on the bottom right.

              Code:
              Section "Module"
                Load "GLcore"
                Load "glx"
                Load "dri"
              EndSection
              
              Section "Device"
                Identifier "Card0"
                Driver     "fglrx"
              EndSection
              
              Section "Monitor"
                      Identifier      "CRT1"
                      Option          "Monitor-outputname" "CRT1"
              	HorizSync       30-121
              	VertRefresh     48-160
              EndSection
              
              Section "Monitor"
                      Identifier      "DFP1"
                      Option          "Monitor-outputname" "DFP1"
              	HorizSync       30-121
              	VertRefresh     48-160
              EndSection
              
              Section "Screen"
                      Identifier      "Screen0"
                      Monitor         "DFP1"
                      Device          "Card0"
                      SubSection "Display"
                              Modes "1600x1200" "1280x1024"
                              Virtual 3200 1200
                      EndSubSection
              EndSection

              Comment


              • #37
                Gtx 470 -EVGA SC :-)

                Hi Yall,

                gbeauche, are they so tight, they will not give you hardware to do dev work on????? :-/

                Well, I jumped to the above card and the improvement in video playback and fantastic, with all the KDE EYE-CANDY turned on! It is way smoother than all the ATI spin on these forums. ;-)

                "It just works."

                Also, in Win7, 64 bit, Civ V has no corruption, as it had with the ATI drivers. A friend noted the same thing, with his 5970. Clearer image, more zoom in and smoother than the ATI spin on these forums.... ;-)

                For ATI, to sell cards into the consumer space, with drivers that fail for quality video playback, is just 2nd rate. Then to turn around and blame the users for buying there cards (ie, "we do not support video playback"), is third rate.

                Still, when it comes to nVida, it just has to be said, Bumpgate....

                The Devil or the Deep blue sea?

                EVGA do lifetime backup, so I've gone with what actually works, here and now-nVida. :-)

                Now, I will leave the ATI fanboys to keep on sleepwalking. ;-)

                MMmmmm. Eye Candy.

                GreekGeek :-)

                Comment


                • #38
                  Do not feed the trolls, you'll never be rid of them.

                  P.S. Playing Civ V on Win 7, 64 bit with my ATI card, I have no idea what you're talking about.

                  Comment


                  • #39
                    This is NOT microsuck forum. So please, you two above, go to hell. Thank you!

                    Comment


                    • #40
                      @HackerFoo

                      Check this:

                      http://www.phoronix.com/forums/showp...85&postcount=2

                      Comment

                      Working...
                      X