Announcement

Collapse
No announcement yet.

fglrx failed to install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx failed to install

    Hi,

    I tried installing catalyst 10.9, but it fails to install, with the error:
    Code:
    Error! Bad return status for module build on kernel: 2.6.32-25-generic (x86_64)
    Consult the make.log in the build directory
    /var/lib/dkms/fglrx/8.771/build/ for more information.
    in the make.log file, it says:
    Code:
    DKMS make.log for fglrx-8.771 for kernel 2.6.32-25-generic (x86_64)
    Wed Sep 29 11:58:07 CEST 2010
    AMD kernel module generator version 2.1
    doing Makefile based build for kernel 2.6.x and higher
    rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
    make -C /lib/modules/2.6.32-25-generic/build SUBDIRS=/var/lib/dkms/fglrx/8.771/build/2.6.x modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.32-25-generic'
      CC [M]  /var/lib/dkms/fglrx/8.771/build/2.6.x/firegl_public.o
      CC [M]  /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_acpi.o
      CC [M]  /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_agp.o
      CC [M]  /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_debug.o
      CC [M]  /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_ioctl.o
    /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_ioctl.c: In function ?KCL_IOCTL_AllocUserSpace32?:
    /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_ioctl.c:196: error: implicit declaration of function ?compat_alloc_user_space?
    /var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_ioctl.c:196: warning: return makes pointer from integer without a cast
    make[2]: *** [/var/lib/dkms/fglrx/8.771/build/2.6.x/kcl_ioctl.o] Error 1
    make[1]: *** [_module_/var/lib/dkms/fglrx/8.771/build/2.6.x] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-25-generic'
    make: *** [kmod_build] Error 2
    build failed with return value 2
    Any idea what goes wrong here? is there anything I can do? maybe change kernel?

  • #2
    Use my script:

    http://kanotix.com/files/install-fglrx-debian.sh

    sudo rm -f /etc/X11/xorg.conf*
    DISPLAY= sudo sh install-fglrx-debian.sh -z

    then reboot.

    Comment


    • #3
      Thanks, I tried to, but got another error:

      Code:
      Reading state information... Done
      You might want to run 'apt-get -f install' to correct these:
      The following packages have unmet dependencies.
        fglrx-amdcccle: Depends: fglrx but it is not going to be installed
        fglrx-dev: Depends: fglrx but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      Package libstdc++5 is not available, but is referred to by another package.
      This may mean that the package is missing, has been obsoleted, or
      is only available from another source
      E: Package libstdc++5 has no installation candidate
      Error: module-assistant missing.
      Hint: Enable universe repository in /etc/apt/sources.list.
      running 'sudo apt-get -f install' gave me:

      Code:
      Removing fglrx-amdcccle ...
      dpkg: warning: while removing fglrx-amdcccle, directory '/usr/lib/fglrx' not empty so not removed.
      Removing fglrx-dev ...
      Removing fglrx ...
      dpkg-divert: mismatch on package
        when removing `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by fglrx'
        found `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by xorg-driver-fglrx'
      dpkg: error processing fglrx (--remove):
       subprocess installed post-removal script returned error exit status 2
      Processing triggers for ureadahead ...
      Errors were encountered while processing:
       fglrx
      E: Sub-process /usr/bin/dpkg returned an error code (1)

      Comment


      • #4
        Well your system is messed up, but not by my script.

        Comment


        • #5
          What distro are you running with, yesterday there was an update with Debian Squeeze that broke fglrx.

          Comment


          • #6
            My own of course. Kanotix Hellfire works with fglrx as thats my script. irc://irc.freenode.net/#kanotix for more info. The script works with Debian.

            Comment


            • #7
              I'm running Ubuntu lucid. It could be that I got that kernel update, but not quite sure what to do about it..

              Comment


              • #8
                Okay I have some progress, I've now successfully uninstalled fglrx. I still can't install a new version though, as the install is broken on both 2.6.32.24 and 2.6.32.25 kernels. The only other kernel to which I can downgrade is 2.6.32.21, which I'm not sure is a good idea to do.

                Strangely, I do still have 2.6.32.23 installed, on which fglrx does compile, but it also automatically try to install to either .24 or .25. Is there a way to prevent this? if so, I could only boot in that kernel for now.

                Comment


                • #9
                  ... damn 1 minute limit...

                  for those interested: I solved the problems with synaptic by running the following

                  Code:
                  sudo dpkg-divert --rename --remove /usr/lib/libGL.so.1.2
                  sudo dpkg-divert --rename --remove /usr/lib32/libGL.so.1.2 
                  sudo dpkg --force-all --purge fglrx

                  Comment


                  • #10
                    You can use latest 2.6.36rc6:

                    http://kernel.ubuntu.com/~kernel-ppa...35.7-maverick/

                    You need to install arch debs of linux-image/header + all header. best all in a new dir and then

                    sudo dpkg -i *.deb

                    Comment

                    Working...
                    X