Announcement

Collapse
No announcement yet.

AMD catalyst 10.9 has been released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    The new Ubuntu kernel breaks wine... FFS! I was thinking it was FGLRX fault.

    At least the new kernel + this fix https://bugs.launchpad.net/ubuntu/+s...er/+bug/641890 is breaking Wine. (4 driver versions tested 10-9, 10-8, 10-4, 10-4).

    If someone knows how to fix this I would be gratefull.

    Comment


    • #52
      EDIT: Its breaks OpenGL inside Wine.

      OpenGL is working perfectly everywhere else.

      Comment


      • #53
        hi,
        i try install ati 10.9 at ubuntu 10.04 (2.6.32-24-generic) x64 and didnt work

        follow howto from cchtml.com and when
        first uninstall 10.8 then

        dpkg -i fglrx*.deb

        i have this errors:

        Selecting previously deselected package fglrx.
        (Reading database ... 161494 files and directories currently installed.)
        Unpacking fglrx (from fglrx_8.771-0ubuntu1_amd64.deb) ...
        Selecting previously deselected package fglrx-amdcccle.
        Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.771-0ubuntu1_amd64.deb) ...
        Selecting previously deselected package fglrx-dev.
        Unpacking fglrx-dev (from fglrx-dev_8.771-0ubuntu1_amd64.deb) ...
        Selecting previously deselected package fglrx-modaliases.
        Unpacking fglrx-modaliases (from fglrx-modaliases_8.771-0ubuntu1_amd64.deb) ...
        Setting up fglrx (2:8.771-0ubuntu1) ...
        update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/GL.conf (gl_conf) in auto mode.
        update-initramfs: deferring update (trigger activated)
        Loading new fglrx-8.771 DKMS files...
        First Installation: checking all kernels...
        Building only for 2.6.32-24-generic
        Building for architecture x86_64
        Building initial module for 2.6.32-24-generic

        Error! Bad return status for module build on kernel: 2.6.32-24-generic (x86_64)
        Consult the make.log in the build directory
        /var/lib/dkms/fglrx/8.771/build/ for more information.
        dpkg: error processing fglrx (--install):
        subprocess installed post-installation script returned error exit status 10
        dpkg: dependency problems prevent configuration of fglrx-amdcccle:
        fglrx-amdcccle depends on fglrx; however:
        Package fglrx is not configured yet.
        dpkg: error processing fglrx-amdcccle (--install):
        dependency problems - leaving unconfigured
        dpkg: dependency problems prevent configuration of fglrx-dev:
        fglrx-dev depends on fglrx; however:
        Package fglrx is not configured yet.
        dpkg: error processing fglrx-dev (--install):
        dependency problems - leaving unconfigured
        Setting up fglrx-modaliases (2:8.771-0ubuntu1) ...
        Processing triggers for ureadahead ...
        Processing triggers for man-db ...
        Processing triggers for python-gmenu ...
        Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
        Processing triggers for initramfs-tools ...
        update-initramfs: Generating /boot/initrd.img-2.6.32-24-generic
        Processing triggers for python-support ...
        Errors were encountered while processing:
        fglrx
        fglrx-amdcccle
        fglrx-dev



        and now i cant install any version of fglrx, 10.7, ubuntu repository, xteam, always same error

        ubuntu 10.04 x64
        Radeon HD 4870


        any suggestion? help?

        (sorry for my very very bad english)

        thanks

        Comment


        • #54
          Originally posted by Qaridarium
          10.8 can handle the standart 32 bit flash in 10.04 kubuntu and the 10.9 goes down if you switch from fullscreen to windows mode only strg+alt+f1 and after that strg+alt+f7 brings the screen back.
          I think I'm experiencing the same issue. I filed a bug report at http://ati.cchtml.com/show_bug.cgi?id=1913 but haven't received a reply yet. Before reporting this as a bug, I asked on the Arch forums if anyone was able to reproduce this issue, but yours is the only similar report.

          Have you by any chance found an explanation of what's wrong and/or maybe a solution?

          Comment


          • #55
            Originally posted by srbungle View Post
            hi,
            and now i cant install any version of fglrx, 10.7, ubuntu repository, xteam, always same error

            ubuntu 10.04 x64
            Radeon HD 4870


            any suggestion? help?

            (sorry for my very very bad english)

            thanks
            I had the same problem and was going nuts. Found it to be an issue with linux kernel 2.6.32-24 (which made it's way to the Ubuntu repositories a few days ago - you probably just got it while running updates). I rolled back to 2.6.32-23 and now I can install any version of Catalyst again, including the new 10.9 (fglrx 8.771).

            Just install the following from Synaptic:
            linux-headers-2.6.32-23
            linux-headers-2.6.32-23-generic
            linux-image-2.6.32-23-generic

            It should update grub for you automatically. Next time you reboot, you should presented an option for which kernel you'd like to use. Select the -23 version and install Catalyst again. It shoudld work now.

            You can either leave -24 there for now or remove it. I would also install StartupManager from synaptic to help you manage grub if you are going to keep several images to boot to.

            Hope that helps! Frustrated the hell outta me for a bit.

            Comment


            • #56
              There is definitely a problem with the new 2.6.32-x kernel and fglrx. Not sure yet what the final resolution will be.

              Comment


              • #57
                i solved like anomalydetected said

                downgrade to kernel 2.6.32-23 and works ati 10.9

                thanks!

                Comment


                • #58
                  Originally posted by Qaridarium
                  just drop the 32bit flash the nativ 64bit one do have less bugs.
                  It's exactly the same situation with the native 64bit Flash plugin. And it's not just Flash either; it has occurred with smplayer a few times, although in this case it's not reproducible always like Flash.

                  Comment

                  Working...
                  X