Announcement

Collapse
No announcement yet.

XRender on ati catalyst

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bridgman
    replied
    I guess the first thing I would do is check to see which Render hooks were pointing to driver code and which (if any) were still pointing to software rendering code in the X server... then hook those locations and see which ones were being called and how often.

    Not like I remember how to do that or anything...

    Leave a comment:


  • jrch2k8
    replied
    Originally posted by bridgman View Post
    My understanding was that XRender *was* accelerated with the new 2D accel code, will try to find out. Weren't there some XRender-based benchmarkes published here a while back (comparing open vs Catalyst 2D performance) ?
    well it would make sense that catalyst 2d should be faster but maybe kde is using some xrender options not accelerated or slow memory mapping or maybe even some fallbacks to XAA for some reason?

    is there an fast way to debug catalyst 2d? to check for fallbacks?

    Leave a comment:


  • bridgman
    replied
    My understanding was that XRender *was* accelerated with the new 2D accel code, will try to find out. Weren't there some XRender-based benchmarkes published here a while back (comparing open vs Catalyst 2D performance) ?

    Leave a comment:


  • jrch2k8
    replied
    Originally posted by ergo View Post
    Hello,

    I own HD 5770 card, and run latest catalyst drivers, 10.8 (ati control center reports 10.7 but i do have tesselation in unigine demo etc.) - and debian squeeze as OS.

    Now that firefox 4.0b5 came out it appears that Xrender is not accellerated.

    http://demos.hacks.mozilla.org/openweb/HWACCEL/ - i get 5fps here, for comparison my wife gets 60fps using nvidia binary.

    Under windows i get 90fps, yet i cant seem to find any way to break the 5fps barrier under linux with or without compiz.

    Is there anything that can be done? Should i enable something specific in my xorg.conf ?
    well in my experience with catalyst 10.1-.8 and my 4850x2 i can say xrender is freaking trully slow (measure is visual based on xrender composite vs radeon driver).

    on the other hand if catalyst glES is based on their opengl library, well you can expect a gazillion of render artifacts/slowness/wrong color mapping/texture corruption/hangups/packs of kernel oops/bugged tesslation(not tested by me but already reported in several threads)/buggy glsl implementation(try kde 4.5.1 and you will see your xorg crying in the logs or the kernel oopsing like there is no tomorrow). so im not so sure you wanna use glES 2.0 just yet in your browser with catalyst(oc if websurfing is an important task for you)

    if you are only testing the beta of firefox then install the debug symbols and use debugging for glES(not sure how to turn it on btw) and keep chromium around with ati bug reports site cuz things could get nasty

    on the other hand if you have an old nvidia card or an old radeon r300 you can try it with mesa glES mesa/gallium and check that out

    Leave a comment:


  • kernelOfTruth
    replied
    I see - thanks for that information

    then it's to be expected that it's slow:

    you tried the XRender-backend under kde 4 for compositing and compared it with nvidia ?

    then you'll know that XRender is really really slow with catalyst/fglrx

    @bridgman:

    could you please give the devs a little poke to improve that ?

    Leave a comment:


  • ergo
    replied
    its not webgl - mozilla guy on reddit said it uses xrender to accelerate stuff - but some webgl tests are slow for me too.

    i get 90fps on same hardware under windows - on linux with nvidia blobs my wife gets 60 fps

    Leave a comment:


  • kernelOfTruth
    replied
    you need catalyst 10.8 (which you have) with opengl es 2.0

    and enable: webgl.enabled_for_all_sites;true

    unfortunately it doesn't seem to be supported yet in linux

    I get an average FPS of 10 (max 23)

    it's not using XRender but opengl afaik

    XRender is pretty slow on catalyst / fglrx

    I get on average 30 FPS with chromium 7

    Leave a comment:


  • ergo
    started a topic XRender on ati catalyst

    XRender on ati catalyst

    Hello,

    I own HD 5770 card, and run latest catalyst drivers, 10.8 (ati control center reports 10.7 but i do have tesselation in unigine demo etc.) - and debian squeeze as OS.

    Now that firefox 4.0b5 came out it appears that Xrender is not accellerated.

    http://demos.hacks.mozilla.org/openweb/HWACCEL/ - i get 5fps here, for comparison my wife gets 60fps using nvidia binary.

    Under windows i get 90fps, yet i cant seem to find any way to break the 5fps barrier under linux with or without compiz.

    Is there anything that can be done? Should i enable something specific in my xorg.conf ?
Working...
X