Announcement

Collapse
No announcement yet.

Sync & swap / vsync video playback issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    That is, the only thing that looks potentially expensive there is the loop, rest is just some severe black magic casting (to_radeon_crtc somewhat blew my mind ) and comparisons and such as far as I can see.

    Comment


    • #12
      Originally posted by nanonyme View Post
      That is, the only thing that looks potentially expensive there is the loop, rest is just some severe black magic casting (to_radeon_crtc somewhat blew my mind ) and comparisons and such as far as I can see.
      Let's keep focus.
      I'm just saying disabling the "CRTC query" feature brings back smooth video playback. Nothing to do with CPU load btw.

      Comment


      • #13
        Digging up the subject, sorry.

        With current GFX components :
        mesa git
        ddx git
        either 2.6.35 mainline or cutting edge drm-radeon-testing/next/core-next..

        the issue remains, which is GL micro-freezes meaning degraded video experience with enabled compositing.
        Especially noticeable in 720p full screen, watching windowed SD xvid you wouldn't notice.

        I am willing to help track this down, at least open a bug report, but where then ? Mesa ? DDX ?

        Thanks in advance !

        Comment


        • #14
          I had a similar problem. Only with KDE. Other people too. I guess developers are all Gnome fanboys

          Anyway, the fix here was to set the following values in the [compositing] section of ~/.kde4/share/config/kwinrc (or ~/.kde instead of ~/kde4, depends on the dirsto):

          Code:
          [Compositing]
          Backend=OpenGL
          CheckIsSafe=false
          DisableChecks=true
          Enabled=true
          GLDirect=true
          GLVSync=false
          OpenGLIsUnsafe=false
          It seems KDE is disabling functionality because it thinks the OpenGL implementation is buggy and unsafe. The above will force KDE to use all GL features.

          Note that the above disables VSync, but don't worry; it actually doesn't. Even if you disable VSync in System Settings, everything is still tear-free and VSynced perfectly.

          On another matter, I noticed you prefer -vo gl? Don't do that. Xv support in the open drivers and with DRI2 and KMS is excellent. Always use Xv. OpenGL is slower and not always tear-free. Xv doesn't have that problem.

          Comment


          • #15
            GL buffer swaps are always tear free with the radeon drivers since we use vline waits when doing the swap, however, they are not throttled to vsync unless your app uses one of the GLX vsync extensions.

            Comment


            • #16
              Maybe it's the throttling then that's at fault. Enabling VSync resulted in the past (two weeks ago or so) in extremely uneven animations. Smooth, but uneven. For example, the effect that zooms out the window to the task bar when minimizing would double its speed half-way through, and then switch back to half speed, and then double speed again.

              In recent Git of Mesa and friends, the unevenness got fixed. But performance was killed; minimizing windows for example is animated at about 5FPS; extremely ugly.

              Switching off VSync in KDE System Settings makes everything smooth and fast again.

              Comment


              • #17
                No luck, same here with above KWin parameters, even with Kwin vsync "disabled", same result.

                Btw I use UnredirectFullscreen set to 'false', this is why fullscreen playback shows these symptoms.

                Comment


                • #18
                  Originally posted by RealNC View Post
                  On another matter, I noticed you prefer -vo gl? Don't do that. Xv support in the open drivers and with DRI2 and KMS is excellent. Always use Xv. OpenGL is slower and not always tear-free. Xv doesn't have that problem.
                  I tried -vo gl while investigating. My prefered default stays -vo xv, but it doesn't seem to make a difference anyway since the environment is composited, including fullscreen playback.

                  Comment


                  • #19
                    Tried KDE SC 4.5 (i am running kde 4.4), no luck either, with or without kwin "vsync" parameter.

                    Could someone please help me file a bug report in the right place ?

                    Facts reminder :
                    - with DRM 2.5.0 or newer, video playback in slighty jerky in a composited env, no matter video output (x11, xv, gl)
                    - when no compositing, video playback is perfectly smooth, either with -vo xv or gl
                    - with DRM 2.5.0 or newer, tainted by disabling CRTC query capability, video playback is smooth again (I guess because it breaks a lot of features related to vsync)
                    - tweaking vblank_mode doesn't help, neither /etc/drirc does.


                    Potential candidates :
                    - Mesa ?
                    - DDX ?
                    - KDE Kwin ?

                    Thanks again in advance,
                    Dams

                    Comment


                    • #20
                      Quick update on this (forgotten ?) issue... Problem still not solved !

                      Now with mesa git, ddx git and 2.6.36rc3, i've been noticing :
                      - using GL, video playback is quite smooth windowed or fullscreen
                      - using XV, video playback is perfectly smooth windowed, and jerky when switching to fullscreen

                      It occurs both with Kaffeine or Mplayer. I use "UnredirectFullscreen=false" as kwin setting.

                      Any ideas ?
                      Is there something special windowmanagers or GFX drivers are doing when switching to fullscreen ?
                      Thanks again in advance,

                      Comment

                      Working...
                      X