Announcement

Collapse
No announcement yet.

hd 3650 AGP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hd 3650 AGP

    Hi, i have buyed hd 3650 AGP (R6xx);
    i using slackware64 (using 32bit version of driver is not problem for me)
    and kde4.x

    witch driver i should use ?
    - open ati
    - open radeonhd
    - mesa gallium
    - closed fglrx


    BTW on AMD site there is no 64bit fglrx for Radeon HD driver but I tested version for PCIe and it works (with very slow 2D rendering and fast 3D)

  • #2
    Originally posted by lamprez View Post
    Hi, i have buyed hd 3650 AGP (R6xx);
    AGP cards are very tricky.

    Originally posted by lamprez View Post
    - open ati
    If you want fast 2D choose the ati (radeon) Driver.
    Originally posted by lamprez View Post
    - open radeonhd
    Dont try this Driver he is no longer maintained and very outdated. So use the "radeon" is you want an Open Driver.
    Originally posted by lamprez View Post
    - mesa gallium
    This is only an Part of the Drive. But for your Card the gallium 3D Driver is in an very early development state.

    Originally posted by lamprez View Post
    - closed fglrx
    Choose this Driver if you want the most 3D Performance.

    Originally posted by lamprez View Post
    BTW on AMD site there is no 64bit fglrx for Radeon HD driver but I tested version for PCIe and it works (with very slow 2D rendering and fast 3D)
    With the open Drivers its different. You get an better 2D performance but the 3D performance is lower.

    Comment


    • #3
      If I enable fglrx i get entries in Xorg.0.log:

      (WW) fglrx(0): Option "AccelMethod" is not used
      (WW) fglrx(0): Option "MigrationHeuristic" is not used
      (WW) fglrx(0): Option "AccelDFS" is not used
      (WW) fglrx(0): Option "EnableDepthMoves" is not used
      (WW) fglrx(0): Option "ColorTiling" is not used
      (WW) fglrx(0): Option "EXAVSync" is not used
      (WW) fglrx(0): Option "RenderAccel" is not used
      (WW) fglrx(0): Option "PrefferedVRefresh" is not used
      (WW) fglrx(0): Option "CalcAlgorithm" is not used


      Firefox is very, very slow; CHrome also.
      If I move windows, cursor or anything that required screen refresh CPU utilization goes to 50-75%

      amdcccle shows i'm using OpenGL 1.4 with compatibility profile (3.3)

      Comment


      • #4
        Looks like you are running an xorg.conf set up for the open drivers and that there may be other install issues as well. Did you run aticonfig --initial (as root) before starting X ?

        You don't "enable" fglrx, you need to install/uninstall and reboot. The kernel drivers are different, and fglrx replaces a number of other system files as well.

        Comment


        • #5
          Originally posted by bridgman View Post
          Looks like you are running an xorg.conf set up for the open drivers and that there may be other install issues as well. Did you run aticonfig --initial (as root) before starting X ?

          You don't "enable" fglrx, you need to install/uninstall and reboot. The kernel drivers are different, and fglrx replaces a number of other system files as well.
          I run aticonfig before starting X
          I wrote 'enable' but i mean that i have changed configuration of my screen section to use fglrx

          I generate slack packages for driver (module + userland tools like amdccle and aticonfig)

          If I comment out options for fglrx 2D rendering is still slow, amdcccle shos that OpenGL 1.4 (!!) i used

          Comment


          • #6
            Changing xorg.conf to use the fglrx X driver only covers one small part of what you need to make the driver work.

            If you're only changing xorg.conf then you're trying to run the fglrx X driver with the open source kernel and 3D drivers, which is going to work about as badly as you might expect.

            You're going to need to do some cleanup; suggest you :

            - stop X
            - uninstall any previous fglrx drivers
            - do a fresh install of fglrx
            - run aticonfig --initial with the -f/force option to let it clean up your xorg.conf
            - start X

            Comment


            • #7
              Having a HD3650 myself, I choose fglrx
              The advantage of 3D desktop and 3D software is preferred.

              Make sure you have the interrupt latency on your AGP port set to 248.
              On my Abit nForce2, the PCI interrupt latency was set to 248 and the freezes and lockups disappeared

              Comment


              • #8
                Originally posted by Qaridarium
                my x1650 agp system only works with "radeon.agpmode=-1" on 10.04 and this is much slower than an catalyst 10.8

                sure an x800 on pcie is faster really fast but AGP is really a shame.

                10.10 works better but its better to wait for the release because its really alpfa..

                you switch agp to pcie mode (turn off agp); xorg.0.log should have an entry of disabling acceleration

                Comment


                • #9
                  Originally posted by lxusr View Post
                  Having a HD3650 myself, I choose fglrx
                  The advantage of 3D desktop and 3D software is preferred.

                  Make sure you have the interrupt latency on your AGP port set to 248.
                  On my Abit nForce2, the PCI interrupt latency was set to 248 and the freezes and lockups disappeared

                  What exactly do you mean by "PCI interrupt latency on AGP port set to 248"?
                  How do you change/set this value in linux? Is it a BIOS config? (my BIOS doesn't have such a thing)
                  Last, where did you get that number from? (how come so specific?)

                  Thanks

                  Comment


                  • #10
                    best: send that agp crap back and buy new hardware. even the cheapest cpu+onboard vga combo is better than you have got now.

                    Comment

                    Working...
                    X