Announcement

Collapse
No announcement yet.

Catalyst 10.6 black squares in firefox and Xorg 1.8 freezes after update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 10.6 black squares in firefox and Xorg 1.8 freezes after update

    Hi,
    i'm using archlinux i686 and I've updated my system yesterday and since the update i'm experiencing some major graphic problems and Xorg freezes from time to time.

    I've spotted the black squares only in firefox and they fill up whole regions (the page view in example or the area of the TabSidebar addon) and they appear and disappear randomly.

    After some time (even without starting firefox) xorg freezes and all I can do is to login via ssh and reboot the box (xorg survives a kill -9 <pid> attempt).

    As I wrote above i'm using Archlinux i686 with
    linux 2.6.34 (stock kernel from repository)
    xorg-server 1.8.1.902
    Catalyst 10.6
    Firefox 3.6.4
    Radeon HD 4650 AGP

    I've already created a bug report here:
    http://ati.cchtml.com/show_bug.cgi?id=1845

    Thanks for any hint to solve the problem. I know my english is bad, bear with it please

  • #2
    I have Debian testing updated around 1 week ago. Kernel is custom 2.6.32.9. Xserver does not lock up but firefox behaves exactly as described. Have gone back to 10.5. Anyone want anymore info please ask.

    Blacksmith

    Comment


    • #3
      Since fglrx doesn't support xorg-server 1.8 you might want to downgrade to 1.7.

      Comment


      • #4
        Thats not the cause of the black square problem as I have and Debian testing uses xserver 1.7.

        Comment


        • #5
          I was referring to the xorg freezes.

          Comment


          • #6
            @RealNC

            Basically fglrx supports xserver 1.8, maybe you want to do

            aticonfig --set-pcs-str=DDX,ForceXAA,TRUE

            while X is not running.

            Comment


            • #7
              No freezing here either, but changing from A2AA to XAA lets me see only gray squares instead of black. Compositing makes no difference.

              Comment


              • #8
                Originally posted by allquixotic View Post
                No freezing here either, but changing from A2AA to XAA lets me see only gray squares instead of black. Compositing makes no difference.
                Have you solve that issue ? I have the same in kubuntu

                Regards

                Comment


                • #9
                  Originally posted by newbeewan View Post
                  Have you solve that issue ? I have the same in kubuntu

                  Regards
                  Nope, and I have no indication that any driver since Catalyst 10.4 has addressed these issues. The big breaking changes that hit with 10.5 and later won't start to get fixed for several more months, I think. Like 4-6.

                  Comment


                  • #10
                    that's a big issue for me, because if I want to play with some games under wine I need catalyst 10.6 to make my game works !

                    So the 10.4 is not interesting for me but no graphic bugs for day to day use

                    I can't waste time to switch between that driver depending to my usage

                    Regards

                    Comment

                    Working...
                    X