Announcement

Collapse
No announcement yet.

The R300 GLSL Compiler Improvements Are Coming

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Originally posted by curaga View Post
    Built for older spec == crappy??

    Why should they raise the GL requirement to 1.5, if they currently have it lower and still work fine?
    Well, given that it is 2010, that VBOs can be supported on all hardware (and actually are), and that it is impossible to obtain optimal performance otherwise (unless using other less popular and much less standard extensions), it would seem to make sense.

    [Actually drivers could attempt to use the VM to write-protect the user data after detecting it does not change, but I don't think even the proprietary drivers dare to attempt this kind of stuff]

    Comment


    • #52
      With ETRacer already often doing 300+ fps, why would it need more performance?

      There is still driver support required, even if card Y could do VBOs.

      Comment


      • #53
        Originally posted by curaga View Post
        With ETRacer already often doing 300+ fps, why would it need more performance?

        There is still driver support required, even if card Y could do VBOs.
        I'm thinking in general its better to design these types of programs compatible with as much generation of hardware as possible. So the celestia people should implement an optional OGL 1.5+ VBO based vertex path in their code without killing older hardware compatibility that use OGL 1.1-1.4 vertex arrays. So if the extension is supported use it, if its not you allways have your old codepath.

        Comment

        Working...
        X