Announcement

Collapse
No announcement yet.

10.5 is out. come and get it.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    MiUNX
    Junior Member

  • MiUNX
    replied
    I've decided I'm giving up on ATI. I will sell my laptop within two months and buying a laptop with NVIDIA. I'm no longer willing to be treated in the way ATI treats its Linux users. Life is to short to ever be bothered with a video card that doesn't function to its (near) utmost capability.

    A goodbye and an FU to ATI.

    Leave a comment:

  • noobish
    Junior Member

  • noobish
    replied
    Originally posted by Hans View Post
    Naw won't help dude...If this doesn't solve the problem, you will have to wait for fglrx 10.6.
    Yeah, I had to start fresh for another reason, went ahead and tried all combinations of 10.3,10.4,10.5 with wine 1.1.38,1.1.44,1.2rc2 on ubuntu64 and kanotix64.

    This time around it resolved the crazy 2D surfaces issue (must have been from the ATI .run package I ran before - and subsequently uninstalled; must have left remnants).

    But it still hangs x every time when loading the game environment during the character loading process. Frustrating; had to go slocate windows just to get eve running. Here's hoping for 10.6!!! I have not messed with all the different wine registry workarounds or catalyst 3D settings on this go around though.

    This is with hd5870 eye6 btw, in case others have some gleaning knowledge to bestow upon me.

    Leave a comment:

  • Ishayu
    Phoronix Member

  • Ishayu
    replied
    First I disabled the propietory driver, and then I uninstalled the FGLRX package with synaptics.

    Then I just installed the drivers straight from the ATi .run installer using the default options, then ran "sudo aticonfig --initial -f" from a terminal, rebooted and it was good.

    Leave a comment:

  • Hans
    Senior Member

  • Hans
    replied
    Originally posted by noobish View Post
    I'm glad most of you are having success with 10.5. I'm certainly not. I still get flickering in metacity composite mode.

    Still get garbage on all 2D surfaces in eve online. Still randomly hangs x.

    I'm on 64bit ubuntu 10.04. Tried both 10.4 and 10.5 repository packages and built 10.5 package from the .run installer.

    But, sounds like I'm going to have to try the install script at the front of this thread before I give up.
    Naw won't help dude. Sounds like the driver was installed correct.

    What you should do, is to uninstall fglrx completely. Now ensure /usr/lib/fglrx and /usr/lib32/fglrx and /etc/ati is deleted aswell.

    Now reinstall the fglrx in the prober way, i.e. using the pkgbuild option with the fglrx installer.

    If this doesn't solve the problem, you will have to wait for fglrx 10.6.

    Leave a comment:

  • TheWretched
    Junior Member

  • TheWretched
    replied
    Got it to work through a post by laidbackwebsage from Ubuntuforums.org!

    Your reply helped me fix this, and the fix is (relatively) easy.

    This assumes that the aborted attempt to install "fglrx" and "fglrx-amdcccle" via apt-get is still extant on your computer. If you rolled it back or got rid of it somehow, go ahead and re-run it so all the files will be present on your machine.

    Now, open a terminal and do the following:
    Quote:
    sudo updatedb
    Quote:
    locate arch_fglrx_2.6.34.patch
    Foreach listed version of the file, do
    Quote:
    sudo gedit <file>
    Replace the first 2 lines of each file with:
    Quote:
    --- a/kcl_wait.c 2010-04-13 20:02:46.494496561 +0200
    +++ b/kcl_wait.c 2010-04-13 19:52:00.054563389 +0200
    and save the file. Remember to do this for ALL the files. (On my machine there were 2.)
    Now do the following:
    Quote:
    sudo apt-get --no-download install fglrx fglrx-amdcccle
    Reboot

    Voila! Fixed!

    Thanks for the link to the bug report...
    Needed to run aticonfig --initial after that, though!

    Leave a comment:

  • noobish
    Junior Member

  • noobish
    replied
    I'm glad most of you are having success with 10.5. I'm certainly not. I still get flickering in metacity composite mode.

    Still get garbage on all 2D surfaces in eve online. Still randomly hangs x.

    I'm on 64bit ubuntu 10.04. Tried both 10.4 and 10.5 repository packages and built 10.5 package from the .run installer.

    But, sounds like I'm going to have to try the install script at the front of this thread before I give up.

    Leave a comment:

  • TheWretched
    Junior Member

  • TheWretched
    replied
    Where did you get the drivers for Lucid?

    I tried the X-Swat repository, but installing those just brings the following installation error...

    ------------------------------
    Deleting module version: 8.732
    completely from the DKMS tree.
    ------------------------------
    Done.
    Loading new fglrx-8.732 DKMS files...
    First Installation: checking all kernels...
    Building only for 2.6.32-22-generic
    Building for architecture x86_64
    Building initial module for 2.6.32-22-generic

    Error! Application of patch arch_fglrx_2.6.34.patch failed.
    Check /var/lib/dkms/fglrx/8.732/build/ for more information.
    And I don't know how to fix it. I am not even sure, why it wants to patch for 2.6.34, as I have 32, as stated above... when running make.sh in above mentioned build directory, it runs just fine...

    Leave a comment:

  • Ishayu
    Phoronix Member

  • Ishayu
    replied
    Stupid edit time limit! :|

    Just wanted to come back to say that I am currently playing World of Warcraft in DirectX mode with all settings maxed out including shadows and it works fine. I have hardware cursor, too!

    At the same time I am streaming video from YouTube, alt+tabbing and changing desktop while the application is in full screen mode, running the game at ~35 FPS, using the in-game voice communication and playing arena as a feral druid at 2.2k rating.

    Ubuntu 10.04 Lucid Lynx x86_64
    Intel Core 2 Duo 2.53Ghz
    ATi Mobility Radeon 4650
    4GB RAM
    1920x1080 monitor

    No tearing, flickering only when I alt+tab for a short while, and overall it just works. Man I can't believe it... O.O

    Leave a comment:

  • Ishayu
    Phoronix Member

  • Ishayu
    replied
    This driver singlehandedly turned pretty much every Wine application I have from "almost but not quite working" to "working completely fine - platinum".

    Plus my own OpenGL/GLUT applications would usually display static flicker until I updated the screen the first time. (Which I didn't for a while to display a laoding screen)
    It worked fine on NVIDIA cards, but it didn't work on ATI cards. Now it works on ATI cards, too!

    The patchnotes don't even come close to describe what was done in this driver release - it is absolutely amazing!

    Thank you, ATI. For once: Really thank you.

    Time to get into Linux gaming. I finally can!

    Leave a comment:

  • kernelOfTruth
    Senior Member

  • kernelOfTruth
    replied
    Originally posted by Kano View Post
    ATI should give Fedora prerelease drivers with xserver 1.8 support - that's what they do for Ubuntu too...
    I support this post.

    it might really be helpful to have a running (working) Fedora installation with fglrx as a backup plan (especially if you're dependent on bleeding edge components !)

    Leave a comment:

Working...
X