No announcement yet.

AMD 8.36.5 Driver -- The Still no fglrx AIGLX Support Edition

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I already test it:

    Sapphire X1650 pro AGP 512MB

    openSUSE 10.2 x86-64


    Switch to text mode and back to X is working now!

    I noticed better performance moving and resizing windows.

    I use openGL to playback videos on mplayer and xine and so far i have not noticed any problems, working as 8.35.5 did.

    PS: When switching to text mode sound playback stops while been there and back to work when return to X.
    Last edited by hobbes; 18 April 2007, 05:33 PM.


    • #12
      At first it appeared that ATI had finally gotten it right. Drivers install fine on 2.6.20.x kernels, no problems. First install, no problems. amdccle install of course still not working, but that's irrelevant. But then on further testing, we discovered that on debian sid based systems, on driver deb uninstall, something is going wrong, this has been confirmed by two users so far.

      When they start x after the reinstall (not the initial 8.36.5 install, which is fine for them) of 8.36.5, they see screen and font corruptions. symptoms include icon jaggedness, weird looking fonts on desktop.

      This is just preliminary, I don't know what the real problem is that is causing something to be changed on deb uninstall, but it's something real.

      Installing an older driver does not appear to resolve this issue, which suggests that either a configuration file or some other xorg component was modified. Also mouse pointer was changed to 'an ugly' one, so something really changed on uninstall. We've never seen this particular issue before by the way.

      Pulling this driver until I can get this issue resolved, although users did report higher initial framerates etc, but it's not worth the damage it's doing on reinstall..

      Installs running and kernels.
      Last edited by gfxdrone; 18 April 2007, 09:12 PM.


      • #13
        Update: we've found that restoring the xorg ati driver makes the screen display correctly again. This sounds like the ati pre install uninstaller may be removing some file it's not supposed to be removing, and which fglrx needs but ati does not, since older fglrx drivers do not correct the display issues. I have the feeling that this may be enough information to figure it out, we're going to try to get a installed packages list diff between pre install and post install and pre reinstall and reinstall.

        Unless someone can think of anything else, that's all I can think to test now.
        Last edited by gfxdrone; 18 April 2007, 09:57 PM.


        • #14
          I installed the drivers on 3 different computers and 2 linux distros, and everything is working fine, 3d opengl, playing video and tv card. all works fine.

          AMD 3200+ Abit nf7, 1gB mem, 9600Pro agp, Fedora 6

          P4EE 3.73ghz Asus P5WD2 Premium, X700Pro pcie, Fedora Core 6

          P4R 550 (3.4ghz) Asus P5WD2 Premium, x850Pro pcie, Slackware 10.2
          Last edited by glussier; 19 April 2007, 12:22 PM.


          • #15
            What card do you have? I have absolutely no problems playing
            1080p videos on the mobility9600

            besides, disabling TexturedVideo, and keeping VideoOverlay on causes awful glitches with video playback (i think it appeared a couple of releases ago). i'll try tinkering with opengl overlay, then.


            • #16
              I also have X1300Pro and Ubuntu 7.04 AMD64 bit with a custom kernel. After installing the new driver no video playback program would start - the application window (tried totem and xine) would just pop up for a split moment and then close again without any log entries. I reverted back to 8.35 and video playback is there again.

              But the 8.35 driver is giving me headache because it randomly freezes the system but where I can repeat the freeze everytime is to use switch user option in Ubuntu. It does not happen with the first switch to other user but when switching back. The log says fglrx is having problems and needs restarting the system (the log I can look after I restart the frozen system).


              • #17
                I've to say, for me is this new 8.36.5 release a disaster.

                On the system start, my Xv is working well (xvinfo/xine-check).
                But if I try to play any video (mpg/avi/mov) with xine (using Xv), Xv corrupts.
                So xine crashed and after this corrupt, xvinfo and xine-check says, that Xv isn't supported. On rebooting I saw a little stacktrace of my X server and in the .xsession-errors, there were a few errors about Xvideo, like bad argument.

                I'm using Debian Sid, 2.6.18 deb Kernel and a PCI-E Sapphire Radeon 1650 Pro card.


                • #18
                  i *really* hope that they'll release a hotfix quickly, e.g. by the end of the month.


                  • #19
                    Originally posted by yoshi314 View Post
                    i *really* hope that they'll release a hotfix quickly, e.g. by the end of the month.

                    Don't count on it but 8.37 may be here early in May.
                    Michael Larabel


                    • #20
                      I manage to download and install the driver. So far, no noticeable problem.

                      Reading many replies so far, I guess I should consider myself lucky.