Announcement

Collapse
No announcement yet.

Radeon KMS bug causing wireless crashes, devs please help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon KMS bug causing wireless crashes, devs please help

    Attn: radeon devs, if you're here... thanks for all your hard work.

    There's an ongoing bug report on Launchpad, initially directed toward iwl3945, but it appears that the problem is actually with the radeon driver... wireless hangs/crashes during high GPU utilization (like video playback), but only occurs when kernel modesetting is turned on. With KMS off, the hardware runs normally. This seems to be some sort of regression, either in the kernel or in the driver.

    Here's the bug report: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/564376

    Please help... there are lots of folks out there with systems that are unusable unless they manually disable kernel modesetting. I'm one of the affected users, in my case on a Thinkpad T60 with X1400 and Intel wireless. There are also users reporting audio corruption under the same conditions as mentioned above, which disappears when KMS is disabled.

    Thanks for any help you can provide!


    Best regards,
    Jason Porter

  • evil_core
    replied
    I switched to KMS/Gallium and after airmon-ng running over 20ours no crash at all in KMS. I had only two blackscreens when playing Quake3 in Gallium/KMS/pageflip after reverting Obcene_CNN Mesa patch(which didnt applied fully - maybe its the reason). With this patch partially applied Quake3 hanged usually in less than minute. I am talking about Gallium, because Classic is generally broken with KMS PageFlip for r500(in xorg.conf). And with PageFlip disabled q3a is laggy in 1600x1200 and frame flow is not smooth. (with PageFlip it is for mine r500). In Classic/PageFlip theres often hang with OpenGL app(permament for fullscreen apps), in every GL window, and to eliminate it xorg restart is needed(and sometimes module reloading)

    Leave a comment:


  • evil_core
    replied
    I am probably also affected by that. I think I didnt had problem for a while with KMS and Gallium because of using ethernet only. Now airmon-ng is running half of a day, and KMS xorg hangs very early.

    I got UXGA T60p with FireGL V5200, and xorg 1.8.x, d-r-t and master DDX/Mesa/drm

    Leave a comment:


  • tomm
    replied
    Originally posted by agd5f View Post
    I'm not convinced this is the fault of the radeon driver. Seems more like it might be an irq or timer problem. Having radeon kms loaded may just aggravate it since it uses irqs and timers more than ums did.
    I hope this problem gets taken seriously. My laptop (Thinkpad T60) is virtually useless with radeon KMS enabled. I think the sound issues plus wireless ones together point the finger at Radeon KMS.

    Anyway, I'm running fine with UMS for the time being.

    Leave a comment:


  • Porter
    replied
    Originally posted by agd5f View Post
    Please try my suggestions on the bug report.
    Hi Alex, thanks for your help. I tried disabling msi, with no effect. In fact, the first time I booted with msi disabled it hung at the splash screen, but sorted itself out on the second boot cycle. Still drops wireless. Running with msi on and radeon kms disabled restores normal operation.

    Originally posted by agd5f View Post
    I'm not convinced this is the fault of the radeon driver. Seems more like it might be an irq or timer problem. Having radeon kms loaded may just aggravate it since it uses irqs and timers more than ums did.
    You are probably on to something there, but what sort of information do you need to test? I can provide logs if you let me know which ones you need.

    Leave a comment:


  • agd5f
    replied
    I'm not convinced this is the fault of the radeon driver. Seems more like it might be an irq or timer problem. Having radeon kms loaded may just aggravate it since it uses irqs and timers more than ums did.

    Leave a comment:


  • agd5f
    replied
    Please try my suggestions on the bug report.

    Leave a comment:


  • Porter
    replied
    Apparently it's slightly more serious than previously thought... users are reporting full kernel crashes when switching the wifi off using the hardware on/off switch. Disabling radeon KMS causes the behavior to disappear.

    https://bugs.launchpad.net/xserver-x...ti/+bug/555286


    Can any of the radeon devs chime in if they see this, to let me know if they're aware of this at all? Thanks!

    Leave a comment:


  • tomm
    replied
    Yes this is a very annoying bug. I can't even get on some wireless networks with radeon KMS enabled. Disable it and I get full bars, 80%+ connection quality.

    Thinkpad T60, Radeon X1300, iwl3945.

    Leave a comment:


  • Porter
    replied
    Ha, I just realized ?yvind is the one who posted earlier in this thread. Hi ?yvind! Thanks for the links and the good information, hopefully it will get in front of the right eyeballs with all the linking.

    Leave a comment:

Working...
X