No announcement yet.

TV-Out Lucid - Output S-video disconnected

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I also tested zaphod with KMS and found that xrandr doesn't play nice with DISPLAY=:0.1. I have to log out and back in when I plug the TV.

    First tests I made were on U64 karmic + 2.6.33 + xorg-edgers (few weeks ago). My HD3650 AGP (RV635) was able to drive a 1280x1024 LCD via DVI and a 1920x1080 TV via DVI->HDMI, but only if the TV was connected at boot, otherwise xrandr couldn't open display :0.1 like you.
    At the time, I did the same tests and had the same results on my laptop with an X1270 (RS690) (or actually worse considering the annoying issue with the mouse cursor able to go to display :0.1 but not back to :0.0).
    Then, after testing again with the laptop using today's packages (same results), I did an additional test: TV unplugged at boot -> auto-login (xrandr cannot open display :0.1) -> log out (TV starts displaying image) -> log in -> xrandr OK (lists supported modes) -> unplug TV -> xrandr KO? (see below) -> re-plug TV (image appears without having to use xrandr!)
    HDMI-0 disconnected 1920x1080+0+0 (normal left inverted right x axis y axis) 708mm x 398mm
    1920x1080 (0x7f) 148.5MHz
    h: width 1920 start 2448 end 2492 total 2640 skew 0 clock 56.2KHz
    v: height 1080 start 1084 end 1089 total 1125 clock 50.0Hz

    So it seems xrandr cannot enable or disable a screen on display :0.1, even when setting DISPLAY variable correctly (or at least I haven't gound a way to do so). Only logging out allows configuration of screens as per xorg.conf.

    In the meantime, I tested kde in lucid beta as I heard they are sorting out slowly their multi head support. I can hotplug fine any screen with a script and no xorg.conf. It's not zaphod mode, but IMHO virtual screen handling is a bit better than gnome: backgound image not stretched (and hence not corrupted beyond 2048), window maximizing ok, panel placement mostly ok, other single display benefits...

    Hope this helps



    • #12
      correct link for script


      • #13
        I've just tried radeon 6.13.0 driver release and this new release didn't solve neither of the problems mentioned.


        • #14
          doing anything dynamic with zaphod is a recipe for trouble. Zaphod support is basically just to support backwards compatibility with old static zaphod setups. If you want dynamic, don't use zaphod.


          • #15
            Originally posted by xeros View Post
            I've got simmilar problem with KMS and S-video.
            On my Lucid installation S-video gets disabled at boot time on KMS because of DAC encoders conflict:

            Do you know how to enable S-video even in clone mode of DVI output?
            Forced load_detection option doesn't enable it as it did on UMS - xrandr always tells it's disabled.
            The analog portion of the DVI port and the S-video port share the same DAC. You can't use both at the same time.


            • #16
              I've got a similar problem.

              I've got S-video (via composite) and DVI hooked up on my Radeon X1600 Pro (RV530), Kubuntu Lucid, radeon diver version 6.13.0.
              S-video works fine while I boot. Displays BIOS fine (skipping Grub because I set gfxmode=1280x1024), Plymouth shows up with some resolution issue, but I still get a decipherable image. As soon as X comes up, though the screen goes black.

              Xrandr says it's disconnected (which is crap), so I try to turn off load detection with "xrandr --output S-video --set load_detection 0", but xrandr says:
              X Error of failed request:  BadName (named color or font does not exist)
                Major opcode of failed request:  149 (RANDR)
                Minor opcode of failed request:  11 (RRQueryOutputProperty)
                Serial number of failed request:  27
                Current serial number in output stream:  27
              There's also this in dmesg:
              [ 3128.024415] [drm] 2: conflicting encoders switching off SVIDEO-1
              [ 3128.024419] [drm] in favor of DVI-I-1


              • #17
                Gah, hit the wrong button. Stupid edit window doesn't make it any better. Anyway...

                Originally posted by agd5f View Post
                The analog portion of the DVI port and the S-video port share the same DAC. You can't use both at the same time.
                My monitor is allegedly using the digital DVI signal, so shouldn't this work?
                The fact that I can get non-X video on S-video would seem to indicate (to me, someone without technical experience, at least) that it is possible...

                Also, I meant to add that I'm using KMS in my first post.


                • #18
                  for kms you want:
                  xrandr --output S-video --set "load detection" 0

                  Also check xrandr to make sure you have an S-video port listed. Some cards have a DIN port (used for both svideo and component), so the make sure you are using the right name for xrandr commands.

                  The digital part of the DVI port and TV can be used together, but it seems your setup is using the analog part. Your best bet is to file a bug ( and attach your xorg log, xrandr output, and dmesg output as I need more info to debug this further.


                  • #19
                    Has anyone here working (enabled) S-video output on 6.13.0 with KMS (like *Ubuntu Lucid) without Zaphod mode on R3xx?


                    • #20
                      this is a known bug

                      take a look here:

                      and this is seems like the bug here:

                      I'm just trying to understand how can I patch my system (I'm new to Ubuntu and Linux) so I can make use of this solution.

                      any help will be appreciated.