Announcement

Collapse
No announcement yet.

AMD Catalyst 10.3 For Linux Released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Can somebody check if this driver works with xorg 1.7?
    I am now using 10.4 beta ant wanted to try full release.

    Comment


    • #32
      Originally posted by pixo View Post
      Can somebody check if this driver works with xorg 1.7?
      I am now using 10.4 beta ant wanted to try full release.
      no it doesnt.

      BTW:
      And another interesting release came:


      Comment


      • #33
        Anybody notice if the backclear patch is still necessary or can I finally go back to my distros xorg release?

        Comment


        • #34
          You'll still probably want to use backclear until the new 2D acceleration is enabled by default.
          Test signature

          Comment


          • #35
            Originally posted by Kano View Post
            @Nille

            Not on BD but in lots of other content you get or encode yourself.
            And witch of this content need L5? For 99% L4.0 is more as enough. And i have see L5 only on Illegal content on P2P Sites. And if some one use it its most because its the highest Number

            Comment


            • #36
              Originally posted by Heiko View Post
              I hate them trolls and all this negativism in these topics.
              and i hate all those people whose stuff "just works" and they don't give a shit about anything or anyone else. doesn't matter thought, does it ?

              Originally posted by Heiko View Post
              It mostly comes from people who use unsupported kernels / xorg versions anyway.
              what is "unsupported kernels / xorg version" and by whom they should be "supported" so i could use it ?
              should i buy some insurance plan and go register with my documents somewhere to get my "support" ?

              Originally posted by Heiko View Post
              When do you guys learn that these are not supported?
              again, for some reason when i asking developers if something doesn't work right: "what should i do?", sneaky bastards always reply to "try newest version" and that previous "became deprecated and unsupported outside of your distribution's maintenance".

              that is, probably, because there is no "supported and unsupported" in F/OSS community but "stable and unstable"...
              and they both working. differently, but working

              Originally posted by Heiko View Post
              I bet if you all would send polite emails, asking (with good reasons) why you would like support for newer stuff in the drivers, it would have a lot more impact than this annoying monthly trolling.
              should i write an official petition letter with supplication to grant me permission in keeping system updated ?

              Originally posted by Heiko View Post
              Personally I found that the driver improvements that occurred over the last two years were mostly a positive experience. The overall improvements for the drivers are great. Keep up the good work AMD! And I trust the quality of the drivers will only improve more in the future.
              probably it did.
              two year ago on even older card i wasn't able to make those "drivers" operational for some time and then i did, it showed some scary pictures and died immediately.
              these days, probably, pictures are less scary.

              Originally posted by MaestroMaus View Post
              You could also commend ATI for giving specs and funding developers to make Open Source drivers...
              and you could agree with undeniable fact that X-blobs are horrendous.
              but nor i nor you did and this is not a thread about OSS depelopers or their awesomeness which they already know about.

              also, i will commend ATI jack shit since there is no ATI, there only AMD and it always rocked.

              Originally posted by MaestroMaus View Post
              But I agree that bitching about something is a much more pleasant thing to do.
              and i agree that moralize anyone is much more pleasant than admit the problem.

              Comment


              • #37
                What about Direct2D support ?

                In the previous article about the 10.2 version of these drivers, there was a mention about a configuration option to enable Direct2D support, and that it should be improved in the next 10.3 version.

                What about this now ? I don't see any mention of Direct2D support in the release notes or installation instructions...

                Comment


                • #38
                  Originally posted by JuLx64 View Post
                  In the previous article about the 10.2 version of these drivers, there was a mention about a configuration option to enable Direct2D support, and that it should be improved in the next 10.3 version.

                  What about this now ? I don't see any mention of Direct2D support in the release notes or installation instructions...
                  It is still there, it is still disabled by default and you can still enable it with the same instruction that were used for the 10.2 drivers.

                  Comment


                  • #39
                    I faced same problem at install than with 10.1.
                    Well not exactly the same. I mention I use the packaging system included in the catalyst with --installandbuildpkg Ubuntu/karmic. The problem is not local to Ubuntu though but to Debian also.

                    When installing with 9.12 installed, the driver compiled but failed to install.
                    After getting everything about fglrx uninstalled it then failed to compile. I though about installing 10.2 then 10.3 and it worked!! There're cross dependencies through drivers ! In which mess are they working in ?

                    It tried also publishing over their bugzilla, a Debian user had posted it first. But man, their bugzilla doesn't know any version after catalyst 9.7 !!!! o_O

                    After all of this I can notice big improvements in my case (HD 4850 512M)
                    - Compiz was unusable due to tremedous lags in 10.2, it's fixed.
                    - Video using gl2 extension get fixed lumina, damn I finally can enjoy true black without playing with loosy constrast controls ^-^
                    - Tomorrow I'll see if the "no ati card detected so let's crash" bug is fixed...

                    Comment


                    • #40
                      So far as I know, I'm running a reasonably supported environment (Ubuntu 9.10, X server updated from repos but not otherwise "new"). I haven't tried 10.3, though, because I haven't heard from anyone who had comparable lockups and saw them go away.

                      Comment

                      Working...
                      X