Announcement

Collapse
No announcement yet.

AMD Catalyst 10.3 For Linux Released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BlackStar
    replied
    Fake edit: siz means six.

    @Michael: please do something about that 1' edit window. Pretty please?

    Leave a comment:


  • BlackStar
    replied
    Originally posted by mugginz View Post
    I must say I'm a bit surprised people are having this issue with nVidia cards. [...]

    I'd be interested to hear from other nVidia users suffering from tearing to see if it can't be gotten to the bottom of.
    I have two nvidia setups, a laptop with a Quadro NVS 135M and a desktop with a 9500GS. For the sake of comparison, I will add the results for my 4850/fglrx and my X1950/radeon.

    Let's ignore dual-monitor setups for a moment because there's no way to get a tear-free desktop there (short of custom modelines to make the refresh rates match - and there's no guarantee that that will be possible).

    There are siz distinct cases that are interesting in the general case:
    1. non-composited desktop
    2. non-composited video playback (XV)
    3. non-composited OpenGL
    4. composited desktop
    5. composited video playback (XV)
    6. composited OpenGL

    For me, the situation looks like this:
    1. Visible tearing on both nvidia setups and fglrx. Tear-free on radeon.
    2. Little/no tearing on nvidia. Visible tearing on fglrx. Little/no tearing on radeon.
    3. No tearing on nvidia/fglrx when vsync is enabled through the driver. Visible tearing on radeon.
    4. Visible tearing on nvidia, fglrx and radeon regardless of vsync setting in the drivers. If enable vsync in compizconfig-settings-manager I get slightly reduced tearing on nvidia (moving a window will usually tear for the first second then stop tearing). Fglrx/radeon tearing remains as before.
    5. Visible tearing on all drivers.
    6. Visible tearing on all drivers.

    For me, flash playback falls under categories 2 and 4 (always tears with compiz, sometimes doesn't tear without compiz).

    KWin might be using a different redraw method than Compiz, i.e. full composition and glXSwapBuffers every frame. In that case, the desktop should be always tear-free (provided your driver supports vsync). I don't know whether tear-free XV/OpenGL could be guaranteed then (maybe but probably not, given the current limitations).

    This document outlines what should be done for proper vsync under all circumstances. I would dearly love to see this feature bumped in priority.

    Leave a comment:


  • chronniff
    replied
    With all that said, then why is it on my old dell inspiron, that has an integrated intel video card using the old 915 module, doesn't suffer from any of the video tearing issues that I get with my new ati 5770.....If I recall it used to have those issues before intel switched to UXA 2d acceleration....

    Leave a comment:


  • mugginz
    replied
    Originally posted by BlackStar View Post
    I get the same tearing on Intel and Nvidia drivers, so don't expect miracles. This is a good summary of the situation:

    Alright, so there are actually a couple issues here. Let me see if I can clear them all up.

    1) nVidia's OpenGL Sync to VBlank option only affects glXSwapBuffers but we don't use it. In order to use this option we would have to do a full screen redraw every frame and while AaronP might think this isn't a problem we don't all have nVidia graphics cards. Even if we did use this option it would only help compiz and not any videos or OpenGL applications compiz is managing. There is currently no way to ensure such things are flicker free when using any compositor as you don't want to sync to vblank but to the compositor's redraw rate. As you cannot get this information from the compositor there is no way to even try to do this. See http://dri.freedesktop.org/wiki/CompositeSwap for all the gory details.

    That pretty much wraps it all up, actually. Just a couple more little notes.

    2) The compiz way of doing sync to vblank doesn't guarantee vsync if your computer is under heavy load. There is no way to fix this with what we have available right now. It also "fights" with the nvidia-settings sync to vblank option.

    3) We don't enable sync to vblank in compiz by default because in the past it caused suspend/resume issues with nvidia cards and right now it causes intel users to get about 0.5 frames per second. Even if we did enable it by default it wouldn't help with the issues most of you seem to be having.
    Source: https://bugs.launchpad.net/ubuntu/+s...87/comments/17
    I must say I'm a bit surprised people are having this issue with nVidia cards. I was running Compiz on an nVidia 8600GT for a while and then upgraded to a 9800GT. After a while I added a second screen to the 9800GT. I didn't suffer from tearing when using sync to vblank. Then when KDE 4.1 was released I started using that as the compositor and that also doesn't display tearing with sync to vblank. I'm able to playback video with Mplayer, Kaffeine, VLC, SMPlayer and Xine all without any tearing whatsoever. Also I have no tearing with wobbly windows or any of the other effects in Kwin.

    If you are using two screens and one has a different refresh rate to the other, even if it's only very small, you will get tearing on one of the screens but I am using two screens with the same refresh so I don't get tearing on either screen.

    Surprisingly even full screen video playback with Flash is also tear free. I'd be interested to hear from other nVidia users suffering from tearing to see if it can't be gotten to the bottom of.

    Leave a comment:


  • BlackStar
    replied
    Originally posted by chronniff View Post
    actually I take it back, after a few hours of tinkering I have found that setting the vsync on it actually does fix a lot of stuff...just not the painting of the windows, so wobbly windows of course tears like a bastard (also tears without wobbly windows). I expect this is a 2d rendering issue, and I guess all I can hope is that the direct2d being worked on will fix this issue...0
    I get the same tearing on Intel and Nvidia drivers, so don't expect miracles. This is a good summary of the situation:
    Alright, so there are actually a couple issues here. Let me see if I can clear them all up.

    1) nVidia's OpenGL Sync to VBlank option only affects glXSwapBuffers but we don't use it. In order to use this option we would have to do a full screen redraw every frame and while AaronP might think this isn't a problem we don't all have nVidia graphics cards. Even if we did use this option it would only help compiz and not any videos or OpenGL applications compiz is managing. There is currently no way to ensure such things are flicker free when using any compositor as you don't want to sync to vblank but to the compositor's redraw rate. As you cannot get this information from the compositor there is no way to even try to do this. See http://dri.freedesktop.org/wiki/CompositeSwap for all the gory details.

    That pretty much wraps it all up, actually. Just a couple more little notes.

    2) The compiz way of doing sync to vblank doesn't guarantee vsync if your computer is under heavy load. There is no way to fix this with what we have available right now. It also "fights" with the nvidia-settings sync to vblank option.

    3) We don't enable sync to vblank in compiz by default because in the past it caused suspend/resume issues with nvidia cards and right now it causes intel users to get about 0.5 frames per second. Even if we did enable it by default it wouldn't help with the issues most of you seem to be having.
    Source: https://bugs.launchpad.net/ubuntu/+s...87/comments/17

    Leave a comment:


  • chronniff
    replied
    actually I take it back, after a few hours of tinkering I have found that setting the vsync on it actually does fix a lot of stuff...just not the painting of the windows, so wobbly windows of course tears like a bastard (also tears without wobbly windows). I expect this is a 2d rendering issue, and I guess all I can hope is that the direct2d being worked on will fix this issue....I also noticed with he aticonfig --odgc that when i use any 3d compositing effects that it is using the full clock of the card, where as before while it would increase it, it wouldn't use the entire 850 mhz (core) and 1200 mhz (memory)...So it seems as though they have in fact improved the power management of my 5770

    Leave a comment:


  • chronniff
    replied
    I just tried all settings and even rebooted after every time, none of the settings seem to help much if at all

    Leave a comment:


  • chronniff
    replied
    I changed them from off unless application specifies to on unless application specifies....should I change it to always on?

    Leave a comment:


  • PsynoKhi0
    replied
    Originally posted by chronniff View Post
    is there any way to install the lucid beta on karmic? and also the biggest problem I have with tearing is with compiz enabled....the opengl in mplayer seems to mostly work for tear free video, but as far as on my desktop the tearing is awful...actually it is bad with or without compiz enabled, just more noticeable with the desktop effects enabled
    Have you changed the vsync settings?

    Leave a comment:


  • chronniff
    replied
    is there any way to install the lucid beta on karmic? and also the biggest problem I have with tearing is with compiz enabled....the opengl in mplayer seems to mostly work for tear free video, but as far as on my desktop the tearing is awful...actually it is bad with or without compiz enabled, just more noticeable with the desktop effects enabled

    Leave a comment:

Working...
X