No announcement yet.

Hybrid ATI/ATI - Intel/ATI solution: small switcheroo how to

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by rmartinez View Post
    In my case (ASUS M51Ta - HD3200 / HD3650), I even don't have a xorg.conf and the switcheroo works fine.

    @Ryushin: Just something important: if you are going to compile your own kernel to test don't forget to copy "R600_rlc.bin" and "R700_rlc.bin" (radeon firmware files) to /lib/firmware/radeon/ before your compilation. You can fin them at
    Thank you for the link to the files. I had not done that yet. I'll be testing this morning.


    • #12
      Well, I got to say I'm pretty excited about this. I got this to work to a limited degree.

      I ran into one issue with the /sys/kernel/debug/vgaswitcheroo not showing up when you mount /sys/kernel/debug. The issue was resolved after digging further and finding out the KMS has to be enabled on both the Intel and ATI drivers. I was disabling the KMS on the ATI driver because the power management does not work with KMS enabled.

      Now this is the problem that I've encountered and I boot into single user mode to test this:

      Upon boot up, both the Intel and the ATI card are powered up and the Intel card is the primary. Everything works find. I can start X and glxinfo shows DRI is working fine.

      Switching to the ATI card works fine using:
      echo "DDIS" > /sys/kernel/debug/vgaswitcheroo/switch

      I think I started X as well and it also worked. But I can't remember at this point.

      Now comes the problem. If I switch back to the Intel card using:
      echo "DIGD" > /sys/kernel/debug/vgaswitcheroo/switch
      it powers off the ATI card. Once the ATI card has been powered off, switching to it again shows a blank screen. It even seems as if the back light is turned off as well.

      So I've troubleshooted some more. If the ATI card is ever powered off, it's not possible to reconnect to it again and have the screen work. Steps I've taken to troubleshoot:

      Method 1:
      Fresh Boot
      echo "OFF"> /sys/kernel/debug/vgaswitcheroo/switch
      ATI card is now turned off.
      echo "On"> /sys/kernel/debug/vgaswitcheroo/switch
      ATI card is now turned on.
      echo "DDIS" > /sys/kernel/debug/vgaswitcheroo/switch
      Result is a blank screen with I think the black light turned off.

      Method 2:
      Fresh Boot
      echo "DDIS" > /sys/kernel/debug/vgaswitcheroo/switch
      Everything works correctly as the ATI card is swiched over. The Intel graphics is powered off at this point.
      echo "DIGD" > /sys/kernel/debug/vgaswitcheroo/switch
      Everything works correctly as the Intel graphics is turned on and the screen switches over to it. The ATI card is powered off at this point.
      echo "DDIS" > /sys/kernel/debug/vgaswitcheroo/switch
      Switching to the ATI card again results in a blank screen.

      So the problem seems to be, once the ATI card is powered off even once, I can never switch to it again and have the screen work.

      Any ideas or debugging issue I should post?


      • #13
        Oh as a side note, I can now run switchable graphics in the BIOS and have the ATI graphics powered off while using Intel graphics. The problem was before that the ATI graphics would remain on and in a full speed mode using a lot of power and making the laptop quite hot. At least now I can power down the ATI card while using the Intel graphics and have the laptop remain nice and cool. So even this is a nice feature for me.


        • #14
          it really DOES work! awesome!

          battery performance increased from 1h to 2h (as in windows)

          although the command "install mkinitrd" didn't work.
          install mkinitrd
          install: missing destination file operand after `mkinitrd'
          Try `install --help' for more information.
          thank you!


          • #15
            however suspend mode does not work. fan is running at full speed and the display stays blank.

            Anyone else experiencing the same problem? (asus m51ta (hd 3200 + hd 3650))


            • #16
              I think "install mkinitrd" wasn't a command


              • #17
                Both TuxOnIce head (AKA Suspend2) and ACPI S3 (echo "3" > /proc/acpi/sleep) work fine for me on the Thinkpad W500.


                • #18
                  Oh, I'm running Debian with tuxonice-head which is currently 2.6.33-rc8. I'm also running the Debian experimental xserver, intel, radeon, and mesa packages.

                  One interesting problem with the suspend, is that the ATI card seems to power itself back on after a hibernate. Though the debug thought it was off:
                  cat /sys/kernel/debug/vgaswitcheroo/switch
                  1: :Off:0000:01:00.0

                  Doing another:
                  echo "ON" > /sys/kernel/debug/vgaswitcheroo/switch
                  echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch

                  Seems to have powered off the ATI Graphics and the laptop is running cool again. I'll probably have to add that to my tuxonice resume information.


                  • #19
                    Originally posted by Wielkie G View Post
                    I think "install mkinitrd" wasn't a command
                    Ok, that would explain the error message

                    Hibernate works, but the fan stays at full speed.
                    btw: suspend and hibernate didn't work before, so I guess it's an issue with "mesa-dri-drivers-experimental". However without this switcheroo the fan would stay at normal speed. But both modes worked untill I installed "mesa-dri-drivers-experimental".


                    • #20
                      Hi, I'm pleased the HowTo was of some use. Here is an updated one I have just made:

                      As soon as I have more time I will make it look nicer

                      About "install mkinitrd", it was meant to say "sudo yum install mkinitrd"