No announcement yet.

AMD Catalyst 10.1 Driver For Linux Released

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by aromanos View Post
    It's very disappointing that packages don't build on Ubuntu 9.10 x86_64. Production support added... yeah sure.

    Anyway, this worked for me:

    chmod +x ./

    ./ --extract

    cd fglrx-install.xxxx/arch/x86_64/usr/lib64/
    (Replace "fglrx-install.xxxx" with the name of the directory that the installer created on your system)

    ln -s

    cd ../../../..

    sudo ./ 10.1 --buildandinstallpkg Ubuntu/karmic


    Happy building,

    -- Andr?s
    Thanks, it works.


    • #62
      any patch or hint how to compile 10.1 on Gentoo ?

      I updated the ebuild according to the patch in following bug:

      unfortunately the patch mentioned in the bug: 2.6.32-9.11-fix_compilation.patch


      2.6.32-9.12-fix_compilation.patch (in renamed form)

      doesn't seem to work anymore or I'm running into another kind of problem:

      CC [M] /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
      CC [M] /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
      In file included from /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:449:
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/drm_proc.h: In function ?FGLDRM__vma_info?:
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:497: warning: format ?%08lx? expects type ?long unsigned int?, but argument 5 has type ?phys_addr_t?
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ?KCL_SetPageCache_Array?:
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1322: warning: passing argument 1 of ?KCL_ConvertPageToKernelAddress? makes pointer from integer without a cast
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.h:337: note: expected ?void *? but argument is of type ?long unsigned int?
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ?__ke__cmpxchg?:
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1479: error: variable or field ?__ret? declared void
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1479: error: variable or field ?__old? declared void
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1479: error: variable or field ?__new? declared void
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ?KCL_MapPageToPfn?:
      /var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1621: warning: unused variable ?bus_addr?
      make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
      make[2]: *** Waiting for unfinished jobs....
      make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-10.1/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
      make[1]: Leaving directory `/usr/src/linux-2.6.33-rc5-zen1_bfs'
      make: *** [kmod_build] Error 2
      * ERROR: x11-drivers/ati-drivers-10.1 failed:
      * Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= GCC_VER_MAJ=4 KVER=2.6.33-rc5-zen1 KDIR=/usr/src/linux kmod_build
      * Call stack:
      *, line 48: Called src_compile
      * environment, line 8045: Called linux-mod_src_compile
      * environment, line 7201: Called die
      * The specific snippet of code:
      Help please !



      • #63
        openSUSE 11.2 results

        Just a message for the non-ubuntu fans:
        Installed the Catalyst 10.1 on openSUSE 11.2/64 on an HP Elitebook 8530p and......
        (suspense building)

        It worked! This is the first Catalyst driver that actually worked since I've had the Elitebook, and boy I tried them all.

        Now I go and enjoy my KDE desktop effects. Please do not disturb me.


        • #64
          Originally posted by tball View Post
          10.1 doesn't work with opencl. Just tried :-). You have to use 9.12 hotfix.
          Hmmm... but shouldn't 10.1 be newer than 10.1 hotfix?
          And what about xvba?


          • #65
            Originally posted by aromanos View Post
            ln -s
            Thanks for that!

            FYI, if anyone's building on the Karmic 2.6.31 RT kernel, you need fix up some line references on the DKMS patch:
            in fglrx-install.XXXXXX/packages/Ubuntu/dists/karmic/dkms/patches/rt_preempt_31.patch , change the line:
            @@ -4998,7 +5005,11 @@ unsigned int ATI_API_CALL KAS_Mutex_GetO
            @@ -5038,7 +5045,11 @@ unsigned int ATI_API_CALL KAS_Mutex_GetO


            • #66
              Install Guide on Ubuntu Karmic

              I got the Catalyst 10.1 working on Karmic x86.
              There are to methods to to this:

              sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libQtGui4
              sudo wget
              sudo chmod +x ./
              ./ --extract
              cd fglrx-install*/arch/x86/usr/lib/
              ln -s
              cd ../../../..
              sudo ./ 10.1 --buildpkg Ubuntu/karmic
              sudo dpkg -i *.deb
              sudo aticonfig --initial -f
              sudo reboot


              sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libQtGui4
              sudo wget
              sudo chmod +x
              sudo sh ./
              --> handle through installation --> automatic
              sudo aticonfig --initial -f
              sudo reboot

              The Catalyst 10.1 is working very fine. For me the first catalyst without tearing by playing XV-Videos.
              But now I have another problem. My PC is connected via a AV-Receiver to my Plasma-TV.
              Catalyst detects the AV-Receiver as an projector.
              In CCC I do not have the Under-/Overscan Controls. I think the problem is that he thinks it is an projector so its disabled.
              Now I have black edge around my tv.
              In CCC 9.12 I had the same problem. CCC 9.11 and older ones were working fine with the under-/overscan tab in CCC.

              Does everyone also have this problem?


              • #67
                [QUOTE=Steo;110202]I got the Catalyst 10.1 working on Karmic x86.
                None cared about architecture :

                if you are x86 :
                ./ --extract
                cd fglrx-install*/arch/x86/usr/lib/
                ln -s
                cd ../../../..
                sudo ./ 10.1 --buildandinstallpkg Ubuntu/karmic

                if you are x86_64 :
                ./ --extract
                cd fglrx-install*/arch/x86_64/usr/lib64/
                ln -s
                cd ../../../..
                sudo ./ 10.1 --buildandinstallpkg Ubuntu/karmic

                Then should work for everyone


                • #68
                  Broken xorg failsafe

                  Has anyone noticed the driver crashes if ati card is not there? And nothing else than power switch can get it out...
                  Hopefully ext4 filesystem is prety tough!

                  Xorg failsafe is vital for me as I move my hardrive between home and work...

                  No other way but to downgrade to 9.12...

                  Thank you very much AMD for your official Ubuntu Karmic support, just love it!


                  • #69
                    Installed fine and working without problems on Opensuse 11.2 and 11.1 (both 64bit).

                    Hope to see some real improvements soon....


                    • #70
                      xorg support

                      What's wrong with you AMD? By the time you start supporting xorg server 1.7, the 1.8 will be out!