Announcement

Collapse
No announcement yet.

KMS + Radeon quick mini guide

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • pheldens
    started a topic KMS + Radeon quick mini guide

    KMS + Radeon quick mini guide

    update 2009 12 23 added some ideas from the comments and kernel stuff for drm radeon testing


    Since the dri wiki left some holes here's a short guide that worked for me.

    Kernel =/> 2.6.32 works

    build with dri/drm/radeon built in to avoid module probing order issues.
    do not use any FB options, these potentially conflict with KMS.

    for interrupts you need last kernel drm and a special extra kernel firmware

    obtain last drm and git linux kernel tree (about 1GB download)
    (this is quite big, drm-radeon-testing appears to be 2.6.32 plus the drm patches at moment of writing)

    Code:
    git clone git://git.kernel.org/pub/scm/linux/kernel/git/airlied/drm-2.6.git
    git checkout -b drm-radeon-testing origin/drm-radeon-testing

    Obtain R700_rlc.bin and built it in your kernel, or put it in firmware/radeon/ to load.
    Either way make sure the kernel loads it at boot, else it will stall for 20s and fail to load it, dont panic it will boot further eventually so you can correct things.







    force kms on in grub menu.lst:
    Code:
    kernel /boot/bzImage radeon.modeset=1
    (also available as modprobe radeon modeset=1
    but using modules gave me issues, modprobing drm first was reported to help in some cases)

    Checkout and build git drm,xf86-video-ati (aka ddx),mesa

    Code:
    git clone git://anongit.freedesktop.org/mesa/drm
    git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-ati
    git clone git://anongit.freedesktop.org/mesa/mesa
    The first time you have to autogen inside the respective trees, to generate configure files, install missing proto files and other dependencies when needed.

    Now build it in this order:

    Code:
     > cat builddri 
    #!/bin/sh
    
    cd drm
    make clean
    git pull
    ./configure --enable-radeon-experimental-api --disable-intel && make && make install
    cd ..
    
    
    cd xf86-video-ati
    make clean
    git pull
    ./configure && make && make install
    cd ..
    
    cd mesa 
    make clean
    git pull
    
    # to enable opengl 2 beta code for r600
    # export CFLAGS="$CFLAGS -DR600_ENABLE_GLSL_TEST"
    # this is now the default since december 2009
    
    ./configure --with-dri-drivers=r600 --disable-gallium && make && make install
    cd ..
    Adjust r600 to your card family radeon,r300,r500 etc (see configure --help)

    If everything built without error you can restart xorg.
    Have fun.
    Last edited by pheldens; 12-24-2009, 06:10 AM.

  • DanL
    replied
    Originally posted by Alexiy View Post
    Yeah, I know that since I simply haven't found that option
    My post was not directed at you, but rather at the OP.

    Leave a comment:


  • Alexiy
    replied
    Yeah, I know that since I simply haven't found that option

    Leave a comment:


  • DanL
    replied
    You no longer need --enable-radeon-experimental-api flag when building drm. It is now enabled by default: http://cgit.freedesktop.org/mesa/drm...065394111f6122

    Leave a comment:


  • Alexiy
    replied
    Hi,

    I'm wonder if compiz, using KMS, should run smoothly on HD3200?

    I have such behavior, only when compiz is up:

    - for example if I have two windows open and I'm changing focus from one window to other, my OS slows down significantly. After a few seconds everything is normal again. I can move the window, the wobbly windows effect works smoothly.

    - or other example, in any case w/ or w/o compiz: I have a picture frame widget on my desktop configured for slide show. And when pictures are changed there, I get the same freeze, and after a few seconds everything is ok again.

    Other things like video playback, desktop composition works well with KMS and DRI2.

    my system is:
    kernel - 2.6.33-rc8
    drm, mesa recently from git
    ati - just updated today
    Slackware x86_64

    Thank you for answering me.

    Leave a comment:


  • tettamanti
    replied
    Originally posted by Alexiy View Post
    I would like to ask, if there is any way to switch on/off KMS w/o recompiling a kernel with "radeon default KMS on" option?

    /etc/modprobe.d/radeon.conf
    radeon.modeset=[01]

    doesn?t work for me.
    The proper sintax would be:
    Code:
    options radeon modeset=0
    but it works only if the driver is build as module; otherwise you have to pass radeon.modeset=0 on the kernel command line.

    Leave a comment:


  • Alexiy
    replied
    Hello,

    I would like to ask, if there is any way to switch on/off KMS w/o recompiling a kernel with "radeon default KMS on" option?

    /etc/modprobe.d/radeon.conf
    radeon.modeset=[01]

    doesn?t work for me.

    Leave a comment:


  • mdias
    replied
    I've got it working in Arch with rc4, but I can't seem to be able to connect a monitor using a DVI-HDMI cable. I have to use a DVI-VGA cable instead.

    Didn't have any problems before, using 2.6.32 kernel.
    Last edited by mdias; 01-23-2010, 11:38 AM.

    Leave a comment:


  • pheldens
    replied
    forum1793 that was my feeling too, kms is slower in 3d
    but everybody says its faster..
    too lame to test it though oops ;p

    Just got me a phenom II X4 3.4Ghz this improved UT2004 quite a bit (+10-20% fps estimate) over the previous Athlon 64 X2

    Leave a comment:


  • forum1793
    replied
    OK, that worked. I must not have read close enough before as I put the files at /lib/firmware and not in the src kernel firmware directory.

    So it switches into kms about 1-1.5 seconds into startup whereas as a module it would do it about 4 seconds into startup.

    I don't notice any increase in 3D between these 2 based on glxgears and urbanterror. I think it was slightly faster before kms but I don't really have anything to base that on other than the way the games feels to me.

    Still have the stuttering problem in xine with audio over hdmi. See my other post for that.

    Leave a comment:

Working...
X