Announcement

Collapse
No announcement yet.

AMD Catalyst 9.11 For Linux Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Wired problem

    I have a wired problem with this driver (9.11). I have a HD5770 card and it's works fine with 2.6.30 kernel. But when I updated to 2.6.31 the X start hangs with a black screen, and I cannot even switch to a terminal, I have to reset (SysRq) the system. The X.Org or kernel log doesn't show any error. The kernel config is basicly the same, I disabled some deprecated USB thing and added a lm_sensor, but thats all the changes between the two configs.

    This is from the end of the Xorg.log file. There is nothing more after this.

    (II) fglrx(0): [drm] DRM interface version 1.0
    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
    (II) fglrx(0): [drm] mapped SAREA 0x2000 to 0x7f69089bc000
    (II) fglrx(0): [drm] framebuffer handle = 0x3000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0): Name: fglrx
    (II) fglrx(0): Version: 8.67.4
    (II) fglrx(0): Date: Nov 4 2009
    (II) fglrx(0): Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0): Build-Kernel UTS_RELEASE: 2.6.31-gentoo-r6
    (II) fglrx(0): Build-Kernel MODVERSIONS: no
    (II) fglrx(0): Build-Kernel __SMP__: yes
    (II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
    (II) fglrx(0): [drm] register handle = 0x00004000
    (II) fglrx(0): DRI initialization successfull!
    (II) fglrx(0): FBADPhys: 0xf01040000 FBMappedSize: 0x01008000
    (II) fglrx(0): FBMM initialized for area (0,0)-(1728,2432)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1728,1050) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1728 x 1382

    Is there some bugzilla, where I can report this officially?

    Comment


    • #62
      9-11 is one of those monthly releases that basically nobody needs. If they would have got reused the 9-10 release with updated controls file it would have been better.

      Comment


      • #63
        After of a couple of reboots, and a reemerge of the ati-drivers, now it's working on 2.6.31, but causes the same black screen/hang on the older 2.6.30 kernel. I don't know what solved the problem, because I did not change any configuration et all, and the emerge was successful the first time. My guess that a successful shutdown on 2.6.31 regenerated some modules database or something for 2.6.31, and now the userland is working fine with that kernel version.

        I wanted to upgrade the kernel, so the errors with the older kernel is not a big problem now.

        Comment


        • #64
          There is a trivial fix for .32 kernel if you want to update.

          #include <linux/signal.h>

          is needed in kcl_io.c. (Fix already in Debian fglrx package and in my script.)

          Comment

          Working...
          X