No announcement yet.

Radeon HD3870 Catalyst 9.9/9.10 black screen and freeze

  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon HD3870 Catalyst 9.9/9.10 black screen and freeze


    I have an issue with fglrx driver since release of Catalyst 9.9.
    Before that the driver worked correctly however when I install Catalyst 9.9 or 9.10 and reboot then the system loads until X starts and then all I can see is a black screen and I can't even switch to text console however when I press the power button on my box then the system seems to start shut down procedure and really shuts down after some time.
    The OS I noticed this issue for the first time was Ubuntu 9.04 (amd64) however it persists on Ubuntu 9.10 (amd64) as well. I have also installed and tested on Ubuntu 9.10 (i386) but there was no improvement.

    Moreover I have noticed that it seems to be related to the fglrx kernel module because when I installed kernel 2.6.32 (from daily builds) and the module didn't compile automatically for this kernel then I got my X back however it was very slow.

    The reason I need to stick with fglrx is that this is the only driver which displays HDMI output correctly on my plasma screen and with open source drivers I only get an "Invalid Format" message on the plasma screen).

    Anyone face the same issue?
    Do you have any idea what the reason for that might be?
    Maybe someone managed to resolve this issue?

    Any information greatly appreciated.
    Last edited by maciejus; 21 November 2009, 09:53 PM.

  • #2
    I have the exact same issue as do many other people. Can't understand why it runs for some and for some not.

    The Catalyst 9.8 runs fine (64 bit system). With opensuse 11.1 and with a litte patching also on opensuse 11.2. I tried a HD3870 and a HD4850. Bot no go.

    Catalyst 9.9, 9.10 and the beta 9.11 crash on loading X. They install fine and a modprobe on fglrx loads the module. X still crashes.

    I and several others have reported it on many sites. As there is no obvious place to report it. I don't know what to do.

    Hopefully someone from ATI reads this or maybe someone knows where to report this error.

    Internet links that i know of:

    This is about patching the old 9.8 since the new ones dont work:


    • #3

      Many thanks for confirmation that I'm not the only one who faces this problem. Thanks for the links as well however I think that is not exactly the same as I can't even switch to text console by Ctrl+Alt+F1

      I have also tried 9.11 beta and the problem persist and I'll try 9.11 today however I doubt it solves the issue.

      On the other hand is there anyone who managed to run the recent catalyst successfully? Can you provide your configuration? Maybe this way we will be able to figure out why it doesn't work for us?


      • #4
        I'm also facing the same problem but with 9.11 on opensuse 11.2 64bit.

        I have tested on two different systems running opensuse 11.2 with HD4670. On both systems 9.11 installs fine, modules is loaded ok but system freezes as soon as X is loaded.

        On both systems 9.10 works flawlessly.

        Also 9.11 runs fine on opensuse 11.1 with HD3200.


        • #5
          I can confirm that there is no improvement on the officially released Catalyst 9.11.
          I have created a new bug report for that as I wasn't sure if similar bugs reported already are related to the same root cause. I have collected quite large amount of data so I'm hoping it will help someone to finally eliminate this problem.
          The link to bug report is - feel free to comment.


          • #6
            I have this issue with HD2600 in fresh 64-bit Gentoo installation. Total freeze if I try use 9.9, 9.10 or 9.11 version of driver. In the same PC older 32-bit installation with version 8.6 of fglrx works fine.