No announcement yet.

AMD Catalyst 9.11 leaked!

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    ATI's download page for the current version:

    still doesn't support --buildpackage Ubuntu/9.10, so had to use Ubuntu/karmic. So probably not fully working for the final release of Karmic, still.

    Haven't rebooted yet, but I'm hoping it will fix opengl for 64bit programs.
    fglrx on AMD64 Karmic works (partly) for me, with a 4670 desktop card. I don't see any kernel crashes or boot problems. OTOH, I boot up in text mode with no splash-screen crap of any kind, so when I run startx, it's from VGA text mode, and the video card wasn't in any other mode from POST until then. (text grub, and no splash boot for the kernel either. console-setup or something loads a new VGA font, but that's all.) So perhaps the crashes you're seeing are because the card is in a diff...

    Nope, still broken on AMD64 Ubuntu 9.10.
    $ fglrxinfo
    Error: couldn't find RGB GLX visual!
    Visual ID: 23  depth=24  class=TrueColor
        bufferSize=4096 level=0 renderType=ci doubleBuffer=0 stereo=1258649631
        rgba: redSize=684153483 greenSize=0 blueSize=1258649631 alphaSize=0
        auxBuffers=0 depthSize=694153503 stencilSize=0
        accum: redSize=1258649631 greenSize=0 blueSize=694153503 alphaSize=0
        multiSample=0  multiSampleBuffers=0
    Does ATI have a bug tracker? I assumed they already knew about this with 9.10, and would fix it for 9.11.

    duh, yes, linked from the download page.
    Last edited by Peter_Cordes; 19 November 2009, 01:00 PM.


    • #22
      AMD Catalyst 9 11 leaked

      thank you very much.
      how does it looks with a new release of a bios update for the CPU?


      • #23
        Originally posted by atroftDiative View Post
        thank you very much.
        how does it looks with a new release of a bios update for the CPU?

        If you're replying to me, then the problem was that --buildpkg is broken, but --install works.

        There seems to be a packaging bug in Catalyst that bites Ubuntu 9.10. I previously added comments to bug 464525, but ATI's Felix Kuehling thinks that's actually a separate bug. I also reported this to ATI already:, where Felix got me to try the --install method of installing the drivers, which worked. (Thanks.) So I'm filing this new bug; I hope the tags I selected are ok. On an AMD64 Karmic system, fglrx installs and works fine (2D desktop, a...
        Last edited by Peter_Cordes; 28 November 2009, 03:39 PM.