No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by DivineGrace View Post
    By the way, Gbeauche, when you have time, can you update your svn version of mplayer that is on your web site? Thanks

    I tried to manually patch the latest (as of yesterday) svn mplayer source with vaapi patches from your mplayer version, but most hunks failed.
    I have a version from August but didn't have the time to work further on it. Actually, the plan was to at least add HQ scaling. Advanced deinterlacing and postprocessing (denoise, sharpness, etc.) through VA-API will come later then. Though, those would only work with Intel and NVIDIA HW since ATI has nothing properly exposed, and unlikely to have anything.


    • Good Morning.
      As a newbie in this forum (but a long time thread follower), I'd like to tell in my first post the following:

      I don't know very much how to help you Mr.gbeauche, but since Catalyst 10.7, my Mobility Radeon HD2600(M76) is not able to decode H264 videos properly anymore.
      The video output appears completely garbled. After about 7/8 seconds, mplayer outputs that "Your System is Too Slow to Play This!"
      Also, like zelda32 said, I'm always having the "Unsupported PixelFormat 61" problem.

      This problem doesn't happen with VC-1 Videos (they're playing properly), although I'm always receiving the message said above ("Unsupported PixelFormat 61").

      My Mplayer output is the following with H264 videos (I'm using an ArchLinux customized package with "shared" ffmpeg (with VAAPI support enabled)): [my mplayer is in Portuguese =( ]

      mplayer -vo vaapi -va vaapi -ao alsa Downloads/vaapi_samples/PlanetEarthBirds.mkv
      MPlayer SVN-r32025-4.5.1 (C) 2000-2010 MPlayer Team
      159 audio & 342 video codecs
      Reproduzindo Downloads/vaapi_samples/PlanetEarthBirds.mkv
      Detectado formato de arquivo libavformat!
      [matroska,webm @ 0xc8afa0] Estimating duration from bitrate, this may be inaccurate
      [lavf] stream 0: video (h264), -vid 0
      [lavf] stream 1: audio (ac3), -aid 0, -alang eng, Main
      [lavf] stream 2: subtitle (unknown), -sid 0, -slang eng, 1
      [lavf] stream 3: subtitle (unknown), -sid 1, -slang fre, 2
      [lavf] stream 4: subtitle (text), -sid 2, -slang spa, 3
      VIDEO: [H264] 1920x1080 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
      libva: libva version 0.31.1
      Xlib: extension "XFree86-DRI" missing on display ":0.0".
      libva: va_getDriverName() returns 0
      libva: Trying to open /usr/lib/dri/
      libva: va_openDriver() returns 0
      ================================================== ========================
      Abrindo decodificador de v?deo: [ffmpeg] FFmpeg's libavcodec codec family
      [VD_FFMPEG] VA API accelerated codec.
      Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
      ================================================== ========================
      ================================================== ========================
      Abrindo decodificador de audio: [ffmpeg] FFmpeg/libavcodec audio decoders
      AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
      Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
      ================================================== ========================
      AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
      In?ciando reprodu??o...
      Unsupported PixelFormat 61
      [VD_FFMPEG] Trying pixfmt=1.
      Aspecto do filme ? 1.78:1 - pr?-redimensionando para corrigir o aspecto do filme.
      VO: [vaapi] 1920x1080 => 1920x1080 H.264 VA-API Acceleration
      [VD_FFMPEG] XVMC-accelerated MPEG-2.
      A: 6.1 V: 2.1 A-V: 3.982 ct: 0.040 0/ 0 114% 218% 6.9% 50 0

      ************************************************** *
      * Seu sistema ? muito LENTO para reproduzir isto! *
      ************************************************** *

      Poss?veis raz?es, problemas, solu??es:
      - Mais comum: driver de _audio_ quebrado/falho
      - Tente -ao sdl ou use ALSA 0.5 ou a emula??o OSS do ALSA 0.9.
      - Experimente com diferente valores para -autosync, 30 ? um bom come?o.
      - Sa?da de v?deo lenta
      - Tente um driver diferente -vo (-vo help para listar) ou tente -framedrop!
      - CPU Lento
      - N?o tente reproduzir um DVD/DivX grande em um CPU lento! Tente
      - Arquivo corrompido
      - Tente v?rias combina??es de -nobps -ni -forceidx -mc 0.
      - M?dia lenta (montagens NFS/SMB, DVD, VCD etc...)
      - Tente -cache 8192.
      - Voc? est? usando -cache para reproduzir um arquivo AVI n?o-entrela?ado?
      - Tente -nocache.
      Leia DOCS/HTML/en/video.html para dicas de ajuste/velocidade.
      Se nenhum destes ajudar voc?, leia DOCS/HTML/en/bugreports.html.

      A: 10.0 V: 3.5 A-V: 6.555 ct: 0.040 0/ 0 115% 218% 12.1% 83 0

      Saindo... (Sair)

      If you need some more details for this problem, please ask me.

      p.s: My system specs: Toshiba A200-PSAE6, Linux x86_64 Archlinux, Core2Duo T7300 @ 2GHz, Catalyst 10.10, Xorg Server 1.9.1, FFMpeg-MT-git


      • Originally posted by gbeauche View Post
        Then this means you are not using the latest libva version, or the right one, or an fglrx installation problem. Please report about the following commands:
        $ ldd /usr/bin/vainfo
        $ ldconfig -p|grep
        $ ldd /usr/bin/vainfo => (0xb7821000) => /usr/lib/ (0xb7818000) => /usr/lib/ (0xb7812000) => /usr/lib/ (0xb7804000) => /usr/lib/ (0xb77fb000) => /lib/ (0xb77f1000) => /usr/lib/ (0xb77ec000) => /usr/lib/ (0xb76d1000) => /usr/lib/ (0xb76b9000) => /usr/lib/ (0xb76b6000) => /usr/lib/ (0xb76b1000) => /lib/ (0xb76ac000) => /lib/ (0xb7549000) => /lib/ (0xb7530000)
        /lib/ (0xb7822000)

        $ ldconfig -p|grep (libc6) => /usr/lib/


        • @evolution

          try using catalyst 10.9. I Got that Unsupported PixelFormat 61 error if i use 10.10.


          • To zelda32:

            I've already tried both catalyst 10.9 and 10.8 (with Xorg Server 1.8 of course), and both versions don't work (as I said in my previous post, my Mobility HD2600 stopped working with H264 files since catalyst 10.7)...

            Further info about my system:

            libva 1.0.5 patched with SDS patches from Arch repos, xvba-video 0.7.6.pre3

            libva: libva version 0.31.1
            Xlib: extension "XFree86-DRI" missing on display ":0.0".
            libva: va_getDriverName() returns 0
            libva: Trying to open /usr/lib/dri/
            libva: va_openDriver() returns 0
            vainfo: VA API version: 0.31
            vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.6.pre3
            vainfo: Supported profile and entrypoints
            VAProfileMPEG2Simple : VAEntrypointIDCT
            VAProfileMPEG2Main : VAEntrypointIDCT
            VAProfileH264High : VAEntrypointVLD
            VAProfileVC1Advanced : VAEntrypointVLD


            • Adding to my last post, I'm sending to the forum screenshots taken from a sample of a VC-1 encoded video (The MS Flight Simulator demo Video) and a sample of a H264 720p MP4 encoded video (downloaded from youtube)...
              Hope this can help.

              In both cases, my CPU utilization is below 10% almost all time...

              H264-encoded video:

              VC-1 encoded video:


              • After further inspection, i noticed that the "Unsupported PixelFormat 61" error happened whether i use vaapi or vaapi:gl and playing any video format.
                Nevertheless, the vaapi acceleration works.

                Btw, will xvba support H.264 L4.1 ?


                • Btw, i encountered random sysem freeze after playing 1080p video (No problem with 720p, yet) using cat 10.9. I am downgrading to 10.7 right now.
                  But i still can ssh-ing to the system and reboot it.


                  • You use r600 or? With a 3450 i only could use vc1, that's why i got rid of it 2 days ago


                    • Hi,
                      I further investigated the problems I'm having in Linux on Windows 7 and found that the "default" Windows 7 Driver for my Mobility Radeon card could decode H264 videos properly on my graphics card.

                      Currently, when I did a driver upgrade to Catalyst 10.10, it stopped decoding H264 videos on hardware (the same problem I have in Arch Linux), and I only can decode VC-1 videos on hardware.

                      Can this be a problem related to some library that AMD updated?