Announcement

Collapse
No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Never mind I already got it to work with fglrx from hardware drivers. The other one I tried earlier and failed was a package created from official catalyst 10.4 installer. Don't know if that package was borked or XvBA version from official cat 10.4 is broken. But it's working now.

    CPU usage is negligible with XvBA but colors are a little different than when using regular GL. Sometimes a little more saturated, but I've also seen some scenes with a greenish cast over them. Don't know quite yet what to make of it. Need more testing.

    Only tested with mplayer, the gstreamer plugin requires newer libavcodec but I have to many apps installed which depend on the one shipped with Lucid. So I'm not going to mess around with that for now.

    Comment


    • It seems that the color issue maybe fixed soon, but you still must be lucky when you can watch the movie at all using xvba.

      Comment


      • Originally posted by Kano View Post
        It seems that the color issue maybe fixed soon, but you still must be lucky when you can watch the movie at all using xvba.
        Hi

        Hopefully the overscan problem will be fixed soon as well, and I could start to switch to Linux with my HTPC too...

        Comment


        • Originally posted by benoe View Post
          Hi

          Hopefully the overscan problem will be fixed soon as well, and I could start to switch to Linux with my HTPC too...
          When do you experience over scan, and with what programs?

          Comment


          • Originally posted by monraaf View Post
            Bah missing header. I guess the ffmpeg from Lucid is already obsolete.
            It was obsolete since almost one year already. ;-) Upgrade to 0.6.0 or a recent enough snapshot from 2010.

            Code:
            xvba_video: XVBA_CreateContext(): status 11
            If you are using an RS780G or RS780E (not RS780V):
            $ sudo service gdm stop
            $ (make sure the X server is not running)
            $ sudo rmmod fglrx
            $ (uninstall the Catalyst driver)
            $ sudo rm -rf /etc/ati (at least all amdpcsdb* files)
            $ (reinstall the Catalyst driver)
            $ grep Gating /etc/ati/amdpcsdb
            $ (make sure you see PP_RS780DisableUVDBranchClkGating set to 1)
            $ sudo aticonfig --initial -f
            (the -f makes sure the amdpcsdb is replace with package defaults)
            $ reboot (really, don't start the X server yet)

            Try some hwdecode-demos program. If you still don't have that key set, this is weird, try to manually set it.

            Comment


            • Hmm, just saw you got it to work in the end.

              Comment


              • Originally posted by DivineGrace View Post
                When do you experience over scan, and with what programs?
                My problem is exactly the same as this:
                http://www.phoronix.com/forums/showthread.php?t=23103

                Comment


                • Originally posted by DivineGrace View Post
                  When do you experience over scan, and with what programs?
                  I have exactly the same problem as in this thread:
                  http://www.phoronix.com/forums/showthread.php?t=23103

                  Meaning that my Panasonic LCD TV appears as a projector, and there are no overscan options for it.

                  This way the TV always has a black border around the desktop

                  Comment


                  • Originally posted by benoe View Post
                    I have exactly the same problem as in this thread:
                    http://www.phoronix.com/forums/showthread.php?t=23103

                    Meaning that my Panasonic LCD TV appears as a projector, and there are no overscan options for it.

                    This way the TV always has a black border around the desktop
                    I used to have this issue last year. I tried all of the fglrx drivers but none worked. Finally, I switched cables from DVI-to-HDMI to straight HDMI into my TV, I no longer have that issue.

                    Comment


                    • Originally posted by DivineGrace View Post
                      I used to have this issue last year. I tried all of the fglrx drivers but none worked. Finally, I switched cables from DVI-to-HDMI to straight HDMI into my TV, I no longer have that issue.
                      Oh, I already have hdmi-hdmi cable.

                      With the previous fglrx driver (ubuntu 9.10 default) it was ok.

                      Comment

                      Working...
                      X