No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by popper View Post
    LOL So in effect gbeauche could today bump to his potential 0.8.x-series and probably easily implement it on the v2.3 SDK supplied OVDECODE_API On Windows, Today.
    Sorry, but, no, I have no intention to work on Windows.


    • Originally posted by gbeauche View Post
      Sorry, I can't report anything for chipsets we don't use. FYI, the Evergreen rendering bug was first reported 2009/12/14 and was finally fixed 2010/12/14, exactly one year later. So, please be patient.
      Ok, maybe if the Evergreen / Cayman Support is satisfactory enough on Linux when I buy my next laptop, I'll buy another one with an ATI card ... For now, I'll stick for a while with my HD2600 + Catalyst 10.7, in this 4-year-old laptop...



      • Hi there - I have a problem with vlc and VAAPI.

        I managed to get VAAPI to work properly. On a Radeon HD 4250 vlc only consumes 30-40% of CPU for 1080p playback (before: 100%).

        The weird thing is that Xorg now consumes 89% of the CPU, which prevents smooth video playback (the video itself is played back, no artifacts). What can I do against this?

        libva: libva version 0.31.1-sds1
        Xlib:  extension "XFree86-DRI" missing on display ":0.0".
        libva: va_getDriverName() returns 0
        libva: Trying to open /usr/lib/va/drivers/
        libva: va_openDriver() returns 0
        vainfo: VA API version: 0.31
        vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.7
        vainfo: Supported profile and entrypoints
              VAProfileH264High               : VAEntrypointVLD
              VAProfileVC1Advanced            : VAEntrypointVLD
        X-Video Extension version 2.2
        screen #0
          Adaptor #0: "ATI Radeon AVIVO Video"
            number of ports: 4
            port base: 143
            operations supported: PutImage
        This is on a Ubuntu 10.10 machine. I've tried both Catalyst 10.10 and 10.12 - they both cause the Xorg-VAAPI issue. When I disable HW-decoding in vlc, Xorg goes down to 2% CPU load - but obviously vlc is at 100% without VAAPI


        • Originally posted by direx View Post
          Hi there - I have a problem with vlc and VAAPI
          Never mind - I got it working. For anyone interested, this is how I did it:
          1. clean installation of Ubuntu 10.10 (amd64)
          2. installed all updates, rebooted
          3. installation of ATI driver from the restricted drivers
          4. open a terminal window and type:
            • sudo apt-add-repository ppa:n-muench/vlc
            • sudo apt-get update
            • wget
            • sudo dpkg -i xvba-video_0.7.7-1_amd64.deb
            • sudo apt-get install vlc vainfo
            • sudo ln -s /usr/lib/va/drivers/ /usr/lib/dri/ #this is a hack, which I needed
          5. after another reboot check vainfo

          This is the PPA which has a modified version of vlc and libva:
          sudo add-apt-repository ppa:n-muench/vlc This PPA has VLC Media Player and it's dependencies. As well as other packages/programs so they build against these newer deps in this repo. All packages are backported either Debian unstable/experimental or Ubuntu Utopic ----------------------------------------------- THIS PPA MIGHT BREAK OTHER PACKAGES (it shouldn't (since they're backported with minimal changes), but someone recommended that I should note it anyways) ----------------------------...

          For my Radeon HD 4250 the default 10.10 Catalyst drivers did the trick - I did not need to update to a newer version.


          • Originally posted by zelda32 View Post
            tried vainfo after that, i got.
            libva: libva version 0.31.1
            libva: User requested driver 'fglrx'
            libva: Trying to open /usr/local/lib/dri/
            libva: va_openDriver() returns -1
            vaInitialize failed with error code -1 (unknown libva error),exit
            I used the tips from page 101 and set
            export LIBVA_DRIVER_NAME="fglrx"

            Now I find with strace that mplayer tries to open
            which I don't have.

            I use Opensuse 11.3 which contains only this library in

            Any ideas?


            • usually on 64 bit systems /usr/lib is a symlink to /usr/lib64


              • Originally posted by energyman View Post
                usually on 64 bit systems /usr/lib is a symlink to /usr/lib64
                Ummm not really. Compatibility libraries are usually in /usr/lib as well in 64-bit systems.


                • except when they land in /usr/lib32 where they belong.


                  • Originally posted by energyman View Post
                    except when they land in /usr/lib32 where they belong.
                    IIRC LSB specifies /usr/lib not /usr/lib32


                    • Sorry fhs not lsb