Announcement

Collapse
No announcement yet.

Linux 2.6.32 To Get R600 KMS Along With 3D

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ex-Cyber
    replied
    Originally posted by zappbrannigan View Post
    I turned power off because even the reset button was dead. Afterwards the radeon fan runs at full speed for ~ 20 seconds. This was very uncommon. The system started windows and debian normal. So i tried the live cd again. The system hang on the login and my monitor failed to show a picture. At the same time the radeon fan start with full speed. I checked with radeon.modeset=0 but the system hang on the login screen.
    You might want to try physically removing power from the system (either unplug it or turn off the master power switch if your PSU has one). Sometimes registers related to power management are "sticky", i.e. their contents survive a normal system power down / restart as long as standby power is still present.

    Leave a comment:


  • zappbrannigan
    replied
    Test with fedora_test_day_live_cd

    Hello Everyone!
    Yesterday I tested the fedora test day live cd with 3 systems. It was a disaster!
    On my ASUS 1005HA Netbook (Intel 945) the 3d acceleration was disabled. On the next system with a Nvidia card (GeForce 6700 XL) KMS and xrandr works. XV seems to be work but wasn't checked. And finally on my system with HD 3870 the most things work! I started with radeon.modeset=1 and after some reboots (which depends on my crypted disks) i got a desktop with working compiz! The test with xv passed. But suddenly the system hang while i test the quick user switch. I turned power off because even the reset button was dead. Afterwards the radeon fan runs at full speed for ~ 20 seconds. This was very uncommon. The system started windows and debian normal. So i tried the live cd again. The system hang on the login and my monitor failed to show a picture. At the same time the radeon fan start with full speed. I checked with radeon.modeset=0 but the system hang on the login screen.

    Leave a comment:


  • remm
    replied
    Originally posted by pvtcupcakes View Post
    I disabled KMS, and I'm able to get into X now.
    When I had KMS enabled, I got the nice high res framebuffer, but as soon as X started I got a black screen and no signal on my monitor.
    The update was not pushed yet, use radeon.modeset=0 For whatever reason, every time there's some update I need, the push takes days ...

    Leave a comment:


  • Pitabred
    replied
    Originally posted by bridgman View Post
    I imagine the driver code needs to know about multiple GPUs even if it is only using one of them. I guess there are four stages of "support" :

    nothing at all - driver gets confused and crashes when >1 GPU

    awareness - driver can only work with one GPU at a time but knows enough to ignore the other ones

    multi-GPU - driver can support multiple GPUs with different screens on each GPU

    multi-GPU rendering - like Crossfire, driver can divide work across multiple GPU engines and combine the results to a single screen
    Case 1 seems to be what's happening to me when I installed Fedora 11. And 12 Alpha. The LiveCD detected a display and ran fine, but when I installed it just didn't want to play nicely with my two 4670's in Crossfire. Not until I went in and added a PCI address to the xorg.conf at least, and even then the whole GUI login screen thing was hosed for me. I had to start X manually after logging in at the command prompt. Not sure if that's a Fedora or a radeon problem, but I still ran into it. I'm usually a *buntu/Deb guy, so it may just be my unfamiliarity with Fedora, but I'd think that the GUI should work right after an install.

    Leave a comment:


  • pvtcupcakes
    replied
    I disabled KMS, and I'm able to get into X now.
    When I had KMS enabled, I got the nice high res framebuffer, but as soon as X started I got a black screen and no signal on my monitor.

    Leave a comment:


  • acreda
    replied
    Originally posted by deanjo View Post
    It's way to late for inclusion in OS 11.2. They already made an exception putting in 2.6.31. Beside's you can always install the Factory KOTD.
    That is what I will be doing but I cant move until fglrx gets support for 31 or 32! is the only module i depend on for holding back, here is hoping that due to the speed of the devel, that mesa can start to get near sometime next year

    Leave a comment:


  • Louise
    replied
    Originally posted by Maarte View Post
    Will Fedora 12 (Constantine) be 2.6.31 or 2.6.32? There seem to be conflicting opinions across both official sites and this forum. Thankyou for any clarification offered.
    The version number will be 2.6.31, but as nanonyme wrote, it have lots of 2.6.32 patches back ported and applied.

    Leave a comment:


  • legume
    replied
    Originally posted by LiquidAcid View Post
    UUID?

    I'm just booting the kernel built from airlied's drm-next tree and once the login is available I modprobe radeon with the corresponding parameters. Is this the wrong approach?
    Should be OK, I have to.

    The stability problems of yesterday seem to be fixed now with todays updates to kernel and xf86-video-ati.

    FWIW when compiling libdrm I had to (unless it was something else I messed up) do

    ./autogen.sh --enable-radeon-experimental-api

    Without that KMS worked, but I couldn't get modeset=0 or an old kernel + agd5f modules to work - The driver would hang on startx.

    Leave a comment:


  • pvtcupcakes
    replied
    Originally posted by Maarte View Post
    Will Fedora 12 (Constantine) be 2.6.31 or 2.6.32? There seem to be conflicting opinions across both official sites and this forum. Thankyou for any clarification offered.
    It'll probably have 2.6.31 at release, but they may upgrade it to .32 later. I just noticed last week Fedora 11 upgraded from .29 to .30

    Leave a comment:


  • bridgman
    replied
    Originally posted by smitty3268 View Post
    Edit: Hmm, Bridgman explained this better than I - don't know how i missed his post as it looks older than mine...
    Don't worry, I missed agd5f's post too

    Leave a comment:

Working...
X