Announcement

Collapse
No announcement yet.

Radeon KMS + DRI2 on Macbook Pro -- Fantastic!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • amphigory
    started a topic Radeon KMS + DRI2 on Macbook Pro -- Fantastic!

    Radeon KMS + DRI2 on Macbook Pro -- Fantastic!

    A big thank you to the devs!

    After building kernel 2.6.31-rc8 & dri2 & drm & mesa & xf86-video-ati I have beautiful 1440x900 accelerated framebuffer and 3d on my 1st gen Macbook Pro (AMD X1600) running Debian unstable. Compiz & Google Earth are behaving as advertised. No artifacts with video playback!

    The only hiccup was in xf86-video-ati (I had to change DRI2BufferPtr to DRI2Buffer2Ptr in radeon_dri2.c).

    After waiting for 10 years I now have an unified video driver in Linux and it is a wondrous thing. Again, thanks!

    Cheers!
    Ed

  • nhaehnle
    replied
    Ah, don't worry, you'll run into bugs sooner or later

    Leave a comment:


  • amphigory
    replied
    Originally posted by nanonyme View Post
    You know, it sometimes feels like I do...
    I'm trying to curb my compulsive compiling habits... with limited success.
    On another note, I've yet to successfully crash X or cause a kernel panic since moving to KMS and the radeon driver from git. It's almost disappointingly stable. No excitement left in my life...

    Leave a comment:


  • nanonyme
    replied
    Originally posted by amphigory View Post
    With the number of changes happening one could spend all day rebuilding from git. :-)]
    You know, it sometimes feels like I do...

    Leave a comment:


  • amphigory
    replied
    Originally posted by nanonyme View Post
    Iirc suokko should have fixed that some time ago. Maybe you didn't build the newest git?
    Yup... pulled it Saturday but am running Xorg 1.6.3. suokko commited change 29 hours ago so it should be fixed now. With the number of changes happening one could spend all day rebuilding from git. :-)

    http://cgit.freedesktop.org/xorg/dri...44d345547b75c5

    Leave a comment:


  • nanonyme
    replied
    Originally posted by amphigory View Post
    The only hiccup was in xf86-video-ati (I had to change DRI2BufferPtr to DRI2Buffer2Ptr in radeon_dri2.c).
    Iirc suokko should have fixed that some time ago. Maybe you didn't build the newest git?

    Leave a comment:

Working...
X