Announcement

Collapse
No announcement yet.

Catalyst 9.8 + Kernel 2.6.29 = Freeze

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Saphy
    Junior Member

  • Saphy
    replied
    Originally posted by Untit1ed View Post
    Thanks, this topic is really helpful. I had the same problem on OpenSUSE 11.0 Kernel 2.6.25.20. I had to use radeonhd driver instead, because fglrx driver crashed my system on X startup.
    fglrx also crash on me, even after I added the SWCursor True option. I also tried setting CONFIG_X86_PAT to N in kernel config. But I still get a black screen and a frozen system (probably a kernel panic) after a while, or immediately if I play any video or run any 3D program.

    The only way to make it not crashing is to disable DRI, but that would have disabled all acceleration. I don't mind the lack of 3D accleration, but does anyone know if there is a way to disable only 3D acceleration so that I can play video?


    Thanks
    Saphy
    Junior Member
    Last edited by Saphy; 05 September 2009, 09:12 PM.

    Leave a comment:

  • Untit1ed
    Junior Member

  • Untit1ed
    replied
    Thanks, this topic is really helpful. I had the same problem on OpenSUSE 11.0 Kernel 2.6.25.20. I had to use radeonhd driver instead, because fglrx driver crashed my system on X startup.

    Leave a comment:

  • blindfrog
    Phoronix Member

  • blindfrog
    replied
    Wohoo you can get rid of the "swcursor trick" now! There's a better fix for those lock ups.

    http://forums.fedoraforum.org/showth...55503&page=241

    1) mv xorg.conf xorg.conf.old
    2) aticonfig --initial -f
    3) aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

    Works great and kwin desktop effects are usable again
    blindfrog
    Phoronix Member
    Last edited by blindfrog; 01 September 2009, 05:09 PM.

    Leave a comment:

  • DteK
    Junior Member

  • DteK
    replied
    Originally posted by TorkildJ View Post
    IT WORKS!
    Thank you very much for your help.
    But i am really a bit surprised that such a strange workaround is needed to avoid total catastrophe with the ati driver

    So to sum up, what seems to do the trick for Fedora 11:
    Code:
    1. Go to init 3 (non graphical mode)
    2. as root write "rmmod radeon; rmmod drm;"
    3. now run ati-driver setup and verify that it has installed without errors
    4. use xorg.conf with correct settings (provided below. "lib64" should be replaced with "lib" for 32bit systems
    5. in /etc/modprobe.d/blacklist.conf add lines "blacklist radeon" and "blacklist drm"
    6. run "depmod -a"
    7. reboot system and pray that it works!
    Here is the final xorg.conf that worked
    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "ServerFlags"
    Option  "AIGLX" "off"
    EndSection
    
    
    
    Section "Files"
    	ModulePath   "/usr/lib64/xorg/modules"
    	FontPath     "catalogue:/etc/X11/fontpath.d"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "glx"
    	Load  "dri"
    	Load  "dri2"
    	Load  "extmod"
    	Load  "record"
    	Load  "dbe"
    EndSection
    
     Section "Extensions"
        Option  "Composite" "Disable"  #make DRI work with fglrx.
     EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    
    	#DisplaySize	  510   290	# mm
    	Identifier   "Monitor0"
    	VendorName   "ACR"
    	ModelName    "Acer V233H"
    	HorizSync    30.0 - 94.0
    	VertRefresh  49.0 - 75.0
    	Option	    "DPMS"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    	Option	    "SWCursor"	"true"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    I did not have to blacklist drm, I did have to remake initrd after black listing radeon though. works lovely.

    Leave a comment:

  • TorkildJ
    Junior Member

  • TorkildJ
    replied
    It works

    Originally posted by TrentZ View Post
    Yes, you put "SWCurosr" in the wrong Device section. It should be in 'aticonfig-Device[0]-0'.
    IT WORKS!
    Thank you very much for your help.
    But i am really a bit surprised that such a strange workaround is needed to avoid total catastrophe with the ati driver

    So to sum up, what seems to do the trick for Fedora 11:
    Code:
    1. Go to init 3 (non graphical mode)
    2. as root write "rmmod radeon; rmmod drm;"
    3. now run ati-driver setup and verify that it has installed without errors
    4. use xorg.conf with correct settings (provided below. "lib64" should be replaced with "lib" for 32bit systems
    5. in /etc/modprobe.d/blacklist.conf add lines "blacklist radeon" and "blacklist drm"
    6. run "depmod -a"
    7. reboot system and pray that it works!
    Here is the final xorg.conf that worked
    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "ServerFlags"
    Option  "AIGLX" "off"
    EndSection
    
    
    
    Section "Files"
    	ModulePath   "/usr/lib64/xorg/modules"
    	FontPath     "catalogue:/etc/X11/fontpath.d"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "glx"
    	Load  "dri"
    	Load  "dri2"
    	Load  "extmod"
    	Load  "record"
    	Load  "dbe"
    EndSection
    
     Section "Extensions"
        Option  "Composite" "Disable"  #make DRI work with fglrx.
     EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    
    	#DisplaySize	  510   290	# mm
    	Identifier   "Monitor0"
    	VendorName   "ACR"
    	ModelName    "Acer V233H"
    	HorizSync    30.0 - 94.0
    	VertRefresh  49.0 - 75.0
    	Option	    "DPMS"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    	Option	    "SWCursor"	"true"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection

    Leave a comment:

  • blindfrog
    Phoronix Member

  • blindfrog
    replied
    Originally posted by nanonyme View Post
    Funny notion but a false one. Fedora sometimes diverts from upstream when testing is being done with X. (since stuff gets to Fedora before it gets upstream, sometimes)
    Yes! And that's even better! I already see it "Catalyst: Even upstream can't keep up". ;D

    Leave a comment:

  • TrentZ
    Junior Member

  • TrentZ
    replied
    Originally posted by TorkildJ View Post
    That helped a little bit.. Now it goes all the way to the login screen before it freezes (and screen is not black).. error message is however the same.. Maybe some other things in my xorg.conf is wrong?
    Yes, you put "SWCurosr" in the wrong Device section. It should be in 'aticonfig-Device[0]-0'.

    Leave a comment:

  • TorkildJ
    Junior Member

  • TorkildJ
    replied
    Originally posted by blindfrog View Post
    Have you blacklisted radeon module from /etc/modprobe.d/blaclist.conf? Black screen here also if I haven't.

    Add "blacklist radeon" there like the others that are already there.
    That helped a little bit.. Now it goes all the way to the login screen before it freezes (and screen is not black).. error message is however the same.. Maybe some other things in my xorg.conf is wrong?

    Leave a comment:

  • nanonyme
    Senior Member

  • nanonyme
    replied
    Originally posted by blindfrog View Post
    Maybe Catalyst devs should just target Fedora releases of the desktop "GNU/Linuxes", since when it works under Fedora it should work everywhere ;D
    Funny notion but a false one. Fedora sometimes diverts from upstream when testing is being done with X. (since stuff gets to Fedora before it gets upstream, sometimes)

    Leave a comment:

  • blindfrog
    Phoronix Member

  • blindfrog
    replied
    Originally posted by TorkildJ View Post
    I have tried this solution on both 32 and 64 bit versions of fedora 11. With standard kernel and 2.6.30.4 (self compiled).. and all results in black screen freeze... Error trace is exactly same as before, so basically this workaround does no good at all

    xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "ServerFlags"
    Option  "AIGLX" "off"
    EndSection
    
    
    
    Section "Files"
    	ModulePath   "/usr/lib64/xorg/modules"
    	FontPath     "catalogue:/etc/X11/fontpath.d"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "glx"
    	Load  "dri"
    	Load  "dri2"
    	Load  "extmod"
    	Load  "record"
    	Load  "dbe"
    EndSection
    
     Section "Extensions"
        Option  "Composite" "Disable"  #make DRI work with fglrx.
     EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    
    	#DisplaySize	  510   290	# mm
    	Identifier   "Monitor0"
    	VendorName   "ACR"
    	ModelName    "Acer V233H"
    	HorizSync    30.0 - 94.0
    	VertRefresh  49.0 - 75.0
    	Option	    "DPMS"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    Option	    "SWCursor"	"true"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "Dac8Bit"            	# [<bool>]
            #Option     "BusType"            	# [<str>]
            #Option     "CPPIOMode"          	# [<bool>]
            #Option     "CPusecTimeout"      	# <i>
            #Option     "AGPMode"            	# <i>
            #Option     "AGPFastWrite"       	# [<bool>]
            #Option     "AGPSize"            	# <i>
            #Option     "GARTSize"           	# <i>
            #Option     "RingSize"           	# <i>
            #Option     "BufferSize"         	# <i>
            #Option     "EnableDepthMoves"   	# [<bool>]
            #Option     "EnablePageFlip"     	# [<bool>]
            #Option     "NoBackBuffer"       	# [<bool>]
            #Option     "DMAForXv"           	# [<bool>]
            #Option     "FBTexPercent"       	# <i>
            #Option     "DepthBits"          	# <i>
            #Option     "PCIAPERSize"        	# <i>
            #Option     "AccelDFS"           	# [<bool>]
            #Option     "IgnoreEDID"         	# [<bool>]
            #Option     "DisplayPriority"    	# [<str>]
            #Option     "PanelSize"          	# [<str>]
            #Option     "ForceMinDotClock"   	# <freq>
            #Option     "ColorTiling"        	# [<bool>]
            #Option     "VideoKey"           	# <i>
            #Option     "RageTheatreCrystal" 	# <i>
            #Option     "RageTheatreTunerPort" 	# <i>
            #Option     "RageTheatreCompositePort" 	# <i>
            #Option     "RageTheatreSVideoPort" 	# <i>
            #Option     "TunerType"          	# <i>
            #Option     "RageTheatreMicrocPath" 	# <str>
            #Option     "RageTheatreMicrocType" 	# <str>
            #Option     "ScalerWidth"        	# <i>
            #Option     "RenderAccel"        	# [<bool>]
            #Option     "SubPixelOrder"      	# [<str>]
            #Option     "ShowCache"          	# [<bool>]
            #Option     "DynamicClocks"      	# [<bool>]
            #Option     "VGAAccess"          	# [<bool>]
            #Option     "ReverseDDC"         	# [<bool>]
            #Option     "LVDSProbePLL"       	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            #Option     "DRI"                	# [<bool>]
            #Option     "ConnectorTable"     	# <str>
            #Option     "DefaultConnectorTable" 	# [<bool>]
            #Option     "DefaultTMDSPLL"     	# [<bool>]
            #Option     "TVDACLoadDetect"    	# [<bool>]
            #Option     "ForceTVOut"         	# [<bool>]
            #Option     "TVStandard"         	# <str>
            #Option     "IgnoreLidStatus"    	# [<bool>]
            #Option     "DefaultTVDACAdj"    	# [<bool>]
            #Option     "Int10"              	# [<bool>]
            #Option     "EXAVSync"           	# [<bool>]
            #Option     "ATOMTVOut"          	# [<bool>]
            #Option     "R4xxATOM"           	# [<bool>]
    	Identifier  "Card0"
    	Driver      "radeon"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "RV770 [Radeon HD 4870]"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    Have you blacklisted radeon module from /etc/modprobe.d/blaclist.conf? Black screen here also if I haven't.

    Add "blacklist radeon" there like the others that are already there.

    Leave a comment:

Working...
X