No announcement yet.

Problem with fglrx and restarting x11

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with fglrx and restarting x11

    Hi, i've been trying to get my awesome3 configuration edited but i always seem to write bad lines in my rc.lua that make awesome not run, so i need to kill X and restart it. this used to work fine but now when I try to restart X it just goes to a blank screen and i have to reboot. I'm assuming it's a kernel panic because my music playing in mpd starts skipping and eventually stops playing. does anyone experience this problem or something similar with restarting X11?

    edit: it's not just with awesome, but with any window manager.

  • #2
    Happens here too. Has been this way with Catalyst for as long as I can remember using it with my new card (8.3 or so [not sure] on an 4870). Never had this problem with the open drivers (on the older X1950 I had).


    • #3
      This only started happening for me in Catalyst 9.7. All previous versions since 2007 when I started using fglrx, have worked for me, until this disgrace of a driver came out.
      Now I'm just using 9.6, where most things except for video playback work fine.


      • #4
        Yeah this only happens to me in catalyst 9.7. I may just downgrade to 9.6 but I'm not quite sure.


        • #5
          I have this behavior with all versions IIRC. When quitting from X, e.g. "text console mode" in kdm, it works. But when I try to stop X from outside, I have to reboot to get it work again.


          • #6
            This is quite an annoyance. Does anyone know if a bug report has been filed?


            • #7
              The "text"/virtual consoles are also unuseable(corrupted display) when X changes resolution as well, as I've had to kill full screen apps from a virtual console which leaves me with a corrupted display. The problem seems to be that sometimes even when apps end normally fglrx does NOT restore the original desktop resolution if the app was running in some other res than the app, and in the case of killing apps it NEVER seems to restore original res(this behavior is OK as it's outside of normal operation).

              I've mentioned this behavior in several catalyst 9.x release threads and a few other IIRC, along with some videos seem to cause the machine to freeze after waking from sleep, compositing enabled seems to cause the machine to wake on freeze, random screen corruption(black rectangles over areas of the display can be "fixed" by forcing refresh), etc.

              Anyways, I'd guess that the screen corruption of "text" consoles is caused by the inability of fglrx to properly manage/restore resolutions in many cases. It's annoying, but I'm more worried about the various freeze bugs. (All of these have been present since 9.2 which was my first experience with catalyst...)

              Now that I think about it, I bet that what happens is that since I can get an uncorrputed virtual terminal after X has switched to another resolution is that when an app dies or quits and doesn't reset resolution to the default value BEFORE ending the app or killing X is that the virtual displays are left trying to display at a resolution that is no longer active/available. AMD should really fix this. It all seems to be down to poor handling of resolution switching in the cataclysm drivers.

              My experience with this is primarily limited to some windows apps under wine and a few buggy opengl native apps. Have you tried CTRL-ALT-BACKSPACE to force X restarts?

              Also if you get stuck ALT-PRTSCR+ RSEINUB (push those letters while holding ALT-PRTSCR is supposed to do a "safe" reboot, and I've become VERY familiar with it because of the freezes...)
              "Raising Skinny Elephants Is Never Utterly Boring"

              On the plus side(if you can call it that) fglrx is forcing me to modernize some of my low level linux knowledge which I've let lapse over the last 9y or so as it had been no longer really necessary to know...
              Last edited by cutterjohn; 15 August 2009, 01:21 PM.


              • #8
                thanks for the ALT-PRTSCR+ RSEINUB. I haven't tried it yet because i haven't frozen X in a while but next time i do i'll be sure to give it a try.

                these annoyances are making me want to go out and buy an nvidia card more than ever before...

                edit: ctrl+alt+backspace and any alt+f* key combinations doesn't break me out of X crashing.


                • #9
                  Still happens on 9.8