Announcement

Collapse
No announcement yet.

ATI R600/700 OSS 3D Driver Reaches Gears Milestone

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • agd5f
    replied
    you can also add the missing symbol to the glx module in the xserver.

    Leave a comment:


  • nanonyme
    replied
    Maybe a bit more in-depth: if you're one of us sorry bastards that have their X server compiled without GLX TLS, workaround involves recompiling X server with --enable-glx-tls and Mesa with the same option. The rest can just compile Mesa with --enable-glx-tls. (it's disabled by default)

    Leave a comment:


  • nanonyme
    replied
    Originally posted by pingufunkybeat View Post
    So gentoo people actually have no problem?
    Ubuntu/Debian users probably neither. Fedora users do.

    Leave a comment:


  • pingufunkybeat
    replied
    Oh?

    So gentoo people actually have no problem?

    Awesome

    Leave a comment:


  • nanonyme
    replied
    Yeah, seems like a good bet all distros that don't use SELinux are enabling GLX TLS.

    Leave a comment:


  • Fran
    replied
    Originally posted by legume View Post
    Ahh, there is talk on IRC that the if your distro builds mesa/xorg with tls you will avoid it.
    Yeah, gentoo builds mesa and xorg with tls when the nptl use flag is enabled.

    Leave a comment:


  • legume
    replied
    Originally posted by Fran View Post
    I've restarted not only X, but the computer. Twice
    Ahh, there is talk on IRC that the if your distro builds mesa/xorg with tls you will avoid it.

    Leave a comment:


  • Fran
    replied
    Originally posted by forum1793 View Post
    Did you compile your own xserver?
    I use gentoo, so yeah :P. But it's the default gentoo xserver, no changes made for the latest git commits.

    Leave a comment:


  • forum1793
    replied
    Originally posted by Fran View Post
    Hmmm? I'm using the latest git drm/mesa/driver (updated a few minutes ago) with xorg-server-1.6.3 and everything works fine
    Did you compile your own xserver?

    I'm using latest from slackware which is also 1.6.3.

    Leave a comment:


  • Fran
    replied
    Originally posted by legume View Post
    It won't show until you restart X.
    I've restarted not only X, but the computer. Twice

    Leave a comment:

Working...
X