Announcement

Collapse
No announcement yet.

ATI R600/700 OSS 3D Driver Reaches Gears Milestone

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ant P.
    replied
    I've installed all the bits to give the 3D driver a go... but it doesn't go

    Code:
    $ glxgears 
    IRQ's not enabled, falling back to busy waits: 2 18
    Running synchronized to the vertical refresh.  The framerate should be
    approximately the same as the monitor refresh rate.
    do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
    Try adjusting the vblank_mode configuration parameter.
    4 frames in 6.0 seconds =  0.665 FPS
    2 frames in 6.0 seconds =  0.333 FPS
    ^C
    Meanwhile the glxgears window is just displaying a static picture of RGB noise... did I do a git pull at a bad time?

    Leave a comment:


  • Wielkie G
    replied
    Hello.

    I just compiled everything to make my rv670 card 3d work. Reboot... Log in to KDE session, everything works so far. glxinfo says it just works. But glxgears crashes X.

    I use Fedora 11 now (not Rawhide). Dmesg says:
    Code:
    [drm:radeon_cs_ioctl] *ERROR* CS ioctl called without modesetting
    uname -sr:
    Code:
    Linux 2.6.29.6-217.2.16.fc11.x86_64
    Xorg.log doesn't say anything which can help (I think).

    I compiled mesa-master and agd5f/drm-r6xx-r7xx-3d + radeonhd-master.

    Leave a comment:


  • DanL
    replied
    My apologies - apparently, the Ubuntu kernel update caused this and not building agd5f's drm. The problem also exists for nouveau users. Here's the bug report for those interested: https://bugs.edge.launchpad.net/ubun...ux/+bug/404496

    Leave a comment:


  • bridgman
    replied
    It's related to drm in the sense that the intel drm seems to interfere with other drms; my guess is that there's going to be a requirement for one more level of runtime decision-making (eg only load drm X if the right hardware is there) which either doesn't exist yet or isn't working yet.

    Leave a comment:


  • nanonyme
    replied
    Originally posted by DanL View Post
    I saw someone else mention this issue in the #radeonhd archives (last month). At this point, I'm not sure what's causing it, but I guess it's related to agd5f's drm.
    I'd consider that a bit unlikely without hearing a very good reason. :3 More likely your Ubuntu kernel or initrd is loading the Intel drivers for some reason or another...

    Leave a comment:


  • DanL
    replied
    Originally posted by nanonyme View Post
    Rather try to find out why they're loaded and if necessary file bugs on Ubuntu's bug trackers.
    I saw someone else mention this issue in the #radeonhd archives (last month). At this point, I'm not sure what's causing it, but I guess it's related to agd5f's drm.

    When Karmic Alpha5 comes out, I'm going to do a fresh install and see if I can reproduce it.

    Leave a comment:


  • nanonyme
    replied
    Originally posted by DanL View Post
    The intel modules loaded again at boot, so I'll probably end up blacklisting them.
    Rather try to find out why they're loaded and if necessary file bugs on Ubuntu's bug trackers.

    Leave a comment:


  • DanL
    replied
    Whereas doing this on Ubuntu Jaunty was straightforward, I had a few issues getting this to run on Ubuntu Karmic (with kernel 2.6.31-rc7). I had the "radeon disagrees with version.." errors in my dmesg that someone posted about earlier.

    I started modprobing manually and discovered that for some reason, i915 and intel_agp were loading at boot (and I don't have any Intel hardware :/ ). I had to unload them, and then I could load radeon. I also had to copy r600_dri.so and swrast.so from /usr/lib/glx/dri to /usr/lib/dri

    The intel modules loaded again at boot, so I'll probably end up blacklisting them.

    I hope this helps.

    Leave a comment:


  • legume
    replied
    Doesn't matter anymore as the problem commit has been reverted in mesa git master.

    Leave a comment:


  • nanonyme
    replied
    Originally posted by agd5f View Post
    you can also add the missing symbol to the glx module in the xserver.
    Well, actually imo better to enable glx-tls with Mesa where distro Mesa would have been built doing that anyway. But yeah, could always add the symbol rather than compiling a new X server too.

    Leave a comment:

Working...
X