Announcement

Collapse
No announcement yet.

ATI R600/700 OSS 3D Driver Reaches Gears Milestone

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • nanonyme
    replied
    I'm not part of any team but 2.6.31 will only give you 2D accel on r600/r700. For the rest you're looking for 2.6.32 or greater or agd5f's DRM branch.

    Leave a comment:


  • rvdboom
    replied
    I have a quick question for the AMD team : what level of support is brought by the incoming 2.6.31 kernel for r600 and r700?
    I seem to remember that KMS was for r500 and lower, but there seem to be some code for r600 in the I have a quick question for the AMD team : what level of support is brought by the incoming 2.6.31 kernel for r600 and r700?
    I seem to remember that KMS was for r500 and lower, but there seems to be some code for r600 in the /drivers/gpu/drm/radeon dir in the kernel tree.
    Is that supposed to be enough to get 3D with r600-r700 devices or does one still need to use the specific r600-r700 kernel modules branch to make it work?

    Leave a comment:


  • FarJumper
    replied
    DanL, thanks a lot! The Guide seems to be very useful. I'll try in later.

    BTW, `sudo update-initramfs -u` handles the problem of blacklisted drivers you mentioned at the line 95.

    Leave a comment:


  • DanL
    replied
    It probably doesn't include it because you need agd5f's DRM for it to work properly.

    Leave a comment:


  • Cieniek
    replied
    Originally posted by FarJumper View Post
    It looks that libgl1-mesa-dri package (libgl1-mesa-dri 7.6.0+git20090902.dc9de806-0ubuntu0tormod) doesn't have r600 module. Only r200 and r300 are exist.
    In a comment of bug whitch affects me:
    Originally posted by Jeffrey Baker
    The version of libgl1-mesa-dri in xorg-edgers doesn't provide r600_dri.so

    Leave a comment:


  • DanL
    replied
    FarJumper, I've been working on a guide for Ubuntu. It's a bit messy, but maybe it will help you: http://ubuntu.pastebin.com/m5751c068

    Leave a comment:


  • nanonyme
    replied
    You could contact tormod directly and ask him to enable it in the build or a reason for why it's not enabled.

    Leave a comment:


  • FarJumper
    replied
    Hi, I a bit confused in getting 3d for my hd3450 worked.

    What was done:

    1. Installed xorg form https://launchpad.net/~xorg-edgers/+archive/ppa
    2. Installed drm modules as explained here: https://launchpad.net/~xorg-edgers/+archive/radeon
    3. Blacklisted both i965 and i915 modules. After this step I've got the radeon module without any errors (at last)

    Now I have an error "/usr/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory". I think it is a problem of the issue with a failover to software rendering for my case. It looks like I missed some important step.

    Please help.

    OS: Ubuntu Karmic

    > uname -a

    Code:
    Linux exigen 2.6.31-9-generic #29-Ubuntu SMP Sun Aug 30 17:39:23 UTC 2009 i686 GNU/Linux
    > dmesg

    Code:
    [   38.726854] [drm] Initialized drm 1.1.0 20090831agd5f
    [   38.770682] [drm] Initialized radeon 1.29.0 20080613 on minor 0
    [   39.747742] [drm] Setting GART location based on new memory map
    [   39.764054] [drm] Loading RV620 CP Microcode
    [   39.764217] [drm] Loading RV620 PFP Microcode
    [   39.779133] [drm] Resetting GPU
    [   39.779189] [drm] writeback test succeeded in 1 usecs
    > glxinfo

    Code:
    OpenGL vendor string: Mesa Project
    OpenGL renderer string: Software Rasterizer
    OpenGL version string: 2.1 Mesa 7.6-devel
    OpenGL shading language version string: 1.20
    > xorg.log

    Code:
    (--) PCI:*(0:1:0:0) 1002:95c5:174b:e400 ATI Technologies Inc Mobility Radeon HD 3450 rev 0, Mem @ 0xc0000000/268435456, 0xd0020000/65536, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
    ...
    (EE) AIGLX error: dlopen of /usr/lib/dri/r600_dri.so failed (/usr/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory)
    (EE) AIGLX: reverting to software rendering
    (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
    Update:

    It looks that libgl1-mesa-dri package (libgl1-mesa-dri 7.6.0+git20090902.dc9de806-0ubuntu0tormod) doesn't have r600 module. Only r200 and r300 are exist.
    Last edited by FarJumper; 09-03-2009, 10:34 AM. Reason: Updated

    Leave a comment:


  • bibi
    replied
    I just looked at my dmesg and /var/lox/xorg.log and i didn't notice anything special, no error.
    Last edited by bibi; 09-03-2009, 09:58 AM.

    Leave a comment:


  • bibi
    replied
    Hi,

    I installed the 3D stack with the method described there : http://www.x.org/wiki/radeonhd%3Aexperimental_3D.
    I used this page for the radeon driver : http://www.x.org/wiki/radeonBuildHowTo

    I can run glxgear (1400 fps :-)).
    When i try to run any 3D application, i get a black screen then X reboot and i have to log in again. Is that normal ?
    I can't activate kde composite as well.

    I suspect a problem in my installation. Do you know the commands to know which version of mesa/libdrm/drm/radeon i run ?

    Thanks.

    Bibi

    Leave a comment:

Working...
X