Announcement

Collapse
No announcement yet.

ATI R600/700 OSS 3D Driver Reaches Gears Milestone

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bridgman
    replied
    OK, sounds like there is an edgers ppa for the drm (cool !). My mistake.

    Leave a comment:


  • Domi09
    replied
    So I either have to build the 3D branch or use the karmic 31 kernel?

    Leave a comment:


  • tormod
    replied
    Originally posted by bridgman View Post
    The 2.6.30 kernel won't have the drm code you need. Unless there's an edgers build for drm (I don't think so) you'll need to build and install libdrm & kernel modules from ~agd5f/drm r6xx-r7xx-3d branch.
    There is Though I haven't got any feedback on it (and can not test it myself): https://launchpad.net/~xorg-edgers/+archive/radeon

    I believe the libdrm from xorg-edgers PPA should work.

    Also, for Jaunty, I recommend using the latest Karmic kernel instead of the 2.6.30 in the PPA.

    EDIT: (mid-air collision) thanks for the feedback, d2xx

    Leave a comment:


  • d2kx
    replied
    Originally posted by bridgman View Post
    The 2.6.30 kernel won't have the drm code you need. Unless there's an edgers build for drm (I don't think so) you'll need to build and install libdrm & kernel modules from ~agd5f/drm r6xx-r7xx-3d branch.
    https://launchpad.net/~xorg-edgers/+archive/radeon

    There is, and I got it working this way.

    In fact, I have been playing some Quake Live matches with the opensource r6xx driver and it ran excellent. How awesome is that?

    Leave a comment:


  • bridgman
    replied
    The 2.6.30 kernel won't have the drm code you need. Unless there's an edgers build for drm (I don't think so) you'll need to build and install libdrm & kernel modules from ~agd5f/drm r6xx-r7xx-3d branch.

    Leave a comment:


  • Domi09
    replied
    I really tried to get the R6xx/r7xx 3D stuff working on Ubuntu 9.04, I compiled all the drivers, mesa and glx, because this did not work somehow, I am now using the PPA Xorg Edgers drivers and kernel 2.6.30. But somehow when I try to activate the composite effects, Xorg restarts.

    Leave a comment:


  • d2kx
    replied
    I for the first time tried the R6xx/R7xx 3D stuff on Kubuntu 9.10 with my AMD Radeon HD 4850 today. The composite performance (KWin desktop effects) is better than fglrx + the 1-2s freezes when maximizing windows/etc. are gone :P It isn't fully stable though (of course).

    Leave a comment:


  • tormod
    replied
    Originally posted by FarJumper View Post
    It looks that libgl1-mesa-dri package (libgl1-mesa-dri 7.6.0+git20090902.dc9de806-0ubuntu0tormod) doesn't have r600 module. Only r200 and r300 are exist.
    Oops, I forgot to add r600 to that package. I uploaded a new right now.

    Leave a comment:


  • agd5f
    replied
    Originally posted by 89c51 View Post
    just a question

    is the infrastructure needed (in the kernel) for Gallium ready??

    and if not in which kernel version is going to be ready??

    thanks
    gallium uses the same ioctls as the kms-enabled ddx and 3d drivers. 2.6.31 has everything you need for r3xx-r5xx, and 2.6.32 will for r6xx/r7xx. However there is not yet an r600 gallium driver.

    Leave a comment:


  • 89c51
    replied
    just a question

    is the infrastructure needed (in the kernel) for Gallium ready??

    and if not in which kernel version is going to be ready??

    thanks

    Leave a comment:

Working...
X