No announcement yet.

Monitor out-of-range after installing fglrx driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • Monitor out-of-range after installing fglrx driver

    My system used to run opensuse11.0 with the fglrx drivers perfectly happily. I had to reinstall due to a dead hard drive, and found that after installing opensuse11.1 I can't get any video after installing the fglrx driver. I have since tried to install 11.0 again and get the same problem, so I don't think it's a difference between 11.0 and 11.1. The card is an AGP ATi Radeon 2600HD Pro.

    My monitor's native resolution is 1024x768 and it runs fine at 60, 70 and 75Hz. With a fresh install of opensuse using radeonhd drivers it displays fine at 1024x768. If I download the ATi driver install run file directly from AMD's site, it runs fine and all appears to have worked. When I run aticonfig ?initial all seems to be OK until I restart X, at which point my monitor shows ?out-of-range?. If I then reboot to runlevel 3 and restore the old xorg.conf that worked fine before the fglrx drivers were loaded, all I get is a blank screen when I start X.

    I have tried quite a few different methods of installing the drivers, and spent a lot of time trying to tweak xorg.conf to get a display with fglrx, and my results are all in a thread on here.

    Given that a known-good xorg.conf still failed after the fglrx drivers went in, can anyone tell me what else has changed? There must be some other configuration files I am missing that went in with fglrx.

    Any help much appreciated.

  • #2
    I don't know how Suse packs its stuff, but, on Gentoo, it's absolutely forbiden to use the AMD/ATI Catalyst installer.
    Doing leads straight to an unstable system, as the Gentoo packaging management links some libraries instead of replacing them (or something like that).

    The question would be : are you sure it's safe to install fglrx from ATI web site ? Wouldn't you use rather some fglrx out of packman ?

    Gentoo as also marked as a dependency of fglrx 9.6 a special release of xorg-server (1.5.3-r7, while the 1.5.3-r6 can't be used with fglrx 9.6). Also is the possibility to use xorg-server 1.6.
    Perhaps, on Suse, is there also some issues between a particular xorg version and fglrx 9.6 ?
    Try downgrade to fgrlx 9.5 or upgrade X to the latest available ?

    Hope this helps


    • #3
      Hi, thanks for the reply.

      I have also tried many times to install the fglrx drivers from the opensuse repositories here: and from the one-click instal option (which is pretty much the same thing) here The result is pretty much the same. See my link above to the other forum thread to see what I've tried so far, but I think my summary in post1 is probably most relevant, since the good xorg.conf file still failed there must be settings elsewhere that are installed by the ATi config script.

      I haven't really thought about compatibility of xorg vs fglrx yet, thanks for the suggestion. I might try to get an earlier version of fglrx and try that.