Announcement

Collapse
No announcement yet.

Mobility Radeon HD 3870 / M88 drivers... :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mobility Radeon HD 3870 / M88 drivers... :(

    Been trying to get this damn thing to work for days now. I bought this Alienware laptop thinking it will last me a while and I'll orgasm every time I boot it up.

    Long story short, I know not to use the proprietary drivers. I installed Jaunty 64bit first, struggled, switched to Intrepid, struggled even more, and now I'm back to Jaunty 64bit. At least the failsafe settings actually are fail safe...

    I tried Intrepid to see if 9.3 drivers + older Xserver would work, but I couldn't get it to work. Thought about going way back to Hardy, but I figured at least I'm seeing the login screen with Jaunty (and correct monitor resolution), so whatever...

    In any case, I am trying to use the radeonhd drivers since I saw that support for M88 cards has been added. I couldn't find anything about regular radeon drivers working with the card, so I went with the hd "version". Can't get it to work, tried the regular radeon, can't get it to work either.

    For the record, this is what I have done to install the radeonhd drivers:

    https://help.ubuntu.com/community/RadeonHD

    I've messed with all kinds of settings in my xorg.conf file, but it seems that only vesa will actually do anything. At this point all I want is 2D support, so that I can at least keep making my crappy little 2D gravity simulator and not have it run choppy on a $1700 machine... I was hoping to upgrade it to 3D over the summer by using OpenGL via SDL, but I guess I'll either have to wait for Karmic or use Vista.

    Oh, I'm not dead set on Ubuntu, either. I'm willing to try another distro if for some reason it has some sort of magic code in there or something. I tried Archlinux once, didn't go so hot, but I'd be willing to try a different distro again no problems. Unless, of course, going back to Intrepid or Hardy is the better choice. I'd do that too, no problems.

  • #2
    Well, I have an update. I installed the new 2.6.30 kernel, and using the radeon drivers works now. glxgears gives ~400fps, which is over twice as good as vesa's ~165fps.

    So it's not perfect yet, but beggers can't be choosers. I'm still really grateful that there are people who work on open source stuff on their own time.

    I guess I'll have to stick with this for now, unless anybody knows of anything better I could try.

    Comment


    • #3
      Poop Loops, you should have the open source drivers configured automatically (using radeon plus 6xx/7xx drm support backported to the Jaunty 2.6.28 kernel) as part of the Jaunty installation. If that doesn't work for you, please let us know what happened and consider filing a bug against Jaunty.

      What happened with the Catalyst driver ? Did you install by building packages and run aticonfig --initial before starting X ?

      Comment


      • #4
        @bridgman

        It is impossible to compile fglrx against a pure 2.6.30 kernel without this KERNEL patch:

        Code:
        diff --git a/arch/x86/mm/tlb.c b/arch/x86/mm/tlb.c
        index 61ddfa0..3d26c0b 100644
        --- a/arch/x86/mm/tlb.c
        +++ b/arch/x86/mm/tlb.c
        @@ -279,6 +279,7 @@ void flush_tlb_page(struct vm_area_struct *vma, unsigned long va)
        
                preempt_enable();
         }
        +EXPORT_SYMBOL(flush_tlb_page);
        
         static void do_flush_tlb_all(void *info)
         {
        I definitely mentioned that long before 2.6.30 final release. It is up to a ATI developer to submit that patch (because the binary part is compiled against it). Even with all known tricks used fglrx does not really work good with 2.6.29+ - dmesg is flooded with lots of messages every time you run a 3d app. So do what Nvidia does and provide at least OFFICAL patches if you don't manage to fix it in time for a full driver release. Also due to your stupid decision to drop fglrx support for older devices you have to provide a workaround for 9-3 or create a new driver for all those devices.

        Comment


        • #5
          Understood... but Jaunty uses 2.6.28, doesn't it ?

          Comment


          • #6
            It does, but read correctly that HE did install 2.6.30.

            Comment


            • #7
              Agreed. I guess we're talking about different points in the story - I was trying to find out what happened on the original install of Jaunty, since nothing else should have been required to use the open source drivers.

              EDIT - I have updated the radeonhd 6xx/7xx instructions to mention that Jaunty includes suitable drm code out-of-the-box.

              I'm guessing that following the installation instructions for radeonhd ended up over-writing the original drm and that the upgrade to 2.6.30 was to get a 6xx/7xx-friendly drm back. Reverting the libgl1-mesa-dri package should have done the same thing - I think - and also allowed unmodified fglrx to work. Just guessing though...
              Last edited by bridgman; 06-16-2009, 07:54 PM.

              Comment


              • #8
                @ Kano
                Here we go again. What part of "we do not support pre-release kernels" don't you get? Support for 2.6.29 is down the line, so don't even start. This being the case, why should ATI provide patches? If users want to use the driver with other kernels, they can do the patches on their own.

                @ Poop Loops
                If you want to use fglrx (which is advisable, given all the money you spent on that lappy) you need to go back to Jaunty's stock kernel.
                The easiest way to get the driver working is with Ubuntu's own installation tool; go to System>Administration and click on "Hardware Drivers". This will install the 9.4 drivers.
                If you want the latest 9.6 you have a couple of options. Either should work, but this is what works best for me (it's a copy/paste from a guide I have on another forum, so mind the editing):

                1.- Got to ATI's website and donwload the driver. The same installer works for both 32bit and 64bit systems.

                2.- Open a terminal and move into the directory where you saved the driver in:

                Code:
                cd /<location of driver>
                3.- Install needed dependancies:

                Code:
                sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms  
                
                #install ia32-libs if on a 64bit system
                4.- Run the installer:

                Code:
                sudo sh <name of .run file>.run
                
                #alternatively, you can simply run ati*.run
                5.- A graphical interface should pop up. Just accept the defaults and let it finish. Once dropped back into the terminal (make sure no errors where given during the process):

                Code:
                cd
                sudo aticonfig --initial
                6.- Reboot

                Comment


                • #9
                  When I first installed Jaunty on this thing, I went to System > Hardware Drives and installed what it recommended. I rebooted to a black screen.

                  I did find instructions later that just told me to

                  sudo apt-get --reinstall xorg-drivers-fglrx
                  sudo aticonfig --initial
                  sudo aticonfig --Overlay-type=Xv (or something like that)

                  And that worked, but even browsing the web with Firefox gave choppy scrolling.

                  I did try to install the drivers manually via

                  http://wiki.cchtml.com/index.php/Ubu...ivers_manually

                  But that didn't work, either. I think I used 9.5 that time, and when I installed Intrepid I tried the 9.3 drivers, because I figured my card was on the list of "legacy" cards now. I'm guessing you're all saying it isn't?

                  Should I still try the 9.6 drives? If so, should I use the stock kernel? If so, then is it enough to boot to the stock kernel, install there, and just use that one and ignore the newer kernel boot?

                  Comment


                  • #10
                    Originally posted by Poop Loops View Post
                    I think I used 9.5 that time, and when I installed Intrepid I tried the 9.3 drivers, because I figured my card was on the list of "legacy" cards now. I'm guessing you're all saying it isn't?
                    If the card indeed has a RadeonHD 3870 chip, it definitely isn't considered legacy by anyone.

                    Comment

                    Working...
                    X