Announcement

Collapse
No announcement yet.

TTM, Radeon KMS Pull Request Goes In

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Jeah, thank you Linus.
    http://git.kernel.org/?p=linux/kerne...e8d11dea0ccceb

    Comment


    • #22
      Originally posted by mattst88 View Post
      I meant libdrm -- has the modesetting-gem branch been merged into master?
      It has been merged, use libdrm master branch, but be sure to configure with --enable-radeon-experimental-api

      Comment


      • #23
        I'm having the same problem:
        Code:
        (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
        [dri] radeon.o kernel module version is 2.0.0 but version 1.17.0 or newer is needed.
        I have:
        -kernel 2.6.31-rc1-git2
        -mesa from master
        -libdrm from master with --enable-radeon-experimental-api
        -xf86-video-ati from kms-support
        -xorg-server 1.6.1.901

        what else do i miss?
        thanks

        Comment


        • #24
          Originally posted by slacker View Post
          I'm having the same problem:
          Code:
          (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
          [dri] radeon.o kernel module version is 2.0.0 but version 1.17.0 or newer is needed.
          I have:
          -kernel 2.6.31-rc1-git2
          -mesa from master
          -libdrm from master with --enable-radeon-experimental-api
          -xf86-video-ati from kms-support
          -xorg-server 1.6.1.901

          what else do i miss?
          thanks
          OK, let's try to get you out of this.

          First of all, you need to check KMS is working :
          - stop X11
          - # modprobe radeon modeset=1

          It should change your screen resolution to its native one.

          If this works, it means you did well on the kernel side.

          You may have not respected the compilation order:
          - libdrm with --enable-radeon-experimental-api.
          - xf86-video-ati from kms-support
          - mesa master

          This should work. If it doesn't, you may want to get the latest kernel from git. Yesterday, Linus merged some DRM fixes, it may help.

          Good luck !

          Comment


          • #25
            Originally posted by M?P?F View Post
            OK, let's try to get you out of this.

            First of all, you need to check KMS is working :
            - stop X11
            - # modprobe radeon modeset=1

            It should change your screen resolution to its native one.
            it's already the native one: it switches to the native resolution during the boot process.

            Originally posted by M?P?F View Post
            You may have not respected the compilation order:
            - libdrm with --enable-radeon-experimental-api.
            - xf86-video-ati from kms-support
            - mesa master
            Ok, done.

            Originally posted by M?P?F View Post
            This should work. If it doesn't, you may want to get the latest kernel from git. Yesterday, Linus merged some DRM fixes, it may help.
            I just pulled git3, which has all the drm fixes.
            But it still doesn't solve the problem
            Someone on irc mentioned that I could have some old headers somewhere, but how would I find them? Anyway I don't think this is the case because I'm using gentoo ebuilds.
            Thanks for your help

            Comment

            Working...
            X