Announcement

Collapse
No announcement yet.

Getting Open Source 3D graphics on R6XX/R7XX cards (NO FGLRX)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • sovok_kpss
    replied
    Does hibernation(TuxOnIce) still don't work with KMS?

    Leave a comment:


  • aljaz
    replied
    Originally posted by h3xis View Post
    This worked. Thank you so much. The only thing now that concerns me is I'm getting a warning that displays before radeon loads that says (II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting. I feel that I should have mentioned earlier that I'm building all of this for r300 - not r600/700. What is KMS and do I need it for r300? I did enable it in my kernel as the first post says to do. Does this error mean that it's not enabled, when it should be? When I run ./autogen.sh --prefix=/usr for xf86-video-ati, I see somewhere that it says checking for XEXT... no. Is this bad/important? It does say "yes" next to kernel modesetting as well. And last, what is OSMesa and do I need it? I have it installed under Debian, but when I run the autogen.sh script it says "no" next to it.
    KMS=kernel modesetting. And no, you don't really need it unless you have multiple concurrent users on the same computer. Under KMS every user has DRI enabled as opposed to without KMS option (this is why it's useful to me).

    Apart from that, you're in the wrong thread. This one talks about R6XX/R7XX. But anyway, it should be the same for R300 and below, because I use the same guide for a laptop with a R1XX. I only leave out the --with-dri-drivers=r600, which under the latest mesa git you shouldn't even need anymore.

    So why don't you have KMS? Have you checked all your kernel options from the guide - they have to be exactly like written in the guide? Did you disable KMS via grub (radeon.modesett=0)?

    For mesa and dri and stuff you should find a wiki.

    Leave a comment:


  • h3xis
    replied
    Originally posted by aljaz View Post
    What updates? If you compile mesa/drm, etc, then any update from debian repositories will rewrite your compilations. That will be until Debian unstable/testing update to the latest mesa and drm releases. If that is the case, you have to again install mesa and drm from git.

    If that is not the case, try with the latest 2.6.33-rc2. Don't forget to put the interrupts firmware under /lib/firmware/radeon.

    I recently did this. You have to set these 3 lines in kernel config to:
    CONFIG_FIRMWARE_IN_KERNEL=y
    CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/R700_rlc.bin"
    CONFIG_EXTRA_FIRMWARE_DIR="firmware"

    Build, run and report.
    This worked. Thank you so much. The only thing now that concerns me is I'm getting a warning that displays before radeon loads that says (II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting. I feel that I should have mentioned earlier that I'm building all of this for r300 - not r600/700. What is KMS and do I need it for r300? I did enable it in my kernel as the first post says to do. Does this error mean that it's not enabled, when it should be? When I run ./autogen.sh --prefix=/usr for xf86-video-ati, I see somewhere that it says checking for XEXT... no. Is this bad/important? It does say "yes" next to kernel modesetting as well. And last, what is OSMesa and do I need it? I have it installed under Debian, but when I run the autogen.sh script it says "no" next to it.
    Last edited by h3xis; 12-25-2009, 08:07 PM.

    Leave a comment:


  • rjwaldren
    replied
    quoted - "Is there anybody running Debian testing/unstable who can no longer get this to work?"

    I'm having the same or similar problem with Lucid on my hd4850 - Since around the time the interrupt patches made it into the kernel tree. The current 2.6.32-9.13 kernel from Ubuntu works fine with KMS enabled, it looks to have drm upto the .32 release plus a few backported patches. The latest Ubuntu kernels from the mainline along with a custom compiled DRM-Radeon-Testing applied to Linus' git and Ubuntus 32-9.13 git source have all failed the same way. The remainder of the stack is the lastest (tried both Edgers-PPA and git compiles) and does not appear to be the problem.

    I've been busy with other things so I haven't been trying to chase it down lately. When radeon modprobes on the newer kernels the screen immediately blanks (as though the HMDI output is disabled). This occurs with both UMS or KMS. SSHing in, dmesg shows the driver probed and loaded the firmwares with out error and reports that it's switching to a massive console mode (? 267x67). And Xorg.0.log looks like everything is going fine (detected modes look good,etc) and it selects the usual 1920x1080 mode. But the log just stops after that, haven't seen any errors reported aside from the failure to actually produce output.

    Like I said the current 32-9.13 kernel along with the latest libdrm, mesa, DDX works great. So I've just been using that and checking every couple of days to see if the kernel (X server) issue is resolved. If rc2 is out now, I should be able to try it and collect some logs this w/e.
    Last edited by rjwaldren; 12-25-2009, 01:55 PM.

    Leave a comment:


  • aljaz
    replied
    Originally posted by h3xis View Post
    Is there anybody running Debian testing/unstable who can no longer get this to work? For the longest time, this guide has always worked and ever since I installed a bunch of updates, it doesn't. I'm running 2.6.32 and I get the error: "(EE) Screen(s) found, but none have a usable configuration." And then it says something else about no video modes being available, even though I have them set. I wish I could figure out what package broke all of this, but I have no idea which one it is. I know this is a pretty vague problem, but again, I'm just wondering if anyone else has experienced this and/or what I can do to resolve it.
    What updates? If you compile mesa/drm, etc, then any update from debian repositories will rewrite your compilations. That will be until Debian unstable/testing update to the latest mesa and drm releases. If that is the case, you have to again install mesa and drm from git.

    If that is not the case, try with the latest 2.6.33-rc2. Don't forget to put the interrupts firmware under /lib/firmware/radeon.

    I recently did this. You have to set these 3 lines in kernel config to:
    CONFIG_FIRMWARE_IN_KERNEL=y
    CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/R700_rlc.bin"
    CONFIG_EXTRA_FIRMWARE_DIR="firmware"

    Build, run and report.

    Leave a comment:


  • h3xis
    replied
    Is there anybody running Debian testing/unstable who can no longer get this to work? For the longest time, this guide has always worked and ever since I installed a bunch of updates, it doesn't. I'm running 2.6.32 and I get the error: "(EE) Screen(s) found, but none have a usable configuration." And then it says something else about no video modes being available, even though I have them set. I wish I could figure out what package broke all of this, but I have no idea which one it is. I know this is a pretty vague problem, but again, I'm just wondering if anyone else has experienced this and/or what I can do to resolve it.

    Leave a comment:


  • stardancer
    replied
    Easier way for Ubuntu Users

    Thank you so much for this thread! Compiz on my Radeon HD 2400 XT without fglrx! Hooray!

    For ubuntu users, and possibly others depending on if your distribution rolls out a package for it, there is a way to avoid the kernel compilation (first 4 steps). To do this, install the drm-next kernel.

    - Go to http://kernel.ubuntu.com/~kernel-ppa...-next/current/
    - Download the linux-image for your arch (64bit or 32bit), linux-headers (all), and linux-headers for your arch.
    - Install those three packages
    - Make sure in /etc/grub/menu.lst that you are booting the drm-next kernel
    - reboot

    Now you can go straight to step 5 of this post (after the kernel compilation).

    Thanks again!

    Leave a comment:


  • stardancer
    replied
    Easier way for Ubuntu Users

    Thank you so much for this guide! Compiz on my Radeon HD 2400XT without fglrx! How much of my life have I spent trying to get fglrx to work over the years only to have it break again a few months later...

    Anyway, for ubuntu users (and maybe others if your dist rolls out a package for this) you can skip the kernel recompile if you use the drm-next kernel. Ubuntu can download it here: http://kernel.ubuntu.com/~kernel-ppa...-next/current/

    Download the linux-image for 32-bit or 64-bit, linux-headers***all, and linux-headers for 32-bit or 64-bit. Install those three packages. Then skip directly to step 5 in the guide (you don't need to build your own kernel).

    Thanks again! Hooray!

    Leave a comment:


  • Duhorigh73
    replied
    Getting Open Source 3D graphics on R6XX/R7XX cards NO FGLRX

    Hi All,

    Can i know has anybody tried any open source tool for migration from Documentum to Vignette database ?
    If yes, then post some ideas how we can achieve that migration.

    Leave a comment:


  • Neo_The_User
    replied
    thanks for the tips and feedback. guide now fixed with the two slashes.

    Leave a comment:

Working...
X