Announcement

Collapse
No announcement yet.

catalyst 9.5 seems to be out.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 9.5 is now officially out.

    Comment


    • Ha ha! They've just copied the 9.4 release notes for 9.5, lol.

      https://a248.e.akamai.net/f/674/9206...t_95_linux.pdf

      and

      https://a248.e.akamai.net/f/674/9206...t_94_linux.pdf

      are identical xD I think it appears AMD's Catalyst for Linux department is heavily understaffed...

      Comment


      • Well i did not find a fix too, but the amdcccle reports 8.61.2.

        Comment


        • well, it fixed at least one bug for me. So it is an improvement.

          Comment


          • Originally posted by RealNC View Post
            Ha ha! They've just copied the 9.4 release notes for 9.5, lol.

            https://a248.e.akamai.net/f/674/9206...t_95_linux.pdf

            and

            https://a248.e.akamai.net/f/674/9206...t_94_linux.pdf

            are identical xD I think it appears AMD's Catalyst for Linux department is heavily understaffed...
            I checked on this; looks like the 9.5 release notes aren't quite finished yet.

            Release notes are generated by the same team for all OSes.
            Test signature

            Comment


            • Originally posted by energyman View Post
              I say:
              YAY!

              the composite (kde effects turned on)+xv = lockup bug is fixed!
              Also:
              OpenGL version string: 2.1.8664
              OpenGL shading language version string: 1.30
              ++

              unfortuntaly it still seems to lock up with kde 4 compositing + opengl accelerated video

              Comment


              • Originally posted by bridgman View Post
                Some people just don't see tearing. Others hardly notice anything *but* the tearing.

                It's fun to watch when you get one of each type standing in front of a test system watching video.
                don't see it either

                if it's there it's very subtle

                the hardlock problem when restarting the X-server (e.g. stopping gdm manually and then restarting it) is still there

                it also is triggered when starting X, stopping it, unloading fglrx, re-installing it / upgrading to a newer version, loading the kernel-module and starting X

                ==> 100% reliable hardlock

                Originally posted by Kano View Post
                fglrx unloading is really much more problematic than unloading nvidia, even when you unload radeon drm (from oss driver) and start fglrx without reboot i had serveral cards which locked up the system then. kill -9 kdm certainly helps a bit, also

                /etc/init.d/atieventsd stop

                can be good to do before kdm stop.
                good to know

                thanks !



                any ETA when that will be fixed ?

                thanks !
                kernelOfTruth
                Senior Member
                Last edited by kernelOfTruth; 19 May 2009, 02:43 PM.

                Comment


                • Originally posted by Kano View Post
                  @RealNC

                  You example video even shows extreme tearing with the oss driver in the upper area which is usually black with 16:9 movie...
                  No problems with the OSS radeon driver here, r500 and latest from sid. Very smooth. I will always thank the guys for fixing this. Besides they rewrote the code for Xv recently. They are at least doing something unlike the official driver developer, who can't get GPU accelerated video for what, 7 months now?

                  Comment


                  • here's a link referring to a patch by the dudes from SabayonLinux that should fix the stupid error messages with 2.6.29 (acpi-related stuff that is missing):

                    http://pastebin.com/f3fd70478

                    update:

                    ok - I don't know what this patch really is supposed to do but it hardlocks my box or at least leads to a black screen (Asus EAH Radeon HD 4850)

                    if it works for you - fine; it doesn't for me
                    kernelOfTruth
                    Senior Member
                    Last edited by kernelOfTruth; 19 May 2009, 02:58 PM.

                    Comment


                    • Originally posted by kernelOfTruth View Post
                      ++

                      unfortuntaly it still seems to lock up with kde 4 compositing + opengl accelerated video
                      What hardware/Bus/OS/kernel/X?

                      Comment

                      Working...
                      X