Announcement

Collapse
No announcement yet.

FOSS driver and X800

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • JonC
    started a topic FOSS driver and X800

    FOSS driver and X800

    Hi. I've been following the articles covering the Free driver development, great stuff.

    I recently upgraded from a 9250 to an x800 (after issues with the old AGP motherboard...). I've got int working nicely, except that glxgears runs at ~70% CPU and ActionCube / Sauerbraten run so slow they are unplayable. DRI is enabled, and I've tried numerous xorg.conf arrangements.

    Is there anyone who uses the Free driver and an x800 who can give me some advice and a peak at their xorg.conf?

    Cheers
    =========
    Using Mesa 6.5.1, Xorg 7.1, radeon driver on fedora core 6.

  • JonC
    replied
    Updating didn't help, and my x800 has packed in. So I won't be investigating further.

    Leave a comment:


  • JonC
    replied
    Just so people know, it looks like some of the functions for openGL haven't been implemented. A quick example is that some openGL screen savers are smooth as anything, while others are crippled and barely run.

    I'll try updating mesa to the latest git and post back any results.

    Leave a comment:


  • Michael
    replied
    Originally posted by JonC View Post
    Honestly, thanks for being so helpful, it is really appreciated.
    You're welcome; thanks for the kind comments. Be sure to come back to the Phoronix Forums!

    Leave a comment:


  • JonC
    replied
    Thanks Michael, I will.

    Honestly, thanks for being so helpful, it is really appreciated.

    Leave a comment:


  • Michael
    replied
    Try contacting Kurtis Kesler at [email protected]

    He is a Sauerbraten developer (or something to that effect) and I had talked with him last year about Sauerbraten and ATI.

    Leave a comment:


  • JonC
    replied
    OK, thanks.

    Now all I need to do is find out what on earth is causing ActionCube and Sauerbraten to go to software mode, and I'll be set.

    Thanks very much.

    Leave a comment:


  • Michael
    replied
    Originally posted by JonC View Post
    Hi, thanks.

    I tried those options a while ago. Some things improve performance, some degrade it, but always it runs at about 70% CPU just doing glxgears.

    Is this normal or is it dropping something back to software acceleration?
    It's normal. As long as in games you are having acceleration, you should be set. Even when I run glxgears with the fglrx drivers the CPU will spike to full load as glxgears is really CPU dependent and really doesn't do much for modern GPUs.

    Leave a comment:


  • JonC
    replied
    Hi, thanks.

    I tried those options a while ago. Some things improve performance, some degrade it, but always it runs at about 70% CPU just doing glxgears.

    Is this normal or is it dropping something back to software acceleration?

    Leave a comment:


  • yoshi314
    replied
    i think i'll put my x300 back in and try with those settings.

    i had problems when experimenting with aiglx on free driver - slowness and lots of screen corruptions.

    some people claim that exa is way faster with those drivers. but i don't think it's safe to use yet.

    Leave a comment:

Working...
X