Announcement

Collapse
No announcement yet.

Random freeze and lockups with ati-6.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Random freeze and lockups with ati-6.10

    I'm using the default driver in Fedora 10, but still get the random freeze/lockup in my laptop (RS690M based), consistent lockup occurs when using Cairo-Dock and other graphics apps. Apparently this still has to do with EXA acceleration, but I also have seen these happen with XAA. Any pointers?

  • #2
    Are you running with KMS and memory management, or with nomodeset ?
    Test signature

    Comment


    • #3
      There were some issues with the accel code in the ddx that recently came to light. Your best bet it to try ati git master.

      Comment


      • #4
        As far as I am aware, yes, I am running with KMS. I have no other options passed to the kernel regarding graphics (APIC is a whole other story due to the laptop's BIOS).

        I'm not sure what do you mean about memory management (TTM/GEM?), and I do not know how to check for those (Xorg.log, maybe?)

        I tried recently to revert back to XAA, however for some reason when I start X with the modified xorg.conf file (Option "AccelMethod" "XAA") I get no X display at all... And the system seems to be in a frozen state, maybe I'm using a malformed xorg.conf file, Fedora 10, as many other modern distributions does not rely any longer on an xorg.conf file for the display's configuration, but you can override the auto configuration with one, however, I may seem to be using a malformed one. Should I use "ati" as the driver or "radeon" directly? I'm guessing the file I'm using is missing some parts (location of Xorg modules, etc), will try later.

        Comment


        • #5
          Is it a hard lockup? If so, it's probably the same I've been getting for ever: http://bugs.freedesktop.org/show_bug.cgi?id=16198
          (Currently testing the last patch attached there)

          Comment


          • #6
            With the 6.10 driver I'm getting a strange problem. I do not seem able to use the XAA AccelMethod any more, I see a message in Xorg.0.log regarding XAA and r300 and upwards not supporting this type of acceleration.

            Comment


            • #7
              6.10 is pretty old now, might be worth updating to latest in git. A number of acceleration issues were fixed in between the two.

              The XAA message just says that Render acceleration is not supported with XAA -- agd5f only added Render accel to EXA. The change was not "taking render accel away from XAA" but "adding render accel to EXA" (in early 2008).
              Test signature

              Comment


              • #8
                I see... It's been a while since I last used git to update the driver, is there a place where the instructions are posted (so you don't have to post them again?)

                Comment


                • #9
                  http://www.botchco.com/agd5f/?page_id=2

                  Comment


                  • #10
                    Thanks a lot, agd5f.

                    Edit

                    Hmm... I'm having a bit of trouble configuring the driver, it seems... I get this output in the console when the configure part of autogen.sh --prefix=/usr (or ./configure --prefix=/usr, for that matter) is running:

                    Code:
                    checking for gcc... (cached) gcc
                    checking whether we are using the GNU C compiler... (cached) yes
                    checking whether gcc accepts -g... (cached) yes
                    checking for gcc option to accept ISO C89... (cached) none needed
                    checking dependency style of gcc... (cached) gcc3
                    ./configure: line 20833: syntax error near unexpected token `XINERAMA,'
                    ./configure: line 20833: `XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)'
                    Last edited by Thetargos; 08 May 2009, 03:19 PM.

                    Comment

                    Working...
                    X