No announcement yet.

Xpress 200M problems... again

  • Filter
  • Time
  • Show
Clear All
new posts

  • Xpress 200M problems... again

    I have Xpress 200m card and recently upgraded my system to Jaunty. 3D now is very slow. Although Compiz is working fine, I can not play any 3D games. Even PPracer is very slow (7-9 FPS).
    Glxgears in Jaunty:
    1454 frames in 5.0 seconds = 290.765 FPS
    1737 frames in 5.0 seconds = 347.231 FPS
    1365 frames in 5.1 seconds = 269.623 FPS
    1718 frames in 5.0 seconds = 343.483 FPS
    I had above 1100 FPS in 8.10 with 6.12.1 OS driver from git.
    Today, I tried Fedora 11 LiveCD - the same problem. Glxgears gave only 140 FPS.
    I know that this is not the best place to post a bug report, but I am waiting for the perfect driver for this card for more than 2 years and ATI stopped supporting our cards. So, OS driver is only option for us. (I think it is too early for me to buy a new laptop).
    You can find my bug report here:
    Thank you for any help.

  • #2


    • #3
      I am back

      Alex, thank you very much for this link.
      I patched r300_context.c and now I am back:
      5655 frames in 5.0 seconds = 1130.871 FPS
      5656 frames in 5.0 seconds = 1131.106 FPS
      5654 frames in 5.0 seconds = 1130.648 FPS

      I am happy again.


      • #4
        Mesa regression in R300

        I am still trying to improve the 3d performance of my Xpress 200M in Ubuntu 9.04. Recently, Maciej Cencora introduced the set of patches to the radeon-rewrite branch that should solve the problem with R300 regression. I compiled this Mesa version, installed it and got the hard lockups of the system in some 3d games: etracer, nexuiz – a black window with the cursor in the left-up corner. However, Compiz works fine. Here what I did:
        1) downloaded the last version of radeon-rewrite;
        2) ./ --prefix=/usr;
        3) make;
        4) sudo make install; and restarted the system.
        I noticed that the libs were installed in the correct position. I also tried the last libdrm from xorg-edgers.
        Did I miss something or the new mesa stuff is still not ready for this card?
        Thank you.

        PS We are urgently waiting for a solution since fglrx does not support these cards in 9.04.

        EDIT: I forgot to mention that the solution mentioned in the second post does not work either - it lockups the system after few minutes in the game.
        Last edited by sergus; 28 April 2009, 02:59 PM.


        • #5
          Please file bug reports ( for apps that don't work with radeon-rewrite so we can get them fixed.


          • #6
            Ok. I will post the bug report. But I first want to be sure that I correctly installed the Mesa stuff. Did I?


            • #7
              Originally posted by sergus View Post
              Ok. I will post the bug report. But I first want to be sure that I correctly installed the Mesa stuff. Did I?
              Sounds like you did.


              • #8
                Sorry. My fault. I had "EnablePageFlip" "on" in my xorg.conf. This option worked fine in Mesa 7.4 but hangs the system completely in radeon-rewrite. Should I report this as a bug for mesa?

                Without PageFlip, 3d works fine but the performance is still not great:
                etracer 6-10 FPS (almost unplayable);
                nexuiz 5-8 FPS (unplayable);
                glxgears is Ok (~1100 FPS).

                Anyway, thank you guys for your work.
                Last edited by sergus; 29 April 2009, 04:00 AM.


                • #9

                  Please, can you post a step-by-step instructions for this? My Xpress200m and Jaunty drives me crazy...



                  • #10
                    Sorry for bumping this thread, but i really need your help. I've googled the net for hours, but can't find the info i need to make my XPress 200m useable with Jaunty...