No announcement yet.

AMD Pushes Out New R600/700 3D Code

  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Yeah, I got glxinfo running:

    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: Mesa DRI R600 20090101 x86/MMX+/3DNow!+/SSE2 TCL
    OpenGL version string: 1.4 Mesa 7.5-devel
    For some reason the preprocessor didn't replace DRI_CONF_FP_OPTIMIZATION_SPEED with what it's defined to be, so I just replaced it myself with 0.
    Also I had to add my chip id to radeon_set_screen_flags(). Note to AMD: 0x9610 is also an RS780!

    glxgears now locks up the X server after printing some numbers related to pixel and vertex shaders .


    • #42
      Richard pushed a couple of updates earlier today. The "clear" code is still broken but that's next on his list.


      • #43
        Originally posted by bridgman View Post
        Richard pushed a couple of updates earlier today.
        Yeah, I noticed. I have subscribed to the git rss feed The headline "redbook hello can run" grabbed my attention. Unfortunately just like glxgears it locks up the X server here.


        • #44
          Hmm... I know it still needs work but I don't think it should be locking up the X server. I have pinged the devs for comment...

          EDIT - Richard said that glxgears *does* hang the system (he's working on that) but he wouldn't expect the Redbook "Hello" program to do that. There is some corruption in "Hello" because the clear code is stubbed out though.

          Just checking, are you using the latest drm from the r6xx-r7xx-3d branch of ~agd5f/drm ? Last change was about 6 days ago but Bad Things will happen with older code.

          EDIT - Richard also mentioned that he is using Option "AccelMethod" "None" for testing right now, in case that helps.
          Last edited by bridgman; 05-19-2009, 04:12 PM.


          • #45
            I do have the latest drm from agd5f's 3d branch installed. AccelMethod none doesn't do anything here, I still get normal 2D acceleration and Xv and a lock up with the redbook hello program. Maybe Richard is using radeonHD?

            Instead of immediately rebooting after a lock up, this time I waited some time hoping that the server would resume normal operation after a while
            It didn't...but if it's of any use my dmesg got spammed with a lot of:

            [drm] wait for fifo failed status : 0xA02034AC 0x00000003
            Edit: RadeonHD doesn't seem to work with agd5f's drm. No acceleration at all and Mesa Software Rasterizer.
            Last edited by monraaf; 05-20-2009, 01:08 AM.


            • #46
              So I was experimenting a little more, added the following options to xorg.conf:

              Option "EXANoComposite" "true"
              Option "EXANoUploadToScreen"
              Option "EXANoDownloadFromScreen"
              Option "MigrationHeuristic" "greedy"
              ...and added a printf statement after the glFlush() from hello.c. Now I launched the hello program from a terminal and alt-tabbed between the terminal and the hello window. Each time I uncovered the hello window the text I put in the printf statement was printed to the terminal but besides the decoration put on by the window manager the hello window remained completely transparent. After a while the hello program segfaulted and about a half minute later the X server finally locked up.
              Last edited by monraaf; 05-20-2009, 01:50 AM.


              • #47
                Update: I managed to get RadeonHD working with the drm. I totally forgot that RadeonHD needs Option "DRI" "on" in the xorg.conf... With RadeonHD and Option "AccelMethod" "None" in the xorg.conf the X server doesn't lock up anymore.

                The hello program still doesn't look how it's intended to be though, still a lot of transparency.

                Last edited by monraaf; 05-21-2009, 01:36 AM.


                • #48
                  None of these xorg.conf changes work for me, except the accelmethod none which slowed window dragging and mousewheel scrolling to annoying levels.

                  I thought I did the git clone...git pull...and git checkout stuff but I must not have. I know this does not support the 780g (hd3200) yet with 3d but I thought I'd try it out.

                  So far 2D acceleration seems to be much better than previous ati or radeonhd.

                  When I cd into mesa and do git branch, I see master and then have an asterisk in front of radeon-rewrite. What do I need to play along? In meantime I'll try to git checkout the r6xxx ones.


                  • #49
                    ASUS AH3650 a.k.a. ATI Radeon HD 3650 512M :

                    if I use radeonhd driver scrolling in Firefox is painfully slow, line by line with redraw every time.

                    I'm up to date to tormod and sarvatt ppa's ... I've tried with 2.6.30-rc{6,7} but no help ...

                    It doesn't happen with radeon driver.

                    any help?

                    When we can expect some breakthrough in 2D and 3D for this (R635) engine ...? compiz ... ?
                    Last edited by zika; 05-24-2009, 04:01 AM.


                    • #50
                      Why do you want to use radeonhd? Use radeon if it doesn't have this problem. Radeonhd should die after adding audio over hdmi support to radeon imho.